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Katello 3.13 Installation

These instructions are for installing Katello 3.13, but the latest stable is 3.18.

Note: After installation of Katello, be sure to trust Katello's CA certificate on your system. This is required for the encrypted
NoVNC connections. You will find katello-server-ca.crt in the /pub directory of your Katello server (e.g.

http://katello.example.com/pub/katello-server-ca.crt ).

Important Note for Existing Installations

Katello does not currently support installation on existing Foreman deployments. DO NOT attempt to install Katello on an
existing Foreman deployment, unless you are a Foreman developer and willing to debug the broken configuration that will



result from attempting an install on existing system.

Hardware Requirements

Katello may be installed onto a baremetal host or on a virtual guest. The minimum requirements are:

e Two Logical CPUs
® 3 GB of memory (12 GB highly recommended)
® The filesystem holding /var/lib/pulp needs to be large, but may vary depending on how many different Operating
Systems you wish to syncronize:
o Allocate 30 GB of space for each operating system. Even though an operating system may not take up this much
space now, this allows space for future updates that will be syncronized later.
® The path /var/spool/squid/ is used as a temporary location for some types of repository syncs and may grow to consume
10s of GB of space before the files are migrated to /var/lib/pulp. You may wish to put this on the same partition as
/var/lib/pulp.
® The filesystem holding /var/lib/mongodb needs at least 4 GB to install, but will vary depending on how many different
Operating Systems you wish to syncronize:
o Allocate around 40% of the capacity that has been given to the /var/lib/pulp filesystem
® The root filesystem needs at least 20 GB of Disk Space

Required Ports

The following ports need to be open to external connections:

® 80 TCP - HTTP, used for provisioning purposes

® 443 TCP - HTTPS, used for web access and api communication

® 5647 TCP - qdrouterd - used for client and Smart Proxy actions

® 9090 TCP - HTTPS - used for communication with the Smart Proxy

Production

Katello provides a puppet based installer for deploying production installations. Production installations are supported on the
following OSes:

0s
CentOS 7 X
RHEL 7 X

Katello can only run on an x86_64 operating systems.

Installation may be done manually or via our recommended approach of using forklift.

Required Repositories

Select your Operating System: H Red Hat Enterprise Linux 7 j

nkn

subscription-manager repos --disable
subscription-manager repos --enable rhel-7-server-rpms
subscription-manager repos --enable rhel-7-server-optional-rpms
subscription-manager repos --enable rhel-7-server-extras-rpms
yum install -y yum-utils

yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.13/katello/el7/x86_64/katello-repos-latest.rpm
yum -y localinstall https://yum.theforeman.org/releases/1.23/el7/x86_64/foreman-release.rpm

yum -y localinstall https://yum.puppet.com/puppet6-release-el-7.noarch.rpm

yum -y localinstall https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum -y install foreman-release-scl

Installation

After setting up the appropriate repositories, update your system:

yum -y update

Then install Katello:



yum -y install katello

At this point the foreman-installer should be available to setup the server. The installation may be customized, to see a list of
options:

foreman-installer --scenario katello --help

Note

Prior to running the installer, the machine should be set up with a time service such as ntpd or chrony, since several Katello features
will not function well if there is minor clock skew.

These may be set as command line options or in the answer file (/etc/foreman-installer/scenarios.d/katello-answers.yaml).
Now run the options:

foreman-installer --scenario katello <options>

Multiple subnets and domains

The installer only supports one subnet and one DNS domain via command line arguments. Multiple entries can be entered via
/etc/foreman-installer/custom-hiera.yaml file:

dhcp::pools:
isolated.lan:
network: 192.168.99.0
mask: 255.255.255.0
gateway: 192.168.99.1
range: 192.168.99.5 192.168.99.49
dns::zones:
# creates @ SOA $::fqdn root.example.com.
# creates $::fqdn A $::iipaddress
example.com: {}

# creates @ SOA test.example.net. hostmaster.example.com.
# creates test.example.net A 192.0.2.100

example.net:
soa: test.example.net
soaip: 192.0.2.100
contact: hostmaster.example.com.

# creates @ SOA $::fqdn root.example.org.
# does NOT create an A record
example.org:

reverse: true

# creates @ SOA $::fqdn hostmaster.example.com.
2.0.192.in-addr.arpa:

reverse: true

contact: hostmaster.example.com.

Forklift

Foreman provides a git repository designed to streamline setup by setting up all the proper repositories. Forklift provides the
ability to deploy a virtual machine instance via Vagrant or direct deployment on an already provisioned machine. For details on
how to install using forklift, please see the README.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:




Thanks to for hosting this website and our project services.
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Smart Proxy Installation

Hardware Requirements

The Smart Proxy server is only supported on x86_64 Operating Systems

® 2 Two Logical CPUs
® 8 GB of memory
e Disk space usage is similar to that of the main Katello server Installation

Required Ports

At a minimum, the following ports need to be open to external connections for installation:



® 80 TCP - HTTP, used for provisioning purposes
® A43 TCP - HTTPS, used for web access and api communication
® 9090 TCP - HTTPS - used for communication with the Smart Proxy

See the User Guide for additional information about Smart Proxy services and required ports.

Installation

Install needed packages:

The same yum repositories need to be configured on the Smart Proxy server as the main Katello server. See the installation
guide for the list of required repositories.

Once you get the repositories configured, install the formean-proxy-content package on the Smart Proxy

yum install -y foreman-proxy-content

Generate Certificates for the Smart Proxies

Prior to installing the Smart Proxy, we need to generate certificates on the main Katello server:

foreman-proxy-certs-gener -foreman-proxy-fqdn "myproxy.example.com"”

--certs-tar nyproxy.example.com-certs.tar"

In the above example, replace ‘myproxy.example.com’ with your Smart Proxy’s fully qualified domain name. This will generate
a tar file containing all the needed certificates. You will need to transfer those certificates to the server that you will install your
Smart Proxy on using whatever method you prefer (e.g. SCP).

The foreman-proxy-certs-generate command will output an example installation command. For example:

Installing Done [100%] [
Success!

To finish the installation, follow these steps:

1. Ensure that the foreman-installer-katello package is installed on the system.

2. Copy ~/myproxy.example.com-certs.tar to the system myproxy.example.com
3. Run the following commands on the Smart Proxy (possibly with the customized
parameters, see foreman-installer --scenario foreman-proxy-content --help and

documentation " more info on setting up additional services):

yum -y localinstall http://katello.example.com/pub/katello-ca-consumer-latest.noarch.rpm

subscription-manager register --org "Default_Organization"

foreman-installer --scenario foreman-proxy-content
--foreman-proxy-content-parent-fqdn "katello.example.com"
--foreman-proxy-register-in-foreman "true"
--foreman-proxy-foreman-base-url ~ "https://katello.example.com"
--foreman-proxy-trusted-hosts "katello.example.com"
--foreman-proxy-trusted-hosts "myproxy.example.com”
--foreman-proxy-oauth-consumer-key "UVrAZfMaCfBiiWejoUVLYCZHT2xhzuFV"
--foreman-proxy-oauth-consumer-secret "ZhH8p7M577ttNUSWmMUGWASag3JeXKguUX"

--certs-tar-file "/root/myproxy.example.com-certs.tar"
The full log is at /var/log/foreman-proxy-certs-generate.log

Install Smart Proxy

Use the provide installation command from foreman-proxy-certs-generate , and tailor for your own purposes as needed. The
defaults will give you a Smart Proxy ready for Content-related services.

See the User Guide to learn about setting up provisioning related services, as well as the Foreman manual

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!
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Client Installation

Client machines can be added in one of two ways: manually or via a provisioned host.

Manual

Install the appropriate Katello client release packages.

Select your Operating System: H Enterprise Linux 7 (CentOS, etc.) j

yum -y install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum install -y https://yum.theforeman.org/client/1.23/el7/x86_64/foreman-client-release.rpm

Now you are ready to install the client package:



The katello-host-tools package reports errata & package profile information, but does not allow you to run remote actions on
the clients.

yum install katello-host-tools

We generally recommend using Foreman Remote Execution or Ansible for remote actions, but we also offer a messaging bus
based client that does have some limitations when used with a large number of clients.

yum install katello-agent

Optionally you can also install “katello-host-tools-tracer™ and the client will report processes that need restarting after an
update back to the Katello server.

yum install katello-host-tools-tracer

Provisioned

In order to install the katello-agent package on a host you are provisioning, you will need to make the appropriate client
repository available within your Katello. The first step is to either create a new product or add to an existing product, the
appropriate client repository from the dropdown in the manual section above. After you create the new repositories, they will
need to be synced locally. Next, you will then need to add them to the relevant content view(s) for the hosts you are wanting to
provision. At this point, a new version of the content view can be published and promoted to the appropriate environments
that you are wanting to provision a host into. At this point, you can go provision a host and the host will install the katello-agent
package during setup.

When provisioning new clients that should use Puppet 5, set a parameter called ‘enable-puppet5’ to ‘true’, so the templates
know which package to install and where to place the configuration. This parameter can be placed at the host, host group, or
another appropriate level of the hierarchy.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our
This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Katello Upgrade

Katello supports upgrades from the previous two versions only. Upgrades should be performed sequentially without skipping
versions in between.

Pre-upgrade

Before upgrading, run the upgrade check script that will check for any active tasks:

foreman-rake katello:upgrade_check




Step 1 - Backup

If Katello is running on a virtual machine, we recommend to take a snapshot prior to upgrading. Otherwise, take a backup of
the relevant databases by following the instructions here.

Step 2 - Operating System

Ensure your operating system is fully up-to-date:

yum -y update

Step 3 - Repositories
Update the Foreman and Katello release packages:

® RHEL7/CentOS 7:

yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.13/katello/el7/x86_64/katello-repos-latest.rpm
yum update -y https://yum.theforeman.org/releases/1.23/el7/x86_64/foreman-release.rpm

yum update -y foreman-release-scl

Step 4 - Update Packages

Clean the yum cache

Al ]
Update the required packages:

yum -y update

Step 5 - Run Installer

The installer with the —upgrade flag will run the right database migrations for all component services, as well as adjust the
configuration to reflect what's new in Katello 3.13.

foreman-installer --scenario katello --upgrade

Step 6 - Reboot if necessary

If kernel packages are updated during Step 2 the system must be rebooted to ensure the new kernel and SELinux policy are
loaded. If there are no kernel or selinux updates then this step can be omitted.

Congratulations!

You have now successfully upgraded your Katello to 3.13.
For a rundown of what was added, please see the release notes.

If the above steps failed, please review /var/log/foreman-installer/katello.log and let us know about it if unable to resolve.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!
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Thanks to for hosting this website and our project services.
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Smart Proxy Upgrade
Step 1 - Operating System

Ensure your operating system is fully up-to-date:

yum -y update

NOTE: If kernel packages are updated here (e.g. upgrading el 6.6 to 6.7), you must reboot and ensure the new kernel and
SELinux policy is loaded before upgrading Katello.

Step 2 - Repositories



Update the Foreman and Katello release packages:

® RHEL7/CentOS 7:

yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.13/katello/el7/x86_64/katello-repos-latest.rpm

yum update -y https://yum.theforeman.org/releases/1.23/el7/x86_64/foreman-release.rpm

Step 3 - Update Packages

Clean the yum cache

Al [ »]

Update packages:

yum update -y
yum install foreman-proxy-content

Step 4 - Regenerate Certificates

On the Katello server, regenerate the certificates tarball for your Smart Proxy:

foreman-proxy-certs-generate --foreman-proxy-fqdn "myproxy.example.com"

--certs-update-all
--certs-tar  "~/myproxy.example.com-certs.tar"

And copy them to your Smart Proxy:

scp ~/myproxy.example.com-certs.tar myproxy.example.com:

Step 5 - Run Installer

The installer with the -upgrade flag will run the right database migrations for all component services, as well as adjusting the
configuration to reflect what's new in Katello 3.13

foreman-installer --scenario foreman-proxy-content --upgrade
--certs-tar-file ~/myproxy.example.com-certs.tar
--certs-update-all --certs-regenerate true --certs-deploy tru

Congratulations! You have now successfully upgraded your Smart Proxy to 3.13 For a rundown of what was added, please see
release notes.!

If for any reason, the above steps failed, please review /var/log/foreman-installer/foreman-proxy.log - if any of the “Upgrade
step” tasks failed, you may try to run them manaully below to aid in troubleshooting.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Client Upgrade

When upgrading clients there are 2 scenarios: manually added clients and provisioned clients.

Step 1 - Update Repositories
Manually Added Clients

Update the Katello client release packages:

Select your Operating System: H Enterprise Linux 5 (RHEL, CentOS, etc.) j

yum update -y https://yum.theforeman.org/client/1.23/el5/x86_64/foreman-client-release.rpm




Provisioned Clients

If the katello-agent was setup during provisioning from a locally synced repository then you will need to go through some
initial setup to add the 3.13 client repositories to your Katello for each version needed. After you create the new repositories,
they will then need to be added to the relevant content view(s) and the older versions removed. At this point, a new version of
the content view can be published and promoted to the appropriate environments. Once the new package is available the
clients can be updated following the next steps.

Step 2: Update Packages

Clean the yum cache

Kl v
Update packages:

yum update katello-agent

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Katello 3.13 Release Notes

For the full release notes, see the Changelog.

Features
System Purpose Support

Katello 3.13 provides setting System Purpose attributes on Activation Keys in the Ul. Additionally, the Hammer CLI supports
setting System Purpose attrbutes on Activation Keys and Content Hosts.

HTTP Proxy Support



Katello 3.13 introduces support for HTTP proxies for content syncing. Repositories may be assigned an HTTP proxy policy: a
global default, no proxy, or specify a proxy. HTTP proxy policies can be applied through bulk actions at the product level.
Documentation regarding HTTP proxy support can be found here.

Content Views

Content View descriptions may now be updated via the Hammer CLI.

SRPM Support

Katello 3.13 provides the ability to upload SRPMs via the APl and through Hammer and Katello to correctly identify the content
as a source RPM.

Change to signing key
Previous releases were signed using the Katelo key, but starting with 3.13 package signing will use the Foreman Key
4674C97BD8C2A3EF63BCB20788BB5C467B5B366A.

Bug Fixes

Katello 3.13 includes 82 bug fixes, which can be seen here

Contributors
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Hammer
What is the CLI?

The Hammer CLI provides users with a command-line interface for interacting with Katello. It's our goal to make all
functionality that's accessible through Katello's Web Ul also available through Hammer so that users may use Hammer for their
entire Katello workflow.

Installation

The first step to install the CLI is to setup the appropriate repositories: foreman, katello and epel.

Select your Operating System: H Red Hat Enterprise Linux 7 j



yum -y --disablerepo --enablerepo=rhel-7-server-rpms install yum-utils wget

yum-config-manager --disable
yum-config-manager --enable rhel-7-server-rpms
yum-config-manager --enable rhel-7-server-optional-rpms
yum-config-manager --enable rhel-7-server-extras-rpms

yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.13/katello/el7/x86_64/katello-repos-latest.rpm
yum -y localinstall https://yum.theforeman.org/releases/1.23/el7/x86_64/foreman-release.rpm
yum -y localinstall https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

After setting up the appropriate repositories, install Katello:

yum -y install tfm-rubygem-hammer_cli_katello

‘ | ¥]

How do | use Hammer?

To get started with hammer, view the help:

hammer -u <user> -p <password> --help

How do | contribute to Hammer?

See the Katello Hammer CLI project if you want to get setup for contributing to the hammer code.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Activation Keys

Activation Keys provide a mechanism to define properties that may be applied to Content Hosts during registration. This
includes properties such as:

Lifecycle Environment
Content View
Subscriptions
Repository Enablement
Host Collections
System Purpose

Definitions



Content Host

Host Collection - A statically defined group of Content Hosts.

Subscription - The right to receive the associated content from Katello.

System Purpose - Helps auto-attach find a subscription that satisfies the intended use of the system

General Features

The following is a high-level summary of the Activation Key features:

Create an Activation Key

Add subscriptions to an Activation Key

Change repository enablement for an Activation Key
Add Host Collections to an Activation Key

Add System Purpose details to an Activation Key
Register a Content Host using an Activation Key

View Content Hosts registered with an Activation Key

Create an Activation Key

To create a new key,

® navigate to: Content > Activation Keys
® click New Activation Key

. FOREMAN  Default Organization v Default Location ~ L & Adminuser -

Monitoy New Activation Key
Activation Keys » New Activation Key
Content

Name

Research

¥ Unlimited Hosts

Configure Description

This is the activation key used by the research department.

isy Infrastructure

Environment

Administer

Library

Content View

| Default Organization View v

M Cancel

® Name: This required option is used to identify the activation key to command line tools, such as subscription-manager.

® (Content Host Limit. This option will control how many Content Hosts may be registered using the key. An “unlimited”
value will not place any limits on usage. Specifying a quantity will limit the number of registered content hosts.
Registering with an activation key consumes one of the available limit quantity, while unregistering makes it available
again. (i.e. this quantity is not a usage counter but a limit of actively registered content hosts)

® Description: A free form text field that can be used to store a description of the key for later reference or for pseudo-
tagging that can be used to search.

® Fnvironmentand Content View: Although optional, at least one activation key used during registration must specify a
content view. Activation keys are used in the order specified to subscription-manager meaning the last activation key
with a content view takes precedence.

The following example would use CV_B's content view:

subscription-manager register --org Default_Organization --activationkey NO_CV --activationkey CV_A --activationkey CV_B

Or equivalently:

subscription-manager register --org Default_Organization --activationkey NO_CV,CV_A,CV_B

For registration to succeed, at least one activation key must be successfully applied. For an activation key to succeed, at least
one of the listed subscriptions must be successfully attached to the registering content host.



Add Subscriptions to an Activation Key

To add subscriptions to a key:

navigate to: Content > Activation Keys

select the desired key from the list

click Subscriptions

click Add

select the Subscriptions you would like to add
click Add Selected

The Auto-Attach setting controls how the group of subscriptions are processed during registration.

When ‘Auto-Attach’ is enabled but no subscriptions are added to the activation key, subscriptions will be automatically added
to cover the installed products. This is equivalent to passing the ‘-auto-attach’ flag to the subscription-manager command:

subscription-manager register --org=Default_Organization --auto-attach

When ‘Auto-Attach’ is enabled and subscriptions are listed for the activation key, two things will happen. First all subscriptions
for custom products will be attached to the registering content host. Second, the group of Red Hat subscriptions will be
attached as needed to cover the content host's installed Red Hat products. This is most commonly used when there is a group
of similar subscriptions (eg. several Red Hat Enterprise Linux from different contracts, or guest subscriptions from different
hypervisors) and which one used is not important. Katello’s subscription tooling, Candlepin, will automatically choose the
minimal proper subscriptions from the group.

Finally, when ‘Auto-Attach’ is disabled, all subscriptions on the activation key will attached to the registering content host,
regardless of whether needed to cover an installed product or not. For example, adding an OpenStack Platform subscription
would then allow that product to be installed after registration.

. FOREMAN  Default Organization ~ Default Location ~ A & Admin User v

Research Select Action | v
Monitor

Activation Keys » Research » List Subscriptions &=

Content
Details Subscriptions Repository Sets Host Collections Associations v

Hosts Activation Key Type:
Auto-Attach Yes @
Configure ® When Auto Attach is enabled, registering systems will be attached to all associated custom products and only associated Red Hat subscriptions required to satisfy the

system's installed products.

Infrastructure
List/Remove Add

Filter.. Search | » Remove Selected

Administer

0 of 1 Selected

Quantity Attached Type Starts Expires Support Level Contract Account
Test Product
0 out of Physical Jul 19, 1:21 PM 07/11/2049
Unlimited
20 ¥ per page Showing 1-1 of 1 « | < 1]0of1 > »

Change Repository Enablement for an Activation Key

To change repository enablement settings using a key:

navigate to: Content > Activation Keys

select the key you want from the list

click Repository Sets

select the repository you want to modify

select the value you want to change from the Select Action menu(‘Override to Enabled’, ‘Override to Disable’, ‘Reset to
Default’)

View and change settings:



. FOREMAN  Default Organization v Default Location v £ & AdminUser ~

Monitor Research Select Action | v

Activation Keys » Research » Repository Sets
Content

Details Subscriptions Repository Sets Host Collections Associations v
Hosts

® Below are the Repository Sets currently available for this activation key through its subscriptions. For Red Hat subscriptions, additional content can be made available
through the Red Hat Repositories page. Changing default settings for content hosts that register with this activation key requires subscription-manager version 1.10 or
Configure newer to be installed on that host.

Infrastructure Filter. Show All Limit to Environment Select Action | v

Override to Enabled
Override to Disabled

Repository Name Product Name Repository Path Status Reset to Default

#  Test Repo Test Product /custom/Test_Product3/Test_Repo Enabled

Add Host Collections to an Activation Key

To add Host Collections to a key:

navigate to: Content > Activation Keys

select the key you want from the list

click Host Collections

click Add

select the Host Collections you would like to add
click Add Selected

. FOREMAN  Default Organization ~ Default Location & & AdminUser ~

Monitor Research Select Action | v

Activation Keys » Research » Add Host Collections =
Content

Details Subscriptions Repository Sets Host Collections Associations v

List/Remove Add

Configure Ffter Add Selected

1 of 2 Selected

Infrastructure

Name Description Capacity
¥  Development 0/ Unlimited
Administer Finance 0/ Unlimited
20 ¥ per page Showing1-20f2 « < 1/0f1 | > @ >

Add System Purpose details to an Activation Key

To add System Purpose to a key:

® navigate to: Content > Activation Keys
® select the key you want from the list
® There is a section for System Purpose where you can set the Service Level, Usage Type, Role, and Add-ons for a system.



= ‘ FOREMAN  Default Organization v Default Location ~ & & AdminUser v

Research Select Action | v
Monitor

Activation Keys » Research &

Content
Details Subscriptions Repository Sets Host Collections Associations v

@® This activation key may be used during system registration. For example:
subscription-manager register --org="Default_Organization" --activationkey="Research"

Basic Information Activation Key Content
. : 7 jon: Z
TifresiE e Name: Research @ Release Version: @
Description: This is the activation key used by(&" Environment :
the research department.
. Host Limit: Unlimited @ Library
Administer
Content View : Default Organization View (& %

System Purpose

Service Level: @

Usage Type: Development/Test @ %

Role: Red Hat Enterprise Linux © %
Server

Add ons: High Availability =

View Content Hosts registered with the Activation Key

To view Content Hosts registered with a particular Activation Key:

® navigate to: Content > Activation Keys
® select the key you want from the list
® select Content Hosts under Associations

— . FOREMAN  Default Organization ~ Default Location ~ A & AdminUser v

Monitor Research Select Action | v

Activation Keys » Research » Content Hosts &
Content

Details Subscriptions Repository Sets Host Collections Associations v

Filter Search | v
Name Subscription Status Environment Content View Service Level Release Version
Infrastructure katello- ©] Library Default Organization View
client. .example.co
m
Administer
20 V| per page Showing 1 -1 of 1 « | < 1jof1 | > | »

Toolbox

Register a Content Host using an Activation Key

The simplest form of registering a content host with an activation key is this:

subscription-manager register --org=Default_Organization --activationkey=$KEY_NAME

Click here for more information

Note that modifying an activation key does not change anything on content hosts previously registered with the key.




Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our
This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.




HOME

GET STARTED ~

GET HELP ~

GET INVOLVED ~

NEWS ~

Katello 3.13 Documentation

313 =



1. Installation
1.1 Katello
1.2 Smart proxy
1.3 Clients

2. Upgrade
2.1 Katello
2.2 Smart proxy
2.3 Clients

3. Release Notes

4. CLI

5. User Guide
5.1 Activation Keys
5.2 Backup
5.3 Foreman proxy
5.4 Content
5.5 Content Hosts
5.6 Content Views
5.7 Disconnected
5.8 Docker Management
5.9 Email Notifications
5.10 Errata
5.11 Glossary
5.12 Content Credentials
5.13 Host Collections
5.14 Lifecycle Environments
5.15 Provisioning
5.16 Puppet Integration
5.17 Red Hat Content
5.18 SUSE Content
5.19 Remote Databases
5.20 Content View Import/Export
5.21 Source RPMs

6. Advanced
6.1 Certificates
6.2 HTTP Proxies

7. Troubleshooting

8. APl Documentation

9. Annotated Backend Requests

Backup

Please use Foreman Maintain for backup and restore functionality. Foreman-maintain is a dependency of Katello starting in
3.7.
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Smart Proxies

What are Smart Proxies?

The Smart Proxy server is a Katello component that provides federated services to discover, provision, control, and configure
hosts. Each Katello server includes a Default Smart Proxy, and you may deploy additional Smart Proxies to remote data
centers. A Smart Proxy server provides the following features:

e Content features, including:
o Repository synchronization
o Content delivery
o Host action delivery (package installation updates, etc)
© Subscription management proxy (RHSM)



® Foreman Smart Proxy features, including:
o DHCP, including ISC DHCP servers
DNS, including Bind and MS DNS servers
Realm, including FreelPA
Any UNIX-based TFTP server
Puppet Master servers
Puppet CA to manage certificate signing and cleaning
Baseboard Management Controller (BMC) for power management
Provisioning template proxy

0O 0 0 0 0O o o

The Katello Smart Proxy server is a means to scale out the Katello installation. Organizations can create various Smart Proxies
in different geographical locations. These are centrally managed through the Katello server. When a Katello user promotes
content to a particular environment, the Katello server will push the content to each of the Smart Proxy servers subscribed to
that environment. Hosts pull content and configuration from the Katello Smart Proxy servers in their location and not from the
central server.

In a fully configured Smart Proxy, communication is completely isolated between hosts and the Katello server.

What is a Foreman Proxy with Content?

A Katello Smart Proxy is a Foreman Smart Proxy with the addition of content-related services.

Deployment

In the simplest use case, a user may only want to use the Default Smart Proxy. Larger deployments would have a single Katello
server with multiple Smart Proxies attached, with these remote Smart Proxies deployed to various datacenters. Smart Proxies
can also be used to scale the number of hosts attached to a single Katello server.

Installation

See Smart Proxy Installation

Removal

To stop all services and remove all Katello and Foreman related packages, run the following command as root on the Smart
Proxy:

katello-remove

Smart Proxy Isolation

The goal of Smart Proxy Isolation is to provide a single endpoint for all of a client's communication, so that in remote network
segments, you need only open Firewall ports to the Smart Proxy itself. The following section details the communication clients
need to have with a Smart Proxy. The installation options mentioned are the default starting with Katello 2.2.
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Content and Configuration Services

There are five primary areas that require client communication:

1 - Content Delivery

That is, yum. Katello Smart Proxies by default have the Pulp feature, which mirrors content for the selected Lifecycle
Environments.

Install Option:
® --pulp=true
Required Connectivity:

® (lients need to be able to communicate with the Smart Proxy on port 443/tcp.



2 - Katello Agent

The Katello agent is a goferd plugin which allows you to schedule remote actions on hosts such as package installation,
updates, etc. A Smart Proxy must be running the Qpid Dispatch Router service for this feature to work.

Install Option:
® --gpid-router=true
Required Connectivity:

® (lients need to be able to communicate with the Smart Proxy on port 5647/tcp

3 - Puppet & Puppet CA

By default, the Puppet CA feature on the Smart Proxy is an independent CA which will manage the certificates for all the clients
registered against the Smart Proxy. Simply select the Puppetmaster and Puppet CA to be the Smart Proxy when creating a
host.

Install Option:
® --puppet=true --puppetca=true .
Required Connectivity:

® (lients need to communicate with the Smart Proxy on port 8140/tcp.

4 - Subscription Management
Content Hosts utilize Subscription Manager for registration to Katello and enabling/disabling specific repositories.
Install Option:
® --reverse-proxy=true
Required Connectivity:

® (lients need to talk to the Smart Proxy on port 8443/tcp.

5 - Provisioning Services

When provisioning a host using DHCP/PXE, you will need, at a minimum, the TFTP feature enabled on the Smart Proxy, and a
DHCP server available. While not required, the Smart Proxy can provide the DHCP service. In order for the installer to obtain its
kickstart template from the Smart Proxy, you should enable the templates feature.

If a TFTP proxy has the Templates feature as well, Foreman will automatically make the communication isolated. Your clients
need to talk to the Smart Proxy on port 67/udp and 68/udp for DHCP, 69/udp for TFTP, and 8000/tcp for Templates.

Consult the installer's --help for the full range of provisioning options.
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Content

Katello can currently host two different types of content, RPMs and puppet modules. RPMs and Puppet Modules can be
synced from an external resource or can be uploaded directly.

The advantages to using Katello to mirror your local content are:

® Reduce bandwith usage and increase download speed by having client machines pull updates from Katello
® Provision hosts using local Repositories covered HERE TODO
® Customize content locally, covered HERE TODO

Definitions

® Repository - Collection of content (either RPM or puppet)



® Product - Collection of Repositories, Content Hosts subscribe to a product
e Library - A special pre-created Lifecycle Environment where Repositories are created and content is synced or uploaded
to. A Content Host can subscribe to library and receive content as soon as the content is synced or uploaded.

Creating a Product

From the web Ul, navigate to:

Content > Products > New Product (top right)

New Product

Go o/products roducts/new

‘ FOREMAN @ porinuser ~

MyCompany ~ Monitor = Content » Hosts « Configure « Infrastructure « Administer

e Q| Showing 0 of 0 (0 Total) 0 Selected | Deselect All | ® Buk Actions || & Repo Discovery
. New Product X Close
Hame* Epel
Label* Epel
GPG Key -
Sync Plan v

+ Mew Sync Flan

Deseription

Cancel

Creating a Repository

From the web Ul, navigate to:
Content > Products > Select desired product > Create Repository (right hand side)
Note the following options:

® Publish via HTTP: allows access to the Repository without any restriction. Unless you desire to restrict access to your
content in this Repository, we recommended to leave this checked.

® URL: If you are syncing from an external Repository (yum or puppet), this would be filled in. This can be changed, added,
or removed later. For example if you are wanting to create a mirror of EPEL, you would set this to
‘https://dl.fedoraproject.org/pub/epel/6/x86_64/".



~ New Repository

& & [D192.168.122.75:300

e FOREMAN

MyCompany ~ Menitor ~ Content ~

Products
Search Q

(] Name

B Epsl>

Product Epel

Details

Mame*

Label*

Type*

URL

GPG Key

Hosts =

Repositories

Configure ~ Infrastructure =

Showing 1 of 1 (1 Total)

Tasks

« Add New Repository

Epel xB6_64

Epel_x86_64

yum

http:/fdownload-i2 fedoraproject org/publepel'Gix86_64/

Publish via HTTP )

Cancel

B 2amin user ~

Administer

0 Selected | Deselect Al % Bulk Actions | | ¢ Repo Discovery | G ANENGE TR

T Remove Product || % Close

Syncing a Repository

From the web Ul, navigate to:

Content > Products > Select desired product > Select the Repository > Sync Now




. Repository Epel x86_6 =
&o (] [D 192.168.122.75:3000/katello/products#/products/127/repasitories/80

e FOREMAN & 2cmin user +

MyCompany ~ Monitor = Content = Hosts = Configure ~ Infrastructure = Administer
Products
Search Q| Showing 1 of 1 (1 Total) 0 Selected | Deselect All | 8 Bulk Actions || &Repo Discovery | [
[~]
Prod uct Epel & Remove Product || X Close
Details Repositories Tasks
« Back to Repository List ZSync Mow | | Remave Repository
Basic Information Content Counts
Name Epel x86_&4
Label Epel_x86_64 Content Type
Typs yum Packages 0
URL http://download-
i2 fedoraproject.orgipublepel/6/x86_64/ (& Errata 0
Fublish via true
HTTPS Package Groups 0
Fublish via [E3
HTTP
Fublished At http://centos installer/pulp/repos/MyCompany/
Library/custom/Epel/Epel_x86_64
GPG Key 3
Sync Status
Alldates and times below are relative to this senver, hd

The progress will be displayed:

. Product List
G- @ [D 192,168,122 75:3000/katello/products#/products/127/tasks/fod1fd1d-8738-4ade-aae0-aeda74dfB846

e FOREMAN B samin User ~

MyCompany =~ Monitor ~ Content = Hosts = Configure = Infrastructure = Administer «
Products
| @] Showing 1 of 1 (1 Total) 0 Selected | Deselect All | B Bulk Actions || &Repo Discovery
[ Mame
PrOd UCt Epe| il Remove Product || % Close
W Epel>
Details Fepositories Tasks
«Back
Task Details

Action Type Synchronize

User admin
Started At 4415/14 12:52 FM
Finished At
Farameters repository 'Epel x86_64" ; product 'Epel’ ;
organization 'MyCompany'

State running
Result i pending
Details

New packages: 37/10694 (6.58 MB/9.78 GB) l

Syncing multiple repositories



To easily sync multiple repositories at once and track their progress, navigate to:

Content > Sync Status

From here you can expand the desired products, and select multiple repositories to sync.

 Repository: Epel x86_6 x Sync Status

o (] [D abed.usersys.redhat.com: yNC_Mmanagement#! =

Q FOREMAN @ 2amin user +

MyCompany -~ Menitor ~ Content ~ Hosts ~

Configure ~ Infrastructure « Administer ~

Sync Status Collapse All Expand All Select None Select Al [ only show syncing.
PRODUCT | START TIME | DURATION | SIZE (PACKAGES) | RESULT
- Epel 0 Bytes

Epel i386 0 Bytes (0)

Epel x86_54 0 Bytes (0)

Synchronize Now

Uploading RPM Content

Uploading RPM content directly is not currently supported. You will need to build a custom yum Repository. TODO Provide
instructions on creating a custom yum repo

Uploading Puppet Content

To upload puppet modules, first create a Repository with type puppet (similarly to creating a yum Repository above):




~ New Repository

&e (] [ |9 abed usersys.redhat.com: 3000/lkatelo/products#/produ

175/repositories/|

e FOREMAN

MyCompany ~

Products

Search

Monitor ~

Content = Hosts = Configure ~ Infrastructure =

Q| Showing 2 of 2 (2 Total)
Product Configuration

Details Repositories Tasks

« Add New Repository

Hame* Fuppet

Label Puppet

Type* puppet
URL

Publish via HTTP )

GPG Key

Cancel

B 2amin user ~

Administer

0 Selected | Deselect Al % Bulk Actions | | ¢ Repo Discovery | G ANENGE TR

T Remove Product || % Close

When creating this Repository the URL field can be left blank.

Puppet modules can be uploaded via the Web Ul, navigate to:

Content > Repositories > Products > Select desired Product > Select desired Puppet Repository > Select file on the right

- Repository: Puppet

o (€] [D abed.usersys.redhat.com:3000/katello/products#/products/175/repositories/30

Q FOREMAN

MyCompany =~

Products

[ Mame

B Configuration »

[ Epel

Monitor =

Content = Hosts = Configure = Infrastructure =

Q| Showing 2 of 2 (2 Total)
Product Configuration

Details Repositories Tasks

« Back to Repository List

Basic Information

Mame Puppet

Label FPuppst

Type puppet

URL [E3
Publish via true

HTTPS

Publish via =
HTTP

Fublished At http:/Mocalhostpulp/reposMyCompany/Librar

yicustom/Configurati/Puppet
GFG Key [E3

Sync Status

All dates and times below are relative to this server.

. Admin User ~

Administer ~

0 Selected | Deselect Al & Bulk Actions || @ Repo Discovery | G JNERETL T3

fil Remove Product || % Close

& Sync Mow | | Remove Repository

Content Counts

Content Type

Fuppet Modules 0

Upload Puppet Module

Choose File |No file chosen
Upload




Subscribing a System to a Product for yum content

To read about registering systems and subscribing them to the Product click TODO.

Scheduling Repository Synchronization

Sync plans give you the ability to schedule Repository synchronization on a hourly, daily or weekly basis. Sync Plans are applied
to Products and thus all Repositories within a Product will be synchronized according to the products plan.

Creating a Sync Plan

If you would like to schedule certain repositories to sync on a hourly, daily or weekly basis, Sync Plans give you this capability.
To create a Sync Plan, navigate to:

Content > Sync Plans > click “New Sync Plan” on the upper right

The Start Date and Start Time fields are used as the day of the week/month and time of the day to run the re-occuring syncs.

For example a sync plan that starts on Sunday 2014-04-06 at 2:30 will occur every Sunday at 2:30 every week if it has a weekly
interval. If on a daily interval it would sync every day at 2:30.

New Sync Plan
%o G [D abed usersys.redhat.com: 2000/ katello/sync_plans#/new
‘ FOREMAN B 2drin User ~
MyCompany ~ Menitor = Content « Hosts Configure « Infrastructure = Administer «
Sync Plans
Search... Q| Showing 0 of 0 (0 Total) 0 Selected | Deselect Al [t ietiCl
[ Mame
New Sync Plan * Close
Hame* Weekly Sync
Deseription
P
Interval weekly v
Start Dare* 2014-04-06
Start Time (-0400 GMT)* - s
02 30
v v

Assigning a Sync Plan to a Product
Navigate to:
Content > Sync Plans > Select your Sync Plan > Products > Add

Then select the Products you want to add and click “Add Selected” in the upper right.



sync Plans

(o (] [D abed usersys.redhat.com:

. FOREMAN

MyCompany ~ Monitor = Content = Hosts = Configure ~ Infrastructure =
Sync Plans

Search Q| Showing 1 of 0 (0 Total)

[] MName

Weekly Sync »

Sync Plan Weekly Sync

Details Products

Product Management

List/Remove Add

[ Name Description
Configuration

Epel

B 2amin user ~

Administer

[IRUNE = i Sync Plan

W Remowve Sync Plan || % Close

0 Selected | De

1 Selected | Deselect All | Add Selected

Sync Status Repositories
Mewver synced 1
MNewver synced 2
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Content Hosts
What is a Host?

A Host is a Foreman concept that represents a server/host/system/computer (whatever you want to call it). In addition to
holding facts about the system, it:

e Stores which operating system the system should be running
e Stores which puppet classes should be assigned

e Stores which parameters apply to which puppet classes

e Allows you to re-provision the machine



What are Content Hosts?

Content Hosts are the part of a host that manages Content and Subscription related tasks. As time goes on more and more of
this functionality will be moved to the Host object. A Host's Content Host:

Stores which Products are assigned (i.e. which Repositories will the system pull content from)
Initiates package install/upgrade/removal

Determines which errata apply to a system

Initiates errata installation

Stores details about System Purpose

How is a Content Host registered?

Subscription Manager is the client for Katello that handles registration.

Installing Subscription Manager
Depending on your Operating System, for:

RHEL, subscription-manager is installed by default

Fedora, subscription-manager is available from the Everything repo for its release: yum install subscription-manager
CentOS 7, subscription-manager is available in the ‘os' repo for its release: yum install subscription-manager

CentOS 5/6, enable the upstream subscription-manager repo and then install subscription-manager (be sure to change
‘6"to ‘5’ if you're on EL5, as the version from 6 will not work):

wget -O /etc/yum.repos.d/subscription-manager.repo http://copr.fedoraproject.org/coprs/dgoodwin/subscription-manager/repo/epel-6/
dgoodwin-subscription-manager-epel-6.repo

yum install subscription-manager -y

Registering with Subscription Manager

First install the bootstrap rpm from your Katello server:

rom -Uvh http://$KATELLO_HOSTNAME/pub/katello-ca-consumer-latest.noarch.rpm

Then register:

subscription-manager register --org=Default_Organization --environment=Library

Subscription manager will prompt for your username and password. You can also specify --username $USER --password
$PASS on the command line.

Registering to a Content View

To register to Content View “MyView” in a “Devel” Lifecycle Environment:

subscription-manager register --org=Default_Organization --environment=Devel/MyView

Registering without using a username and password

Activation Keys allow you to register and consume content without using a username and password. To create an Activation
Key see the Activation Key Guide

Once you have created an activation key, register with:

subscription-manager register --org=Default_Organization --activationkey=$KEY_NAME

Actions with registered Content Hosts

To see the list of your Content Hosts, navigate to Hosts > Content Hosts



. FOREMAN

ACME_Corporation ~

Monitor ~

Content ~ Hosts = Configure ~ Infrastructure ~

. Admin User ~

Administer

Content Hosts

Name

client.devel

dhepl29-73 rduredhat.com

dhep129-81 rdu redhat.com

testks.rdu.redhat.com

testks rdu redhat com

Q| Showing 5 of 5 (5 Total)

Subscription Status

0s Environment

Red Hat Enterprise Linux
Server 6.4

Red Hat Enterprise Linux

Server 6.5

Red Hat Enterprise Linux
Server 7.0

Red Hat Enterprise Linux

Server 6.5

Red Hat Enterprise Linux

Server 65

0 Selected | Deselect All |  Buk Actions

Content View Registered Last Checkin

Default Organization View 7/3/14 10:02 AM 7/3/14 10:02 AM

Default Organization View 6/13/14 10:30 AM

Default Organization View €/18/14 3:16 PM €/23/14 7:15 PM

IyDistro 6/19/14 4:45 PM 6/20/14 4:47 PM

ErrataTest 6/19/14 4:26 PM 6/19/14 4:30 PM

7/10/14 12.56 PM

Changing the Lifecycle Environment and Content View of a
Content Host:

Navigate to the Content Host Details page, Host > Content Hosts > Click the name of the desired Content Host

. FOREMAN

ACME_Corporation ~

Monitor ~

Content ~ Hosts = Configure ~ Infrastructure ~

. Admin User ~

Administer

Content Hosts
Name

] client.devel

dhcpl29-73 redhat.com »

dhep129-81 rdu redhat.com
testks rdu redhat com

[ testks.rdu.redhat.com

Look in the upper right corner for the

Q| Showing 5 of 5 (5 Total)

Content Host dhcp129-73.rdu.redhat.com

Details

Provisioning Details

Subscriptions Host Callections

Basic Information

Name
uuiD

Description

Type

Subscriptions

Subscription
Status

Details

Auto-Attach
Service Level

Activation Keys

dhcp129-73.rdu.redhat.com &
2df6452c-852d-4ab8-h6ac-728362f913cl

Initial Registration Params 4
Virtual Guest

@ invalid

Red Hat Enterprise Linux Server - Not supported by
a valid subscription

=
=

Yes

None

Content Host Properties

os
Release

Arch

Red Hat Enterprise Linux Server
2.6.32-431 el6 xB6_E4
xB6 R4

“Content Host Content”:

Tasks

Unregister Content Host

Product

Errata

Packages

Content Host Content
£
(3

Release Version
Content View Default Organization View

Environment

[ Library (] Dev

Content Host Status

Registered 6/19/14 10:30 AM
Checkin 7/10/14 12:56 PM
Networking
Hostname dhepl29-73 rdu redhat.com
IPvd Address 10.13.129.73
IPvE Address 1
Interfaces + ctho
+ 1o

ect All | B Bulk Actions | RINEENEC R LR

X Close




Content Host Content

Felease Version (g

Content View Default Organization View [

Environment

B Library

|| Dev

Then select the new Lifecycle Environment you desire, select the new Content View you desire, and click save.

Assigning a Content Host to a Product

In order for a Content Host to receive package updates and access Repositories hosted on Katello, it needs to be subscribed to
a product.

Navigate to Hosts > Content Hosts > Select Content Host > Subscriptions > Click the “Add” tab

‘ FOREMAN B Acrin User ~

ACME_Corporation ~ Monitor Content ~ Hosts « Configure ~ Infrastructure ~ Administer +

Content Hosts

Search Q| showing 20 of 35 (35 Total) 0 Selected | Deselect All | B Bulk Actions | g

(] Name

Content Host dhcp129-73.rdu.redhat.com Unregister Comer Host || x Close

[ client.devel

Details Provisioning Details Subscriptions Host Callections Tasks Packages Errata Product Content
W dhcpl29-73.rduredhat.com »

[J dhepl29-81 rdu redhat.com
Successfully removed 1 subscriptions.

[ testl.devel.example.com

[ testl0.devel example.com Subseription Details Run Auto-Attach

Statl lid
[] testll devel.example.com atus ® invali

Details Red Hat Enterprise Linux Server - Mot supported by a
[0 testl2.devel.example.com wvalid subscription

Auto-Attach Yes =
[ testl3 devel.example.com Service Level =

[ testl4 dewvel.example.com

ListRemove Adel
testl devel.example.com

[ testl6 dewvel.example.com
Search... Q| Showing 2 of 2 (2 Total) Subscriptions 1 Selectsd | Daselsct Al
[ testl7.devel example.com
] Quantity Attached Starts Expires Support Level Contract Account
[0 testlB.devel.example.com

testl9.devel.example.com |

0 out of Unlimited

[ test2.devel example.com

test20.devel.example.com

01 1 out of Unlimited B/4/14 5i27/44

M test2] devel.examnle.com h

Check the checkbox under the Products you want to add and select “Add Selected” in the upper right.

To see existing attached Products, click the “List/Remove” tab. To remove a Product, select the checkbox under the desired
Product in this list and click “Remove Selected”.

Package Management

To perform package actions on a singleContent Host, navigate to: Hosts > Content Hosts > Select Content Host > Packages



FOREMAN . Admin User ~

ACME_Corporation ~ Monitor ~ Content ~ Hosts Configure ~ Infrastructure ~ Administer =

Content Hosts

Seareh Q| Showing 5 of 5 (5 Total) 0 Selected | Deselect All |  Buk Actions

@ Name Content Host dhcp129-73.rdu.redhat.com Unregister Corterr Host || xClose |y

] client.devel

W dhepl29-73.rduredhat.com ¥

[ dhepl29-81 rduredhat.com

Details Provisioning Details Subscriptions Host Callections Tasks Packages Errata Product Content

Package Actions

[ testks.rduredhat.com Package Install v rame Perform

[ testks.rdu.redhat.com

Installed Packages

Filter Showing 416 Packages

Installed Package Remove D
acl-2.2.49-6.16 xB6_64 (=]

aicddoc-firmware-30-2 el6 noarch (=]

apr-1.3.9-5 el6_2.x86_64 (]

apr-util-1.3.9-3 el6_0.1.x86_64 ]

apr-util-ldap-1.3.9-3 el6_0.1x86_E4 [x]

atmel-firmware-1.3-7 el .noarch (=]

attr-2.4.44-7 el6 x86_64 (=]

audit-2 2-4 elf_5 x86_64 [] -

From here you can:

e See alist of installed packages
® Perform a yum install/update/remove of a Package or Package Group
e Update all packages (equivalent of running ‘yum update’)

View and Install Applicable Errata

If your synced Repositories contain Errata, you can use Katello's Errata management to track and install Errata.

Navigate to: Hosts > Content Hosts > Select Content Host > Errata

B Admin User ~

Default Organization ~ e s f re Ac

Content Hosts

search Q| Showing 1 of 1 (1 Total) 0 Selected | ¥ Bulk Actions

[J Name

Content Host client.devel.foo6 Unvegister Coert Host || % Close
DT
Details Frovisioning Details Subscriptions v Host Collections Tasks Packages Errata Froduct Content
Applicable Errata
Show from Current Environment (deviincrementaltest) v
Search a Showing 231 of 231 {231 Total) 0 Selacted | APy Selected
[ Type Id Title Issued
[ ¥ Bug Fix Advisory RHBA-2014:1309 lvm2 bug fix update 11/25/14 EI
[ 4% Bug Fix Advisory RHBA-2014:1734 yum-rhn-plugin bug fix update 10/29/14
@ Product Enhancemeant Advisory RHEA-2014:1733 tzdata enhancement update 10/28/14
[ % Bug Fix Advisory RHBA-2014:1666 gee enhancement update 10/19/14
) A Security Advisory - Moderate RHSA-2014:1671 Moderate: rsyslog5 and rsyslog security  10/19/14
update
] A Security Advisory - Moderate RHSA-2014:1655 Maderate: libxml2 security update 10/15/14

To apply errata, search for the errata you want and select the checkbox beside each errata. Then click “Apply Selected” at the
top right.



The “Show From” filters what applicable errata to show:

e Current Environment - Shows only Applicable Errata available in the Host's Content View & Lifecycle Environment.

® Previous Environment - Shows Applicable Errata that are available from the Host's Content View but in the previous
Lifecycle Environment. Promoting the Content View Version from that previous Lifecycle Environment to the current
Lifecycle Environment for this Host would cause all Applicable Errata shown to then be available.

® Library Synced Content - Shows Applicable Errata which have been synced to the Library. This shows you what is
applicable even when the Errata have not been published into a Content View. All applicable Errata are shown regardless
of availability to the Content Host.

Change Host Collection Asssignments

To change Host Collection assignments for a Content Host, navigate to: Hosts > Content Hosts > Select Content Host > Host
Collections

‘ FOREMAN B Acminuser -

ACME_Corporation ~ Monitor *  Content ~ Hosts~  Configure v Infrastructure ~ Administer ~

Content Hosts

Seareh Q| Showing 5 of 5 (5 Tatal) 0 Selected | Deselect All | B Bulk Actions
] Name
Content Host dhcp129-73.rdu.redhat.com Unregister Content Host || X Close
[ client.devel

Details Provisioning Details Subscriptions Host Collections Tasks Packages Errata Product Content
W dhepl29-73.rduredhat.com ¥

] dhepl29-81 rdu redhat.com

Host Collection Management
[ testks rduredhat com

List/Remove Add
| testks.rduredhat.com

Filter

0 Selected | Deselect All | Remove Selected
] Name Description Capacity
] Database Servers 1/ Unlimited

Bulk Actions

Katello provides the ability to perform actions on many Content Hosts at once such as:

Package installation/upgrade/removal

Listing and applying applicable errata

Assigning Host Collections

Changing Lifecycle Environment and Content View assignments

In order to use the bulk actions, perform whatever search you desire and select which Content Hosts you want to modify. If
you want to select all Content Hosts from a search result, click the ‘checkbox’ above the table:



@ FOREMAN B raminuser ~

ACME_Corporation ~ Monitor * Content ~ Hosts = Configure ~ Infrastructure ~ Administer =

Content Hosts

Search.. IE Showing 20 of 35 (35 Total) 0 Selscted | Desslect Al

[ Name Subscription Status [+11 Environment Content View Registered Last Checkin

(=] [ ] Fed Hat Enterprise Linux Library Default Organization View 7/3/14 10:02 AM 7/3/14 10:02 AM
Server 6.4

O dhepl29- Red Hat Enterprise Linux Library Default Organization View 6/19/14 10:30 AM 7/11/14 12:56 PM

73 rdu.redhat.com Server 6.5
O dhepl29- Red Hat Enterprise Linux Library Default Organization View 6/18/14 3:16 PM 6/23/14 7:15 PM

81 rdu redhat.com Server 7.0
[ testl devel example com Dev StableQS T/11/14 4:23 PM Never checked in
[0 testl0.devel.example.com [ ] Dev StableOS 7/11/14 4:32 PM MNever checked in
[ testll.devel.example.com [ ] Dev Stable0S 71114 432 PM Never checked in
[ testl2.devel example.com [ ] Dev Stable0OS 7/11/14 4:32 PM Never checked in
[ testl3 devel example com [ ] Dev StableOS 7/11/14 432 PM Newver checkad in
O testld devel.example.com [ ] Dev StableOS 7/11/14 4:32 PM MNever checked in
[ testlE.devel example.com [ ] Dev Stable05S 7/11/14 4:32 PM MNewver checked in B
[ testl6.devel example.com [ ] Dev Stable0OS 7/11/14 4:32 PM Never checked in
[ testl7.devel.example.com [ ] Dev Stable0S T11/14 4:32 PM MNever checked in
O testlB.devel.example.com [ ] Dev StableQS 7/11/14 4:33 PM MNever checked in
[ testl9 devel.sxample.com @ Dev StableQS 7/11/14 4:33 P Mever checked in <

This will select all Content Hosts on that page (only the ones that are visible). To select all that correspond to that search query,
notice a bar has now appeared:

FOREMAN . Admin User ~

ACME_Corporation ~ Monitor Content ~ Configure v Infrastructure ~ Administer =

Content Hosts

Search IE Showing 20 of 35 (35 Total) 20 Selected | Deselect All 2 0 it =3

# Name Subscription Status 0s Environment Content View Registered Last Checkin

All 20 items on this page are selected. Select all 35 -

client devel 2 at Enterprise Linux Library Def:

3 rdu.redhat.com Red Hat Enterr

dhcpl29-81 rdu redhat.com Red Hat Enterprise Linux

testl devel nple com Jev StableOS il 4:23 PM Never checked in

StableOS / 4 4:3: Never checked in

StableOS ) 4: Never checked in

StableOS il 44:3 M r checked in

StableOS 4 4:3: Never checked in

StableOS 7 4:32 PM checked in

StableOS 7 4:32 PN M r checked in

StableOS / 4 Never checked in

StableOS 7 checked in

StableOS

StableOS

Next select the ‘Bulk Actions’ button in the top right.

From here you can select the tab corresponding to any action you wish to perform.

Set System Purpose attributes

To set System Purpose attributes for a host, Navigate to the Content Host Details page, Host > Content Hosts > Click the name
of the desired Content Host. You can edit Service Level, Role, Usage Type, and Add-ons from the System Purpose section.
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System Purpose @

Service Level (SLA):
Usage Type:
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kvm
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@ Fully entitled

Yes
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High Availability
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&
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@
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@

Tasks Packages v Errata
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Content Views

What can a Content View be used for?

® To stage content through environments (Dev, Test, Production).
® To filter the contents of a repository (include a package or exclude certain errata, for example).
® To have multiple snapshots of the same repository and/or puppet modules.

Definitions

e (Content View - snapshot of one or more repositories and/or puppet modules.
e Composite Content View - a Content View that contains a collection of other Content Views.
® Filter - provides finer grained control over content in a Content View. Can be used to include or exclude specific



packages, package groups, or errata.

® Publishing - Content Views are ‘published’ in order to lock their contents in place. The content of the Content View is
cloned and all filters applied. Publishing creates a new version of the Content View.

® Promoting - Content Views can be cloned to different Lifecycle Environments (Dev, Test, Production).

General Workflow

First create a product and repository in the library environment and populate the repository with content (by syncing it or
uploading content). A Content Host can now register directly to library and be attached to the content therein. Updates will be
available as soon as new content is synced or uploaded.

To utilize Content Views for filtering and snapshoting:

Create a Content View

Add the desired repository and/or puppet modules to the Content View
Optionally create one or more Filters to fine tune the content of the Content View.
Publish the Content View

Attach the Content Host to the Content View

6. Optionally promote the Content View to another environment

s wnN =

At this point the Content Host will no longer be getting content directly from Library, but from the Content View. Updates to
library will not affect this Content Host.

Note that all of the actions below can also done with hammer, the CLI tool, and examples are given at the end of each section.

Creating a Content View

To create a Content View using the web Ul, navigate to:
Content > Content Views

Click the Create New View button on the top right of the screen.

‘ FOREMAN (B Acmin user +
content views ~ Monitor ~ Content ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Content Views
Search Q| showing 3 of 3 (3 Total) 0 Salected | Deselect All | + Create New View
) Name "
- New Content View X Ciose
) COMPOSITE
O Puppet Modules View Details
Name® New Contant View
(J Yum Repos
Label* New_Content View
Descript “This is my new content view, not sure what it wil contain yet|
4
Composite View? [
A composita view contains other confont viows.
Cancel ﬂ
From the CLI:

hammer content-view create \
--organization="Default Organization" \

--name="New Content View" \
--description="This is my new content view."

Creating a Composite Content View

To create a Composite Content View using the web Ul follow the above steps for Creating a Content View but check the
“Composite View?" checkbox.



From the CLI:

hammer content-view create \
--organization="Default Organization" \
--name="New Composite Content View" \

--description="This is my new composite content view." \
--composite

Adding Repositories

Adding a repository to a Content View means whenever a Content View is published, all of the content contained within the
repository at that time is included in the Content View. If the repository is synced after publishing the Content View, the

Content View will contain the state of the repository prior to syncing. A new version of the Content View must be published in
order for the new version to get the contents of the newly synced repository.

To add a repository using the web Ul, navigate to:
Content > Content Views > Select the desired Content View > Content (within sub navigation) > Repositories

FOREMAN (B Admin User ~

content views - Monitor ~ Content - Hosts ~ Configure ~ Infrastructure ~

Administer -

Content Views

Search... Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | *+ Create New View

[ Name

New Content View | s Pubiin ew Verson [T

Versions  Contentw  PuppetModules  History  Details  Tasks
O COMPOSITE

O Puppet Modules

Repository Selection
([ Yum Repos

List/Remove Add

[Anproguets ] Fwer

() Name Product Last Sync Sync State Content

Red Hat Enterprise Linux 6 Server Red Hat Enterprise Linux Server NA 0 Packages
RPMs xB6_64 6Server 0 Errata
N/A N/A

() Red Hat Enterprise Linux 6 Server - | Red Hat Enterprise Linux Server 0 Packages
Supplementary RPMs i386 6Server 0 Errata

From the CLI, adding a repository:

hammer content-view add-repository \
--organization="Default Organization"

--name="New Content View" \
--repository="CentOS 6.5"

Adding a Puppet Module

Adding a puppet module to a Content View means that whenever the Content View is published the puppet module is locked
to the version selected. If the “Use Latest” version is selected then the puppet module will be “frozen” at the latest version

available when the Content View is published. A new version of the Content View must be published in order for the new
version to get any updated puppet module.

To add a puppet module using the web Ul, navigate to:

Content > Content Views > Select the desired Content View > Puppet Modules (within sub navigation)



FOREMAN [

content views - Monitor ~ Content ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~

Content Views
Soarch Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | *+ Croate New View
[ Name .
New Content View | s Pusion New version ||
O COMPOSITE
Versions  Contentw  PuppetModules  History  Details  Tasks
New Content View >
(J Puppet Modules Currently Selected Puppet Modules
[ Yum Repos Showing 0 of 0 (0 Total) 0 Selected | Deselect Al m

You currently don't have any Puppet Madules included in this Gontent View, you ¢an add puppst modules using the button on the right.

‘ FOREMAN (B Admin User ~

content views - Monitor ~ Content ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Content Views
Search Q| showing 4 of 4 (4 Total) 0 Selected | t Al |+ Croate Now View
[ fame New Content View [ 0 punten e verson |PTE)
[ COMPOSITE

Versions  Contentw | PuppetModules  History  Detalls  Tasks
New Content View

O Puppet Modules Module List

[ Yum Repos Select A New Puppet Module To Add

iter Showing 4 of 4 (4 Total)
Name Actions
postgresql




FOREMAN (B Admin user -

content views ~ Meonltor ~ Content ~ Hosts ~ Configure ~ Infrastructure v Administer v

Content Views

Search Q| Showing 4 of 4 (4 Total) 0 Selected | Deselect All | * Create New View

New Content View [ s Pubiin New version [T
O COMPQOSITE

Versions  Contenty  PuppetModules = History  Detalls  Tasks
® New Content View >

() Puppet Modules

) Name

Module List / Select Module / apache

Yum Repos . :
o > Select an Available Version of apache

Fiter

Author Version Summary Repositories Actions

puppetiabs. Use Latest (currently 1.0.1) Puppet module for Apache Puppet Select Version
puppetabs. 1.0.1 Puppet module for Apache Puppet Select Version

FOREMAN (B Admin User ~
content views - Monitor - Content-  Hosts-  Configure -  Infrastructure - Administer -
Content Views
Search... Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | *+ Create New View
Name .
o New Content View | s Pubiin ew Verson [T
J COMPQOSITE

Versions  Contents  PuppetModules  History  Detalls  Tasks
® New Content View >

[ Puppet Modules Currently Selected Puppet Modules

() Yum Repos Fer Showing 1 of 1 (1 Total) 0 Selected | Deselect Al m
Name Author Version Actions
apache puppetiabs Latest (Currently 1.0.1) Select new version H Remove Module ‘

From the CLI, first find the UUID of your puppet module from the list:

hammer puppet-module list \
--organization="Default Organization" \

--repository "Puppet Modules"

Then add the puppet module:

hammer content-view puppet-module add \
--organization="Default Organization" \

--content-vie ew Content View" \
--uuid=91cc9bb7-dbb3-4798-b50a-45173b763cbb

Adding Content Views to a Composite Content View

Adding a version of a Content View to a Composite Content View means whenever the Composite Content View is published,
all of the content contained within the specific version of that Content View is contained in the Composite Content View. If the
Content Views contained within the Composite Content View are updated (i.e. a new version is published) or if their content is



updated after publishing the Composite Content View, the Composite Content View will only contain the versions of the

Content View(s) prior to syncing. A new version of the Composite Content View must be published in order for it to get the
updated Content Views.

To add a Content View to a Composite Content View using the web Ul, navigate to:

Content > Content Views > Select the desired Content View > Content (within sub navigation) > Repositories

‘ FOREMAN 1B Admin User ~

content views - Monitor ~ Content - Hosts ~ Configure ~ Infrastructure ~ Administer ~

Content Views

Search Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | + Create Now View

O Name

O New Gontent View

Composite Content View COMPOSITE [ & Pusiton new version. [T
Versions Content Views History Details Tasks

O Puppet Modules
o List/Remove Add

O Yum Repos

In order to add a content view to a composite view you must first publish an initial version of the content view.

Fer 1 Selected | Deselect All
() Name Version Environment Description Gontent

Puppet Modules Library gdsfhsdfh 0 Repositories
e T ="
) Yum Repos 4 prod, test, Library 1 Repositories

0 Puppet Modules

Find the Content View ID of the specific version of the Content View to add:

hammer content-view version list \
--organization="Default Organization" \

--content-view="New Content View"

From the CLI, add a Content View to a composite Content View:

hammer content-view update \
--organization="Default Organization" \

--content-view="New Composite Content View" \
--component-ids=2

Creating a filter

If only using Content Views as snapshots, Filters are unnecessary. If the desire is to filter what content make it into the view,

such as blacklisting a package by name or version, or blacklisting errata by date or type, Filters can help accomplish these
tasks.

To create a new Content View Filter using the web Ul, navigate to:

Content > Content Views > Select the desired Content View > Content (within sub navigation) > Filters > New Filter



FOREMAN (B Admin user ~

content views ~ Monitor ~ Content ~ Hosts ~ Configure v

Infrastructure -

Administer -
Content Views
Search. Q| Showing 4 of 4 (4 Total) 0 Selected | Deselect All | *+ Create Now View
() Name

New Content View

O COMPOSITE
Versions  Contentw  PuppetModules  History ~ Details  Tasks
New Content View >

O Puppet Modules Filters

[ Yum Repos Search. Q| showing 0 of 0 (0 Total) 0 Selected | Deselect All | +New Fittor || & Remave Filters

YYou currently don't have any Filters included in this Content View, you can add a new Filter by using the button on the right.

FOREMAN

) Acrinvser ~

Administer ~

content views ~ Monitor ~ Content ~ Hosts ~ Configure ~

Infrastructure ~

Content Views

Search. Q| Showing 4 of 4 (4 Total) 0 Selected | Deselect All | + Create New View
) Name .
. New Content View

O COMPOSITE
Versions | Contents  PuppetModules  History  Detalls  Tasks
New Content View >

(O Puppet Medules « Filters List
O Yum Repos Add New Filter
Name* New Fiter
Content Type* Package c
Type" Exclude A
Description Here s my new fiter

oeee



FOREMAN (B Admin User ~

content views - Monitor ~  Content ~ Hosts ~  Configure ~ Infrastructure ~ Administer ~
Content Views
Search. Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | + Create Now View
[ ame New Content View [ 2 punten e verson |PTE)

() COMPGSITE

Versions | Contentw  PuppetModules  History  Detalls  Tasks
@ New Content View >

=l PuppetModules Filters / New Filter

O Yum Repos

New Filter (Exclude Packages)

Packages Affected repositories @)

1 Remove Packages.

(] Package Name Detail
‘something-olsel EqualTo B 1000 +Add
() hitpd All Versions (# Edit

From the CLI, adding a Content View Filter:

hammer content-view filter create \
--organization="Default Organization" \
--content-view="New Content View" \

--name="New Filter" \
--inclusion=false \

--type=rpm

From the CLI, adding a Content View Filter rule:

hammer content-view filter rule create \
--organization="Default Organization" \
--content-view="New Content View" \
--content-view-filter="New Filter" \

--name="something-else" \
--max-version="10.0.0" \
--min-version="10.0.0"

Selecting which Repositories to Filter

By default a Filter applies to all repositories (present and future) in the Content View. It's possible to select which repositories
within the Content View apply to the filter. This is useful, for example, if the desire is to exclude errata from only certain
repositories in a view.

To select which repositories to Filter in the web Ul, navigate to:

Content > Content Views > Select the desired Content View > Content (within sub navigation) > Filters > Select the desired Filter
> Affected repositories (within sub navigation)



. FOREMAN

(B Admin User ~
content views - Monitor ~ Content -~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Content Views
Search Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | + Create Now View
() Name

New Content View

O COMPOSITE
Versions | Contentw  PuppetModules  History  Detalls  Tasks
® New Content View >

(B ROl Fiters / New Filter
O Yum Repos

New Filter (Exclude Packages)

Packages Affected repositories @)

() This fiter applies to all repositories in the content view (current and future).

@ T ftor appiles oy ta subset ofreposkories i the content view

(T m
Affected? Name Product Type Sync Status Content
4 Red Hat Enterprise Linux 6 Red Hat Enterprise Linux yum N/A 0 Packages
Server RPMs x86_64 6Server Server 0 Errata
o Red Hat Enterprise Linux & Red Hat Enterprise Linux yum NA 0 Packages
Server - Supplementary RPMs  Server 0 Erata

1386 6Server

From the CLI, adding a Content View Filter:

hammer content-view filter update \
--organization="Default Organization" \

--name="New Filter" \
--repository-ids=2,3,7

Publishing a Content View

Publishing a Content View produces a new version of the content view that is subsequently promoted to the Library lifecycle
environment. This newly published version of the content view is now available to any content host registered to Library.

To publish a Content View, in the web Ul, navigate to:

Content > Content Views > Select the desired Content View > Publish New Version

‘ FOREMAN

(B Admin User ~

content views - Monitor - Content~  Hosts ~

Configure ~ Infrastructure ~ Administer ~

Content Views
Search.

Q| showing 4 of 4 (4 Total)

0 Selected | Deselect All | + Create Now View
O Name

New Content View

() COMPGSITE

Versions  Contentw  PuppetModules  History  Detalls  Tasks
@ New Content View >

O Puppet Modules

Publish New Version
O Yum Repos A new version of New Content View and promoted to the Library environment. It can be
promoted to other environments from the Versions tab of this Content View.

Version Details

Version 1

Comment Iniial version|
4

oo 1




FOREMAN (B Admin user ~

content views - Monitor -~ Content - Hosts - Configure - Infrastructure - Administer -
Content Views
Seare Q| showing 4 of 4 (4 Total) 0 Selected | Deselect All | * Create New View
o Name New Content View [ 2 Pt e verson ||

0 COMPQSITE

m Versions Content v Puppet Modules History Details Tasks

O Puppet Modules

O Yum Repos

Version Status Environments Content Author Actions
Version 1 h O N - Library 0 Packages
Publishing and promoting to 1

[ Errata (A ¥ []E[)

environment.

From the CLI:

hammer content-view publish \
--organization="Default Organization" \

--name="New Content View"

Registering a Content Host

To register a Content Host that is not currently registered to the Content View, simply use subscription manager on the client
Content Host and run:

subscription-manager register --org=ACME_Corporation --environment=Library/my_rhel_view

This would register the Content Host to the Library environment and the my_rhel_view Content View.
If the Content Host is already registered, from the Ul:

Hosts > Content Hosts > Select the desired Content Host



FOREMAN B Admin User ~

content views - Monitor ~ Content - Hosts ~ Configure ~ Infrastructure ~ Administer -
Systems
Search Q| Showing 1 of 1 (1 Total) 0 Selected | Deselect All | i BukActions m
) Name

System dhcp129-211.rdu.redhat.com Romove Systom ||  Ciose

® dhcpi29-211.rduredhat.com >

Details Subscriptiens System Groups Tasks Events Packages Errata

Basic Information System Content
Name dhcop128-211.rdu.redhat.com @ Release Version @
uuID e1ee500b-beB5-434-afab-16162a859756 Content View Yum Repos .
Description Initial Registration Params 24
Type Guest m Ganeel

Environment

 Library [ test () prod

Subscriptioens

Subscription Status @ valid

Auto-Attach @
Service Level @
System Status
Activation Keys None
Registered 4/9/14 2:58 PM
Checkin 4/15/14 12:08 PM
System Properties
os Red Hat Enterprise Linux Server N
Networking
Release 2.6.32-431.e16.x86_64
Hostname dhcp128-211.rdu.redhat.com
Arch X86_64
IPv4 Address 10.13.129.211
Number of CPUs 1
IPv6 Address =1
Sockets 1
Interfaces + eth0
Cores per Socket 1 + 0o

From the CLI:

hammer content-host update \
--organization="Default Organization" \

--name="dhcp129-211.rdu.redhat.com” \
--content-view="New Content View" \
--lifecycle-environment="Library"

Promoting a Content View

Initially a Content View is published to Library as version 1. If there are Content Hosts in other environments that would like to
consume this Content View, a version of the content view will need to be promoted to those environments. For example, given
the Content View “New Content View”, version 1 of which has been promoted to the Dev environment. Any Content Hosts in
Dev attached to the Content View would remain at version 1 until a version 2 is both published and promoted to the Dev
environment.

To promote a Content View in the Web Ul, navigate to:

Content > Content Views > Select the desired Content View > Versions (within sub navigation) > Click promote for desired
version



‘ FOREMAN

(B Admin User ~

content views - Monitor ~ Content - Hosts - Configure - Infrastructure -
Content Views
Searen Q| showing 4 of 4 (4 Total)
O Name .
New Content View
[ COMPOSITE
Versions  Content v PuppetModules  Histery ~ Detalls  Tasks
New Content View >
O Puppet Modules Fter
O Yum Repos
Version Status Environments
Version 1 Published. (4/15/14 3:57 PM) » Library

FOREMAN

Administer -

0 Selected | Deselect All | *+ Create Now View

Content Author Actions

487 Packages
112 Errata (A 44 % 13 @55)

(B Admin User ~

contentviews -~  Monitor~  Content~  Hosts~  Configure ~  Infrastructure ~

Content Views

Search Q| showing 4 of 4 (4 Total)
O Name .
New Content View
O COMPOSITE
Versions Content v Puppet Modules History Details Tasks
New Content View >
O Puppet Modules « Back to Version List
O Yum Repos Promote Version 1

Choose one or more lifecycle environments from the existing promotion paths available in
‘walden’.

s e

Promote Version |l ITE]

Administer -

0 Selected | Deselect All | + Create New View




. FOREMAN

) scminvser +

content views ~ Monitor~  Content~  Hosts v

Configure ~  Infrastructure -
Content Views
Search Q| Showing 4 of 4 (4 Total)

@ Nama New Content View

) GOMPOSITE

Versions Content v Puppet Modules History Details Tasks
@ New Content View »

O Puppet Modules

Successfully initiated promotion of New Content View version 1 to test.
O Yum Repos

Version Status Environments

Version 1 « Library

Promoting to 1 environment. . test

To promote a Content View in the CLI:

hammer content-view version promote \
--organization="Default Organization" \
--content-view="New Content View" \
--to-lifecycle-environment="Test" \
--version 1

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a

Thanks to

Administer v

0 Selected | Deselect All | # Create New View

Content Author Actions

0Errata (A0 0@0)

. Source available:

for hosting this website and our project services.
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Katello Inter-Server Sync

NOTE: This feature has been deprecated and will be removed in a future release of Katello. Please consider using Content View
Import/Export instead.

NOTE: This feature is intended to replace the ‘katello-disconnected’ script.

Intro

If you are working in an air-gapped network environment where some of your Katello servers do not have Internet
connectivity, you may be interested in using the Katello Inter-Server Sync (ISS) feature. This allows you to export repos,
including repos in content views, on your “upstream” Katello server, and then import said repos into your “downstream” server
that does not have connectivity. Individual repos can be exported, or all of the repos in a content view.



List of currently supported repo content types:
e yum

Future releases will enable support for additional content types.

Upstream Katello Server

Published Content View

Yum Repository Yum Repository Puppet Modules
Fedora 29 x86_64 Custom Yum Content ntpd, motd, stdlib

ISO Export

Yum Repository Yum Repository
Fedora 29 x86_64 Custom Yum Content

network air-gap

Downstream Katello Server

Library
Yum Repository Yum Repository Other Content
Fedora 29 x86_64 Custom Yum Content Yum, Puppet, Docker, etc

The diagram above shows an example scenario where a user wants to export all Yum content in a content view and then
import to another Katello server. The ISO file is burned to media and then walked across the air-gap in the network.

Detailed Operation
Exporting

The ISS feature allows users to move Yum content from one Katello server to another, in a way that is compatible with air-
gapped networks. Typically users will set up an upstream server that is connected to the Internet, and then create a content
view that contains Yum content that they would like to present to the downstream server (step 1).

Content is exported via either hammer repository export or hammer content-view version export (step 2). It is exported to the
location set in “pulp_export_destination” in the Settings page, under the Katello tab. This defaults to /var/lib/pulp/katello_export .
Please be aware that the location needs to be readable and writable by the foreman user. SELinux permissions also need to be
set on the export location with the type httpd_sys_rw_content_t as well as foreman user and group ownership.

You can select to either export as a plain set of directories, or as a set of ISO files. The “iso_size_mb" parameter sets how large



you would like each ISO file to be. It defaults to 4380 MB, which is the size of a single-side, single-layer DVD.

Importing

Importing (step 3) can be done in one of two ways. The first way is to make the export available via HTTP to the importing
Katello instance. Simply put the export in /var/www/html/pub/export , either via copy or symlink. After that, edit your CDN
location from the manifest import page to point to “http:///export/path/to/export" and the Red Hat Repos page will then work
as expected, using your exported data. Please be sure to use 'http' and not 'https' when altering the CDN url. Katello by default
only supports the CA certificate for “cdn.redhat.com. This is a [known limitation]
(http://projects.theforeman.org/issues/16392) that will be addressed in a future version.

The second way is to perform a repository sync via hammer, specifiying the source location. Please see the hammer repository
sync command for more information. This method is the only way to import custom content, and is the only way to import

incremental content.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.




HOME

GET STARTED ~

GET HELP ~

GET INVOLVED ~

NEWS ~

Katello 3.13 Documentation

313 =



1. Installation
1.1 Katello
1.2 Smart proxy
1.3 Clients

2. Upgrade
2.1 Katello
2.2 Smart proxy
2.3 Clients

3. Release Notes

4. CLI

5. User Guide
5.1 Activation Keys
5.2 Backup
5.3 Foreman proxy
5.4 Content
5.5 Content Hosts
5.6 Content Views
5.7 Disconnected
5.8 Docker Management
5.9 Email Notifications
5.10 Errata
5.11 Glossary
5.12 Content Credentials
5.13 Host Collections
5.14 Lifecycle Environments
5.15 Provisioning
5.16 Puppet Integration
5.17 Red Hat Content
5.18 SUSE Content
5.19 Remote Databases
5.20 Content View Import/Export
5.21 Source RPMs

6. Advanced
6.1 Certificates
6.2 HTTP Proxies

7. Troubleshooting

8. APl Documentation

9. Annotated Backend Requests

Docker Management

Katello can be used to manage and deploy Docker content. Katello can retreive Docker content from a variety of sources such
as Docker hub, private Docker registries, the Red Hat CDN, and so forth. Docker content can then be published and promoted
via Content Views and then pulled or proivisioned to a server running Docker.

What is Docker?

Docker is a tool used to manage Linux containers. To read more about Docker, check out the official Docker site. Docker
repositories, which contain images and tags, can be retrieved, stored, managed, and deployed from Katello.

How to sync a Docker repository



The easiest way to get Docker content into Katello is to sync it in. You can either sync Docker content from the Red Hat CDN (if
you have subscriptions for the content) or from a registry such as Docker Hub.

Red Hat Docker Images

Content can be synced into Katello using a Red Hat manifest in much the same way as yum content. See our guide on how to
manage Red Hat content for more information.

Docker Hub/Docker Registry

To sync content from a Docker registry such as Docker Hub (which is the official Docker-run registry), simply start by creating a
new Repository.

FOREMAN . Admin User ~
Default Organization ~ Monitor ~ Content ~ Contalners ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Products
farch. Q| Showing 2 of 2 (2 Total) 0'Selecteg |WBiichctions|) Repo Discovany
Name

Product Tester Close

) Red Hat Enterprise Linux Sen
Details Repositories Tasks
m Tester>

Add New Repository
General Information

Name*

Label”

Type® docksr |
Sync Information

URL

URL of the registry you want 1o sync. Example:
hrips/iregistry hub. docker.com

Upstream Repository
Name

Name of the UpSTream repository you want to sync. Example: ‘Dusybox'
or Tedora/ssh'.

Cancel | Save

On the new Repository screen, select “Docker” as the content type. Once you do that, you'll be given two options: upstream
name and URL. The URL will be the registry URL; for Docker Hub, this would be https:/registry-1.docker.io/ .

For the upstream name, you want to use the fully qualified upstream name which also includes any namespace such as the
username. This can be just “busybox” if the Repository is an official Docker Hub Repository or it can be something like
“fedora/ssh” where “fedora” is the username/namespace.

Then click save and then sync the Repository as you normally would. Katello will fetch all the images and tags contained within
that Repository.

How to Upload Docker Images

In versions of Katello prior to 3.0, Docker images could be uploaded directly via either the Ul or CLI. However, Katello 3.0 only
supports the Docker Registry v2 format, which is significantly different than the Docker Registry v1 format. The docker save
command outputs a Docker image in v1 format, which cannot be uploaded directly to a v2 repository.

As a workaround, you can create a local Docker registry like so:

docker run -p 5030:5000 --name registry registry:2

Note the :2 above, which specifies a v2 registry. Push your changes to your newly created local registry then follow the

instructions in the section above to sync this registry to Katello. This will ensure that your Docker content stays in Docker's v2
registry format.

How to Publish and Promote Docker Content



Docker content can be published and promoted via Content Views much like yum or puppet content.

FOREMAN Admin User ~
Default Organization ~ Monitor ~ Content ~ Containers ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Content Views
Search... Q| Showing 2 of 2 (2 Total) 0 Selected | Create New View

Name
TeSt Copy View | Remove View | Close

wat

Versions Yum Content Puppet Modules Docker Content History Details Tasks

Repository Selection

List/Remove Add

All Products B Filter Add Repositories
Name Product Last Sync Sync State Content
~ business Tester N/A N/A
busybox Tester 2/2/15 118 PM Success 10 Docker Images
5 Docker Tags
— redis Tester 1/19/15 5:10 PM Success 179 Docker Images

19 Docker Tags

tester Tester 2/17/15 3:40 PM Success 12 Docker Images
1 Docker Tags

wat Tester

After creating a Content View, visit the Docker Content tab. Here you can select any Docker repositories you want to add to
your Content View. After you've added Docker Repositories to your view, you may proceed as normal. Visit the Content View
user guide for more information.

How to View and Pull Docker Content

To view Docker content contained with Katello, visit the Docker Tags page. This can be accessed under the Content menu at
the top of any page.



FOREMAN . Admin User

Default Organization -~ Monitor - Content - Contalners = Hosts~  Configure =  Infrastructure - Administer =
Docker Tags
Swarch Q| showing 25 of 25 (25 Total)
Name Product Name Repository Name
28.14 Tester redis
2.8.15 Tester redis
2.8.16 Tester redis
2.8.17 Tester redis
2.8.18 Tester redis
2.8.19 Tester redis
2.8.6 Tester redis
28.7 Tester redis
288 Tester redis
289 Tester redis
buildroot-2013.08.1 Tester busybox
buildroot-2014.02 Tester busybox
latest Tester tester
latest Tester redis
latest Tester busybox
ubuntu-12.04 Tester busybox
ubuntu-14.04 Tester busybox

On the Docker Tags page, you can see a list of Docker Tags grouped by Repository in Katello. This shows you Tags grouped
across Content Views and Lifecycle Environments. Suppose | wanted to pull the latest Tag from my redis repository, | would
click the latest row for my redis repository.



FOREMAN Admin User ~

Default Organization -~ Monitor ~  Content - Contalners -  Hosts~  Configure -  Infrastructure ~ Administer -
Docker Tags

Q| Showing 25 of 25 (25 Total)
Name i

redis:latest X Close
redis:2.8.14

. Basic Information

redis:2.8.15

Product Tester
redis:2.8.16 Repository redis
redis:2.8.17

Environment Content View Version Image Published At
redis:2.8.18
Library Default Organization View 1.0 3b7234aa3098129352dc... localhost:5000/default_organization-
redis:2.8.19 tester-redis:latest
redis:2.8.6 Library redisv 3.0 3b7234aa3098129352dc... localhost:5000/default_organization-
library-redisv-Tester-

eckn 7 0.7 redis:latest
redis:2.8.8
redis:2.8.9

busybox:buildroat-2013.08. 1
busybox:buildroot-2014.02
tester:latest

redis:latest >

busybox:latest
busybox:ubuntu-12.04
busybox:ubuntu-14.04

| can see here that my redis Repository has been added to a published Content View called redisv. If | want to use the tag from
that Content View, | would just copy the Published At URL and then on my docker server | would run:

$ docker pull localhost:5000/default_organization-library-redisv-Tester-redis:latest

Pulling repository localhost:5000/default_organization-library-redisv-Tester-redis...

How to Provision Docker Content

See how to provision content in the documentation in the foreman-docker documentation. Provisioning content from Katello
works in much the same way.

First, proceed to the new Container page by accessing it from the Containers menu at the top. Then, select the Local Content
tab on the second step. This will allow you to select a Docker image from a published Katello repository which is in an
environment/content view/Smart Proxy. Then just proceed in the wizard as per the Foreman Docker instructions. When you
are finished, you should have a new container running from an image in Katello.

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our
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Email Notifications

Types of Email Notifications

In addition to the Email Notifications that Foreman provides:

® Puppet run summary (Daily/Weekly/Monthly)
® Puppet errors

Katello provides a few addition reports:

e Katello Host Advisory (Daily/Weekly/Monthly) - A report of all of the Errata applicable to all readable Content Hosts
e Katello Promote Errata - A report generated at Content View promotion time showing what Errata applicable to the
Content Hosts within that Content View.



e Katello Sync Errata - A report generated after each Repository sync listing new Errata synced and how many Content
Hosts are applicable.

Configuring the Foreman/Katello to send emails:

The configuration of how the Foreman/Katello service sends email is located in  Adminster > Settings > Email .

For more information see: Email Configuration

Opting in to the emails
By default a user will receive no email notifications. Each notification must be opted into.

To optin for your own user, at the very top right of the web interface, hover over your Username, click “My Account” and then
click the “Mail Preferences” tab.

To optin for other users, navigate to “Administer” > “Users” > Click the desired User > click the “Mail Preferences” tab.

Select which emails and frequency you would like the user to have and click “Submit”.

. FOREMAN B AaminUser -

Default Organization ~ Monitor ~  Content=  Containers=  Hosts =  Configure~  Infrastructure « Administer ~

User Mail Preferences Locations Organizations Roles
General
Mail enabled ¥
Notifications
Katello host advisory Weekly ¥ | A summary of available and applicable errata for your hosts
Katello promote Subscribe ¥ | A post-promotion summary of hosts with available errata
errata
Katello sync errata Subscribe v | Asummary of new errata after a repository is synchronized
Puppet error state No emails v | A notification when a host reports a puppet error
Puppet summary Weekly ¥ | Asummary of eventful puppet reports

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our

This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Errata

Errata are updates between major releases. An Erratum is metadata about a group of packages that explains the importance
of the package updates. Errata may be released individually on an as-needed basis or aggregated as a minor release. There are
three main types of errata:

® Enhancement: the new packages contain one or more added features
e Bugfix: the new packages contain one or more bug fixes
® Security: the new packages fix one or more security vulnerabilities

With regard to Content Hosts, Errata is divided into two distinct classifications depending on whether or not the Errata is
present in the Content Host's Lifecycle Environment and Content View:

® Applicable: the errata applies to one or more Content Hosts
® |nstallable: the errata applies to one or more Content Hosts and is present in the Content Host's Lifecycle Environment



and Content View

Definitions

® (Content Host
e Content View
® |ifecycle Environment

General Features

The following is a high-level summary of the Errata features:

View List of Errata

View Errata Details

View Affected Content Hosts

View Repositories Containing Errata
Applying Errata

View List of Errata

To view the list of Errata in the Organization:

® navigate to: Content > Errata

FOREMAN . Admin User ~
Default Organization ~ Monlitor ~ Content ~ Contalners ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Errata
Search. Q| showing 40 of 2809 (2809 Total) 0 Selected | *+ ApPply Errata
) Errata ID Title Type Affected Content Hosts Updated
) RHSA-2014:1984 Important: bind security update A Security Advisory - Important 0 12/11/14
] RHSA-2014:1983 Important: xorg-x11-server security update A Security Advisory - Important 0 1210114
] RHBA-2014:1970 dovecot bug fix update ¥ Bug Fix Advisory 0 12/8/14
] RHSA-2014:1974 Important: rpm security update A Security Advisory - Important 0 12/8/14
] RHBA-2014:1964 selinux-policy bug fix update ¥ Bug Fix Advisory 0 12/7/14
0 RHBA-2014:1965 curl bug fix update ¥ Bug Fix Advisory 0 12/7/14
O RHBA-2014:1967 sssd bug fix update ¥ Bug Fix Advisory 0 121714
0 RHBA-2014:1961 system-config-firewall bug fix update ¥ Bug Fix Advisory 0 12/4/14
[ RHSA-2014:1919 Critical: firefox security update A Security Advisory - Critical 0 121114
® RHSA-2014:1948 Important: nss, nss-utll, and nss-softokn security, 4 Security Advisory - Important (] 12/1/14
bug fix, and enhancement update
O RHEA-2014:1918 oprofile enhancement update Product Enhancement Advisory 0 11/30/14
O RHBA-2014:1909 Ivm2 bug fix update 3 Bug Fix Advisory 0 11/25/14
(0 RHSA-2014:1911 Moderate: ruby security update A Security Advisory - Moderate o 11/25/14
() RHBA-2014:1886 mdacim bug fix update 3 Bug Fix Advisory 0 11/23/14
() RHBA-2014:1884 eyrus-sas| bug fix update 3 Bug Fix Advisory 0 11/19/14
() RHBA-2014:1883 webkitgtk and gimp bug fix update 3 Bug Fix Advisory 0 11/19/14
() RHBA-2014:1875 device-mapper-multipath bug fix update 3 Bug Fix Advisory 1 11/18/14
() RHBA-2014:1867 nss-softokn bug fix update ¥ Bug Fix Advisory o 11/17/14
) RHEA-2014:1869 new packages: kmod-cracleasm Product Enhancement Advisory 0 11/19/14
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View Errata Details

To view the details of an Errata:

® navigate to: Content > Errata
e C(Click on an Errata ID



FOREMAN (B Admin user ~

Default Organization ~ Meonitor v Content v Containers v Hosts ~ Configure ~ Infrastructure v Administer v
Errata
Search. Q| Showing 40 of 2809 (2808 Total) 0 Selected | *+ Apply Errata
O Errata D . " . 3
Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update * Close
) RHSA-2014:1984
Details Content Hosts Repositories
) RHSA-2014:1983
O RHBA-2014:1870 Advisory RHSA-2014:1948
CVEs
O RHSA-2014:1974 Type Security Advisory
7 Severity Important
RHBA-2014:1964 \ssued 121114
O RHBA-2014:1965 Last Updated On 12/1/14
Reboot Suggested? No
) RHBA-2014:1967 R
Topic
O RHBA-2014:1961 Updated nss, nss-util, and nss-softokn packages that contain a patch to
mitigate the CVE-2014-3566 issue, fix a number of bugs, and add various
O RHSA-2014:1919 enhancements are now available for Red Hat Enterprise Linux 5, 6, and 7.

RHSA-2014:1948 Red Hat Preduct Security has rated this update as having Important
security impact.

) RHEA-2014:1918

Description

O RHBA-2014:1909 Network Security Services (NSS) is a set of libraries designed to support
the platfc of ity-enabled client and server

0 RHSA-2014:1911 applications. Netscape Portable Runtime (NSPR) provides platform

independence for non-GUI operating system facilities.
O RHBA-2014:1886
This update adds support for the TLS Fallback Signaling Cipher Suite Value

| RHBA-2014:1884 (TLS_FALLBACK_SGSV), which can be used to prevent protocol downgrade
attacks against applications which re-connect using a lower SSL/TLS
— RHBA-2014:1883 protocol version when the initial connection indicating the highest

supperted protocol version fails.
O RHBA-2014:1875
This can prevent a forceful downgrade of the communication to SSL 3.0.
The SSL 3.0 protocol was found to be vulnerable to the padding oracle
attack when using block cipher suites in cipher block chaining (CBC) mode.
This issue is identified as CVE-2014-3566, and also known under the alias
POODLE. This SSL 3.0 protocol flaw will not be addressed in a future
update; it is recommended that users configure their applications to
require at least TLS protocel version 1.0 for secure communication.

) RHBA-2014:1867
) RHEA-2014:1869

) RHSA-2014:1870

View Affected Content Hosts

To view the Affected Content Hosts of an Errata:

® navigate to: Content > Errata
® (lickonanErrata ID
® (Click on the Content Hosts Tab

Note the following option:

® Checking the box limits the display of Content Hosts to those which already have the Errata available in their Lifecycle
Environment and Content View.

. FOREMAN [ Acmin user -
Default Organization ~ Menitor v Content ~ Containers v Hosts ~ Configure ~ Infrastructure v Administer v
Errata
Search. Q| Showing 40 of 2809 (2808 Total) 0 Selected | *+ Apply Errata
(] ErratalD ) . X
e Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update * Close
] RHSA-2014:1984
Details Content Hosts Repositories

] RHSA-2014:1983 —
O RHBA-2014:1970 Apply To Content Hosts

™) Only show content hasts where Important: nss, nss-uil, and nss-softokn security, bug fix, and enhancement update is currently avaiable in the host's Lifecycle Environment.
) RHSA-2014:1974

Filter by Environment +
O RHBA-2014:1964 Search. Q Showing 1 of 1 (1 Total) 0 Selected |+ ApPly to Hosts
O RHBA-2014:1965
Name os Environment Content View
O RHBA-2014:1967
O) walden-rhel7.rdu.redhat.com Red Hat Enterprise Linux Server 7.0 Library cv

) RHBA-2014:1961
) RHSA-2014:19189
) RHEA-2014:1918
) RHBA-2014:1909
) RHSA-2014:1911
) RHBA-2014:1886
) RHBA-2014:1884
) RHBA-2014:1883
) RHBA-2014:1875
) RHBA-2014:1867
) RHEA-2014:1869

] RHSA-2014:1870



View Repositories Containing Errata

To view the Repositories Containing an Errata:

® navigate to: Content > Errata
® C(Click on an Errata ID
® (lick on the Repositories Tab

Note that you can filter by Lifecycle Environment and Content View.

‘ FOREMAN [
Default Organization ~ Monitor ~ Content ~ Containers ~ Hosts ~ Configure ~ Infrastructure ~ Administer ~
Errata
Baarch. Q| showing 40 of 2809 (2808 Total)
) ErratalD . . .
Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update
M RHSA-2014:1984
Details Content Hosts Repositories
) RHSA-2014:1983 -
o RHBA-2014:1970 Repositories Containing Errata RHSA-2014:1948
Library + Default Organization View
) RHSA-2014:1974
O RHBA-2014:1964 Search. Q Showing 1 of 1 (1 Total)
] RHBA-2014:1965 ] Name Product Content View Last Sync
] RHBA-2014:1967 ) RHEL6& Red Hat Success 20 days ago

) RHBA-2014:1961
() RHSA-2014:1919
() RHEA-2014:1918
) RHBA-2014:1909
() RHSA-2014:1911
] RHBA-2014:1886
() RHBA-2014:1884
] RHBA-2014:1883
() RHBA-2014:1875
] RHBA-2014:1867
() RHEA-2014:1869

) RHSA-2014:1870

Applying Errata
How Errata is applied to a Content Host(s) depends on whether the Errata is installable.

e |f the Errata is already installable then the Errata is applied to the Content Host(s).

0Selected  *+ Apply Errata

X Close

0 Selected

e |f the Errata is not installable then an Incremental Update is generated. An Incremental Update creates a point release of
the Content View with the Errata included. The Errata can also be applied to the Content Host(s) as part of this process.

There are two ways to apply Errata:

® Asingle Errata can be applied to one or more Content Hosts
® Several Errata can be applied to one or more Content Hosts via a bulk operation

Applying a Single Errata
To apply a single Errata:

Navigate to: Content > Errata
Click on an Errata ID

Click on the Content Host tab
Select the desired Content Hosts
Click “Apply to Hosts"”

Confirm the action



. FOREMAN

Default Organization

[l Admin User -

Monitor ~ Content ~ Containers ~ Hosts ~ Configure ~ Infrastructure ~ Administer -

Errata

All Repositories

Search...

Errata ID

RHSA-2014:1948 >

RHBA-2014:1875

RHEA-2014:1866

RHEA-2014:1733

RHBA-2014:1637

RHBA-2014:1515

RHBA-2014:1426

RHBA-2014:1378

RHBA-2014:1376

RHEA-2014:1472

RHEA-2014:1532

RHEA-2014:1530

RHBA-2014:1384

RHBA-2014:1555

RHBA-2014:1459

RHBA-2014:1590

RHEA-2014:1500

RHBA-2014:1362

‘ FOREMAN

Default Organization

¢ @ Applicable [ Installable

o Showing 19 of 19 (18 Total) 1 Selected m

Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update % Close

Details Content Hosts Repositories

Apply To Content Hosts

[} Only show content hosts where Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update is currently available in the host's Lifecycle
Environment.

Filter by Environment s

Search... Q Showing 1 of 1 (1 Total) E-CLV N Apply to Hosts

[ Name (o] Environment Content View

S
ok T urohatcom | e oo LnacEener 70 |dm | roeL

[ Admin User -

Monitor ~ Content ~ Containers ~ Hosts v Configure ~ Infrastructure ~ Administer ~

Errata

All Repositories

Search...

Errata ID

RHSA-2014:1948 »

RHBA-2014:1875

RHEA-2014:1866

RHEA-2014:1733

RHBA-2014:1637

RHBA-2014:1515

RHBA-2014:1426

RHBA-2014:1378

RHBA-2014:1376

RHEA-2014:1472

RHEA-2014:1532

RHEA-2014:1530

RHBA-2014:1384

RHBA-2014:1555

RHBA-2014:1459

RHBA-2014:1590

RHEA-2014:1500

RHBA-2014:1362

4 Applicable [ Installable
Q| Showing 19 of 19 (19 Total) 1 Selected m
Important: nss, nss-util, and nss-softokn security, bug fix, and enhancement update x Close

Details Content Hosts Repositories
Errata List » Select Content Hosts » Confirm

Apply RHSA-2014:1948

These Errata are not Installable via your published Content View versions running on the selected hosts. The new Content View Versions (specified below) will be
created which will make this Errata Installable in the host's Environment. This new version will replace the current version in your host's Lifecycle Environment. To
install these errata immediately on hosts after publishing check the box below.

Content View Version Environment Host Count

RHEL 21 dev 1

[} Apply Errata to Content Hosts immediately after publishing.

Applying Several Errata

To apply several Errata:

Navigate to: Content > Errata
Select the desired Errata

Click “Apply Errata”

Select the intended Content Hosts

Click “Next”
Confirm the action



Q FOREMAN

Default Organization

- Monitor ~ Content ~

Containers ~

Hosts ~ Configure ~

Infrastructure ~

[l Admin User -

Administer -

Errata

All Repositories

Search...

( Errata ID

RHSA-2014:1948 »

[ RHBA-2014:1875

\ RHEA-2014:1866

\ RHEA-2014:1733

C RHBA-2014:1637

C RHBA-2014:1515

\ RHBA-2014:1426

\ RHBA-2014:1378

\ RHBA-2014:1376

l RHEA-2014:1472

\ RHEA-2014:1532

l RHEA-2014:1530

\ RHBA-2014:1384

Q FOREMAN

Default Organization

4 @ Applicable () Installable
qQ  Showing 19 of 19 (19 Total)

Title

Important: nss, nss-util, and nss-

softokn security, bug fix, and
enhancement update

device-mapper-multipath bug fix
update

tzdata enhancement update
tzdata enhancement update
at bug fix update

audit bug fix and enhancement
update

openldap bug fix and enhancement
update

nss bugfix and enhancement update

xcb-util, xorg-x11-drivers, and mesa
bug fix and enhancement update

elfutils bug fix and enhancement
update

libnl3 enhancement update
new packages: json-c

subscription-manager bug fix and

- Monitor ~ Content ~

Containers ~

Type
A Security Advisory - Important

3¢ Bug Fix Advisory

Product Enhancement Advisory
Product Enhancement Advisory
3¢ Bug Fix Advisory

¢ Bug Fix Advisory

3¢ Bug Fix Advisory

3k Bug Fix Advisory

3¢ Bug Fix Advisory

Product Enhancement Advisory

Product Enhancement Advisory
Product Enhancement Advisory

3k Bug Fix Advisory

Hosts v Configure ~

Content Host Counts

1 Applicable, 0 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable
1 Applicable, 1 Installable
1 Applicable, 1 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable

1 Applicable, 1 Installable
1 Applicable, 1 Installable

1 Applicable, 1 Installable

Infrastructure ~

1 selected [l

Updated

121114

11/18/14

11/16/14
10/28/14
10/14/14

10/13/14
10/13/14

10/13/14

10/13/14
10/13/14

10/13/14
10/13/14

10/13/14

[ Admin User -

Administer -

Errata

All Repositories

Search...

[ Errata ID

[ RHBA-2014:1875
( RHEA-2014:1866
[ RHEA-2014:1733
( RHBA-2014:1637
¢ RHBA-2014:1515
0 RHBA-2014:1426
[ RHBA-2014:1378
( RHBA-2014:1376
¢ RHEA-2014:1472
[ RHEA-2014:1532
[ RHEA-2014:1530
0 RHBA-2014:1384
( RHBA-2014:1555
[ RHBA-2014:1459
[ RHBA-2014:1590
( RHEA-2014:1500

C RHBA-2014:1362

4 [ Applicable [ Installable
Q Showing 19 of 19 (19 Total)

Apply Errata

Errata List » Select Content Hosts

[ Only show content hosts where is currently available in the host's Lifecycle Environment.

Filter by Environment

Search...

L Name

Cancel m

Q Showing 1 of 1 (1 Total)

[o]

S
ed Hat Enterprise Linux Server 7.0

T e N S

Environment

+sonces [

Close

1 Selected

Content View



. FOREMAN B Admin user ~

Default Organization Monitor ~  Content~  Containers~  Hosts~  Configure ~  Infrastructure ~ Administer -
Errata
All Repositories 4 ¥ Applicable Installable
Search... Q| Showing 19 of 19 (19 Total) 1 selected [l
Errata ID
Apply Errata Close
RHBA-2014:1875 Errata List » Select Content Hosts » Confirm

RHEA-2014:1866
These Errata are not Installable via your published Content View versions running on the selected hosts. The new Content View Versions (specified below) will be

RHEA-2014:1733 created which will make this Errata Installable in the host's Environment. This new version will replace the current version in your host's Lifecycle Environment. To

install these errata immediately on hosts after publishing check the box below.
RHBA-2014:1637

Content View Version Environment Host Count
RHBA-2014:1515

RHEL 21 dev 1
RHBA-2014:1426

RHBA-2014:1378 Apply Errata to Content Hosts immediately after publishing.

RHBA-2014:1376 Sancel m

RHEA-2014:1472
RHEA-2014:1532
RHEA-2014:1530
RHBA-2014:1384
RHBA-2014:1555
RHBA-2014:1459
RHBA-2014:1590
RHEA-2014:1500

RHBA-2014:1362

Foreman 2.3.3 has been released!

Foreman 2.2.2 has been released!

View our
This web site is licensed under a . Source available:

Thanks to for hosting this website and our project services.
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Glossary

The following terms are used throughout this document, and are important for the users understanding of Katello.

Activation Key

A registration token which can be used in a kickstart file to control actions at registration. These are similar to Activation Keys
in Spacewalk, but they provide a subset of features because after registration, Puppet takes control of package and
configuration management.

Application Lifecycle Environment

Steps in a promotion path through the Software (Development) Life Cycle (SDLC). Content (packages, puppet modules) can be
moved through lifecycle environments via content view publishing/promotion. Traditionally these environments are things like
Development -> Test -> Production. Channel cloning was used to implement this concept for this in Spacewalk.

Attach

Associating a Subscription to a Host which provides access to RPM content.



Capsule

An additional “server” that can be used in a Katello deployment to facilitate content federation and distribution in addition to
other localized services (Puppet master, DHCP, DNS, TFTP, and more).

Change Set

Set of packages and puppet modules which are promoted between Application Lifecycle Environments. Katello records the
progress of changesets as they promoted. Katello also provides audit capabilities to review how environments have changed
over time.

Compute Profile

Default attributes for new virtual machines on a compute resource.

Compute Resource

A virtual fabric, or cloud infrastructure, where hosts can be deployed by Katello. Examples include RHEV-M, OpenStack, EC2,
and VMWare.

Content

Software packages (RPMS), Package Groups, Errata, and Puppet modules. These are synced into the Library and then
promoted into Lifecycle Environments via Content Views in order to be used/consumed by Hosts.

Content Delivery Network (CDN)

The mechanism to deliver Red Hat content in a geographically co-located fashion. For example, content which is synced by a
Katello in Europe will pull content from a source in Europe.

Content View

A definition of content that combines products, packages, errata and Puppet modules, with capabilities for intelligent filtering
and snapshotting. Content Views are a refinement of the combination of channels and cloning from Spacewalk.

External Node Classifier

A Puppet construct that provides additional data for a Puppet master to be used for configuring Hosts. Foreman acts as an
External Node Classifier to Puppet Masters in a Satellite deployment.

Facter

A program that provides information (facts) about the system on which it is run (eg: total memory, operating system version,
architecture, etc.) Facter facts can be used in Puppet modules in order to enable specific configurations based on Host data.
Hammer

The command line tool for Katello. Hammer can be used as a standard cli (and used in scripts) and can also be used as a shell
in the same way that spacecmd, virsh and others work.

Host

A system, either physical or virtual, which is managed by Katello.

Host Group

A template for how a Host should be built. This includes the content view (which defines the available RPMs and Puppet
modules), and the Puppet classes to apply (which determines the ultimate software and configuration).

Location

A collection of default settings which represent a physical place. These can be nested so that a user can set up defaults, for
example, for Europe, which are refined by Tel Aviv, which are refined by DataCenter East, and then finally by Rack 22.
Library

The Library is the single origin of all content which can be used. If you are an Information Technology Infrastructure Library
(ITIL) shop, it is your definitive media library.

Manifest

The means of transferring subscriptions from a Subscription Provider (such as the Red Hat Customer portal) to Katello. This is
similar in function to certificates used with Spacewalk.

Organization

A tenant in Katello. Organizations, or orgs, are isolated collections of hosts, content and other functionality within a Katello
deployment.

Permission

The ability to perform an action.

Product

A collection of content repositories.

Promote

The act of moving content from one Application Lifecycle Environment to another.

Provisioning Template

User defined templates for Kickstarts, snippets and other provisioning actions. These provide similar functionality to Kickstart
Profiles and Snippets in Katello.

Puppet Agent

An agent that runs on a Host that applies configuration changes to that Host.

Puppet Class

A Puppet Class is re-usable named block of puppet manifest, similar to a class in an object-oriented programming language.
Puppet classes must be included/instantiated in order to use their functionality. Puppet Classes can be parameterized - they
can take parameters when they are included/instantiated and those parameters may be used by the underlying manifest to
affect the ultimate configuration.

Puppet Manifest

A Manifest is a simple set of Puppet instructions. Manifests typically have the .pp extension. A manifest is much like a



procedure in programming terms.

Puppet Master

A Capsule component that provides Puppet manifests to Hosts for execution by the Puppet Agent.

Puppet Module

A Puppet Module is a set of Puppet manifests/classes, template files, tests and other components packaged together in a
specific directory format. Puppet Modules are typically associated with specific software (eg: NTP, Apache, etc) and contain
various classes used to assist in the installation and configuration of that software. Puppet Labs maintains a repository of
official and user-contributed modules called the Puppet Forge.

Pulp Node

A Capsule component that mirrors content. This is similar to the Spacewalk Proxy in Spacewalk. The main difference is that
content can be pre-staged on the Pulp Node before it is used by a Host.

Repository

A collection of content (yum repository, puppet repository).

Role

A collection of permissions that are applied to a set of resources (such as Hosts).

Smart Proxy

A Capsule component that can integrate with external services, such as DNS or DHCP.

Smart Variable

A configuration value that controls how a Puppet Class behaves. This can be set on a Host, a Host Group, an Organization, or a
Location.

Standard Operating Environment (SOE)

A controlled version of the operating system on which applications are deployed.

Subscription

The right to receive content and service from Red Hat. This is purchased by customers.

Syncing

Mirroring content from external resources into an organization’s Library.

Sync Plans

Scheduled execution of syncing content.

Usergroup

A collection of roles which can be assigned to a collection of users. This is