Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Katello 3.2 Installation

These instructions are for installing Katello 3.2, but the latest stable is 3.18.

Note: After installation of Katello, be sure to trust Katello's CA certificate on your system. This is required for the encrypted
NoVNC connections. You will find `katello-server-ca.crt` in the `/pub` directory of your Katello server (e.g. http://katello.example.com/pub/katello-server-ca.crt).

**Hardware Requirements**

Katello may be installed onto a baremetal host or on a virtual guest. The minimum requirements are:

- Two Logical CPUs
- 8 GB of memory (12 GB highly recommended)
- The filesystem holding `/var/lib/pulp` needs to be large, but may vary depending on how many different Operating Systems you wish to synchronize:
  - Allocate 30 GB of space for each operating system. Even though an operating system may not take up this much space now, this allows space for future updates that will be synchronized later.
- The path `/var/spool/squid` is used as a temporary location for some types of repository syncs and may grow to consume 10s of GB of space before the files are migrated to `/var/lib/pulp`. You may wish to put this on the same partition as `/var/lib/pulp`.
- The filesystem holding `/var/lib/mongodb` needs at least 4 GB to install, but will vary depending on how many different Operating Systems you wish to synchronize:
  - Allocate around 40% of the capacity that has been given to the `/var/lib/pulp` filesystem
- The root filesystem needs at least 20 GB of Disk Space

**Required Ports**

The following ports need to be open to external connections:

- 80 TCP - HTTP, used for provisioning purposes
- 443 TCP - HTTPS, used for web access and api communication
- 5647 TCP - qdrouterd - used for client and capsule actions
- 9090 TCP - HTTPS - used for communication with the smart proxy

**Production**

Katello provides a puppet based installer for deploying production installations. Production installations are supported on the following OSes:

<table>
<thead>
<tr>
<th>OS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CentOS 6</td>
<td>X</td>
</tr>
<tr>
<td>CentOS 7</td>
<td></td>
</tr>
<tr>
<td>RHEL 6</td>
<td>X</td>
</tr>
<tr>
<td>RHEL 7</td>
<td></td>
</tr>
</tbody>
</table>

Katello can only run on an x86_64 operating systems.

Installation may be done manually or via our recommended approach of using forklift.

**Required Repositories**

Select your Operating System:  

```
yum -y --disablerepo=* --enablerepo=--rhel-6-server-rpms install yum-utils wget
yum-config-manager --disable ***
yum-config-manager --enable rhel-6-server-rpms epel
yum-config-manager --enable rhel-6-server-optional-rpms
yum -y update
yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el6/x86_64/katello-repos-latest.rpm
yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/foreman/1.13/el6/x86_64/foreman-release.rpm
yum -y localinstall https://yumpuppetlabs.com/puppetlabs-release-pc1-el-6.noarch.rpm # will install with Puppet 4
#yum -y localinstall https://yum.puppetlabs.com/puppetlabs-release-el-6.noarch.rpm # use this instead if you prefer Puppet 3
yum -y install foreman-release-sd
```
After setting up the appropriate repositories, update your system:

```
yum -y update
```

Then install Katello:

```
yum -y install katello
```

At this point the `foreman-installer` should be available to setup the server. The installation may be customized, to see a list of options:

```
foreman-installer --scenario katello --help
```

**Note**

Prior to running the installer, the machine should be set up with a time service such as ntpd or chrony, since several Katello features will not function well if there is minor clock skew.

These may be set as command line options or in the answer file (/etc/foreman-installer/scenarios.d/katello-answers.yaml). Now run the options:

```
foreman-installer --scenario katello <options>
```

**Forklift**

Foreman provides a git repository designed to streamline setup by setting up all the proper repositories. Forklift provides the ability to deploy a virtual machine instance via Vagrant or direct deployment on an already provisioned machine. For details on how to install using forklift, please see the [README](#).

---

**Foreman 2.3.3 has been released!** Follow the quick start to install it.

**Foreman 2.2.2 has been released!** Follow the quick start to install it.
1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Capsule Installation

Hardware Requirements

The Capsule server is only supported on x86_64 Operating Systems
2 Two Logical CPUs
8 GB of memory
Disk space usage is similar to that of the main Katello server

Installation

Required Ports
At a minimum, the following ports need to be open to external connections for installation:

- 80 TCP - HTTP, used for provisioning purposes
- 443 TCP - HTTPS, used for web access and api communication
- 9090 TCP - HTTPS - used for communication with the smart proxy

See the User Guide for additional information about Capsule services and required ports.

Install needed packages:
The same yum repositories need to be configured on the Capsule server as the main Katello server. See the installation guide for the list of required repositories.

Once you get the repositories configured, install the katello-capsule package on the capsule

yum install -y katello-capsule

Generate Certificates for the Capsules
Prior to installing the Capsule, we need to generate certificates on the main Katello server:

capsule-certs-generate --capsule-fqdn "mycapsule.example.com"
--certs-tar "~/mycapsule.example.com-certs.tar"

In the above example, replace 'mycapsule.example.com' with your Capsule's fully qualified domain name. This will generate a tar file containing all the needed certificates. You will need to transfer those certificates to the server that you will install your Capsule on using whatever method you prefer (e.g. SCP).

The capsule-certs-generate command will output an example installation command. For example:

Installing Success!

1. Ensure that the foreman-installer-katello package is installed on the system.
2. Copy ~/mycapsule.example.com-certs.tar to the system mycapsule.example.com
3. Run the following commands on the capsule (possibly with the customized parameters, see foreman-installer --scenario capsule --help and documentation for more info on setting up additional services):
yum -y localinstall http://katello.example.com/pub/katello-ca-consumer-latest.noarch.rpm
subscription-manager register --org "Default_Organization"
foreman-installer --scenario capsule
--parent-fqdn "katello.example.com"
--register-in-foreman "true"
--foreman-base-url "https://katello.example.com"
--trusted-hosts "katello.example.com"
--trusted-hosts "mycapsule.example.com"
--oauth-consumer-key "UVRz3MaClbiWejoUVLYCZHT2xhzuFV"
--oauth-consumer-secret "ZHr87M57t1nU3WmUGWASaq3JaXKgUX"
--pulp-oauth-secret "TPk42MYZ42nAE3rZvyLBh7LxobsnE0Ub"
--certs-tar "~/mycapsule.example.com-certs.tar"

The full log is at /var/log/capsule-certs-generate.log

Install Capsule
Use the provide installation command from capsule-certs-generate, and tailor for your own purposes as needed. The defaults will give you a Capsule ready for Content-related services.

See the User Guide to learn about setting up provisioning related services, as well as the Foreman manual
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Client Installation

Client machines can be added in one of two ways: manually or via a provisioned host.
Manual
Install the appropriate Katello client release packages. For CentOS 6, you will also need to enable the COPR repository for subscription-manager.

Select your Operating System: Enterprise Linux 5 (CentOS, etc.)

```
yum install -y https://fedorapeople.org/groups/katello/releases/yum/3.2/client/el5/x86_64/katello-client-repos-latest.rpm
```

Now you are ready to install the katello-agent:

```
yum install katello-agent
```

Provisioned
In order to install the katello-agent package on a host you are provisioning, you will need to make the appropriate client repository available within your Katello. The first step is to either create a new product or add to an existing product, the appropriate client repository from the dropdown in the manual section above. After you create the new repositories, they will need to be synced locally. Next, you will then need to add them to the relevant content view(s) for the hosts you are wanting to provision. At this point, a new version of the content view can be published and promoted to the appropriate environments that you are wanting to provision a host into. At this point, you can go provision a host and the host will install the katello-agent package during setup.

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.

View our Privacy Policy
This web site is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Source available: github/theforeman/theforeman.org

Thanks to our sponsors for hosting this website and our project services.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Katello Upgrade
Katello supports upgrades from version 2.0. For users transitioning from 1.4, please see - Transition Guide.
Pre-upgrade considerations

Before you upgrade, you need to run the upgrade check script that will check for any active tasks, your version of Katello, and if there are any content hosts that will be deleted (see below). This script is included in Katello 2.4.3.

To run the script:

```
foreman-rake katello:upgrade_check
```

**Step 1 - Backup**

If Katello is running on a Virtual Machine, we recommend to take a snapshot prior to upgrading. Otherwise, take a backup of the relevant databases by following the instructions here.

**Step 2 - Operating System**

Ensure your operating system is fully up-to-date:

```
yum -y update
```

**NOTE:** If kernel packages are updated here (e.g. upgrading el 6.6 to 6.7), you must reboot and ensure the new kernel and SELinux policy is loaded before upgrading Katello.

**Step 3 - Repositories**

Update the Foreman and Katello release packages:

- **RHEL6 / CentOS 6:**

```
yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el6/x86_64/katello-repos-latest.rpm
```

- **RHEL7 / CentOS 7:**

```
yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el7/x86_64/katello-repos-latest.rpm
```

**Step 4 - Update Packages**

Clean the yum cache

```
yum clean all
```

Update the required packages:

```
yum -y update
```

**Step 5 - Run Installer**

The installer with the `--upgrade` flag will run the right database migrations for all component services, as well as adjusting the configuration to reflect what's new in Katello 3.2

```
foreman-installer --scenario katello --upgrade
```

Congratulations! You have now successfully upgraded your Katello to 3.2 For a rundown of what was added, please see release notes.

If for any reason, the above steps failed, please review `/var/log/foreman-installer/katello.log` – if any of the “Upgrade step” tasks failed, you may try to run them manually below to aid in troubleshooting.
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.

View our Privacy Policy

This web site is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Source available: github/theforeman/theforeman.org

Thanks to our sponsors for hosting this website and our project services.
Capsule Upgrade

Step 1 - Operating System

Ensure your operating system is fully up-to-date:
NOTE: If kernel packages are updated here (e.g. upgrading el 6.6 to 6.7), you must reboot and ensure the new kernel and SELinux policy is loaded before upgrading Katello.

Step 2 - Repositories

Update the Foreman and Katello release packages:

- RHEL6 / CentOS 6 Foreman packages are not available yet:

  ```sh
yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el6/x86_64/katello-repos-latest.rpm
  yum update -y https://fedorapeople.org/groups/katello/releases/yum/foreman/1.13/el6/x86_64/foreman-release.rpm
  ```

- RHEL7 / CentOS 7:

  ```sh
yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el7/x86_64/katello-repos-latest.rpm
  yum update -y https://yum.theforeman.org/releases/1.13/el7/x86_64/foreman-release.rpm
  ```

Step 3 - Update Packages

Clean the yum cache

```sh
yum clean all
```

Update packages:

```sh
yum update -y
yum install katello-capsule capsule-certs-generate
```

```sh
scp ~/mycapsule.example.com-certs.tar mycapsule.example.com:
```

Step 4 - Regenerate Certificates

On the Katello server, regenerate the certificates tarball for your capsule:

```sh
capsule-certs-generate --capsule-fqdn "mycapsule.example.com"
  --certs-tar "~/mycapsule.example.com-certs.tar"
```

And copy them to your capsule:

```sh
scp ~/mycapsule.example.com-certs.tar mycapsule.example.com:
```

Step 5 - Run Installer

The installer with the –upgrade flag will run the right database migrations for all component services, as well as adjusting the configuration to reflect what's new in Katello 3.2

```sh
foreman-installer --scenario capsule --upgrade
  --capsule-certs-tar "~/mycapsule.example.com-certs.tar"
  --certs-update-all --certs-regenerate --deploy
```

Congratulations! You have now successfully upgraded your Capsule to 3.2 For a rundown of what was added, please see release notes.!

If for any reason, the above steps failed, please review /var/log/foreman-installer/capsule.log – if any of the “Upgrade step” tasks failed, you may try to run them manually below to aid in troubleshooting.
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Client Upgrade

When upgrading clients there are 2 scenarios: manually added clients and provisioned clients.
Step 1 - Update Repositories

Manually Added Clients

Update the Katello client release packages:

Select your Operating System: [Enterprise Linux 5 (CentOS, etc.)]

```
yum update -y https://fedorapeople.org/groups/katello/releases/yum/3.2/client/el5/x86_64/katello-client-repos-latest.rpm
```

Provisioned Clients

If the katello-agent was setup during provisioning from a locally synced repository then you will need to go through some initial setup to add the 3.2 client repositories to your Katello for each version needed. After you create the new repositories, they will then need to be added to the relevant content view(s) and the older versions removed. At this point, a new version of the content view can be published and promoted to the appropriate environments. Once the new package is available the clients can be updated following the next steps.

Step 2: Update Packages

Clean the yum cache

```
# yum clean all
```

Update packages:

```
# yum update katello-agent
```

Foreman 2.3.3 has been released! Follow the quick start to install it.

Foreman 2.2.2 has been released! Follow the quick start to install it.
Puppet Upgrade

This document outlines how to upgrade from Puppet 3 to Puppet 4.
Overview

Puppet 4 support was added to Foreman in version 1.12, and in Katello in 3.2. Puppet 4 is a major upgrade from Puppet 3; the changes are too numerous for this document. More information can be found in the Puppet 3.x to 4.x: Get upgrade-ready document and the Puppet 4.0 release notes.

Running Puppet 3 and Puppet 4 on the same server is not possible. However, it is possible to run one version of Puppet on your Katello server, and another version of Puppet on one or more capsules. For example, you could have Puppet 4 on your Katello server, Puppet 3 on two capsules, and Puppet 4 on another capsule. The same would work vice-versa, with Puppet 3 on your Katello server and a mix of Puppet 3 and 4 on your capsules.

The upgrade to Puppet 4 will require an outage to your Katello server or capsule, but does not have any long-running data migrations.

Client Support

When planning your upgrade, keep in mind the following compatibility matrix:

<table>
<thead>
<tr>
<th></th>
<th>Puppet 3 client</th>
<th>Puppet 4 client</th>
</tr>
</thead>
<tbody>
<tr>
<td>Puppet 4 server</td>
<td>Compatible</td>
<td>Compatible</td>
</tr>
<tr>
<td>Puppet 3 server</td>
<td>Compatible</td>
<td>Not compatible</td>
</tr>
</tbody>
</table>

Detailed information about Puppet client support is available in the Puppet documentation.

Syntax changes in Puppet 4

Some older Puppet modules will require syntax updates to be compatible with Puppet 4. For example, if you find that some configuration values on clients are blank after running the Puppet agent, you may need to update your Puppet modules.

Upgrading

There are two styles of upgrade. You can either stand up a new capsule that's Puppet 4 and have clients start using it, or upgrade an existing Puppet 3 capsule to Puppet 4. If you do not have an existing capsule and only use the main Katello server, you'll need to upgrade it in-place to take advantage of Puppet 4.

In either upgrade scenario, be sure that you have access to the Puppet Labs packages.

In-place migration

If you plan on upgrading an existing Katello server or capsule to Puppet 4, the process is straightforward.

- Take backup or VM snapshot of server
- run `katello-service stop` to stop all services
- run `foreman-installer --upgrade-puppet`. This will perform the upgrade.

The `--upgrade-puppet` option will also restart services. Once it's done, you can either log in again via the web UI, or run `hammer ping` to check service status. If you run `puppet --version` on the server, it should show `4.6.0` or similar.

Note that you cannot use `--upgrade-puppet` and `--upgrade` at the same time. If you need to do both, run the `--upgrade` first to pull in the latest bugfixes, ensure all services are working as expected, take a new backup, and run `--upgrade-puppet`.

New Capsule

If you would rather leave your existing infrastructure in place, you can create a new Puppet 4 capsule, register it to your Katello server, and then have new or existing clients start using that. As long as the Yum repo for Puppet points to the Puppet 4 location, it should automatically pull in Puppet 4. More information is available on the About Puppet Collections and packages page.

Special considerations for “self-registered” Katello installations

Some users have “self-registered” Katello installations, where the system registers to itself to pull content. In this case, you will need to ensure you have synced down the relevant Puppet 4 repositories and subscribed the server to the correct products before starting the upgrade.

The upgrade process will perform any needed package upgrades before commencing configuration changes, so the Katello server should be able to obtain packages from itself before shutting down.
Further reading

The Foreman upgrade notes contains further notes, including a great “Further reading” area. The Katello installer will automate many of the manual steps, but the Foreman document is a good reference to see what is happening under the covers.

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Katello 3.2 (Malt Liquor) Release Notes

For the full release notes, see the Changelog.
Notable Features

Puppet 4 Support
Puppet 4 is now supported by Katello. For more information, visit the Puppet upgrade page.

Content Host Subscriptions Bulk Actions
Users can now attach Subscriptions to multiple Content Hosts in the UI via bulk actions. Similar functionality is also available via hammer under hammer host subscriptions subcommands.

File type repository updates
In Katello 3.1, the file repository type was added for storing generic files in Katello. The 3.2 release brings with it the ability to add those file repositories to a content view. Now you can you snapshot your generic files into views and push them through environments just as you would for RPM or Puppet content. This can be used to create a production set of Python packages, Ruby gems, tarballs or even Debian repositories. In addition, an API has been added for viewing file content in your Katello just as you would any other content type.

Searchable ostree repos
Adds a new menu item ‘Content -> OSTree Branches’ that enables one to search OSTree branches across different content views/lifecycle environments.

Create/update Composite Content View by Content View names in hammer
Versions of published content views can be added or removed from a composite content view via hammer. The version number and content view ID can now be used to identify the content view version to add to the composite content view. For example, to add version 1.2 of content view with ID 1 to composite view composite_cv:

hammer content-view add-version --name composite_cv --content-view-version 1.2 --content-view-version-content-view-id 1 --organization 'Default Organization'

You can remove a version in a similar way:

hammer content-view remove-version --name composite_cv --content-view-version 1.2 --content-view-version-content-view-id 1 --organization 'Default Organization'

Features

Capsule
- [RFE] make it possible to run capsule-remove unattended (#16003, 010d458f)
- Content Hosts: UI should have some indicator as if/which capsule is providing content (#15818, 69df0ec0)

Tooling
- Update to foreman-tasks 0.8.0 (#16171, d385d8ac, 2145ea4e)

Tests
- Enable HoundCI for checking rubocop cops (#16242, da866bef)
- Add a coverage report to Katello (#15288, 407d3ae3)
- Turn on AssignmentInCondition cop (#15483, a7228ec6)
- Add code climate and build status badges to Katello README (#15608, d51e0587)

Errata Management
- add a way to manually generate applicability for a host (#16295, f9ea2ba2)

Content Views
- Add content-view published status to “ hammer -u admin -p changeme content-view list” (#16302, 60ed450e)
- [RFE] Content View - package filter version field too short for length of typical version strings (#16332, f6930f84)
- Allow adding file type repositories to content views (#13661, 94e8f780)
Hammer
- “hammer content-host info” command should have information related to “Content Host Status” (#14829, 29520f64)
- Create/update composite content-view by content-view Names (#14604, fa2c5214)
- Test with Ruby 2.3 (#15691, 725801c8)
- Listing product content for an activation key does not show correct state in Hammer (#16000, 4158f75, 028bd011)
- Hostgroup info should show associated cv and lifecycle-environment (#15990, 5b617f3b)

Subscriptions
- As a UI user I like to select hosts to attach subscriptions (#10431, 95d7b249)

Atomic
- UI - As a user I want to be able to search rpm-ostree repos (#13953, 67d0bd27)

Web UI
- Upgrade katello to new angular/jasmine (#15085, 35879d13)

Backup & Restore
- Fully online backup (#15454, 46e44353)

API
- [Sat6] allow multiple rpms to be added via content-view filter rule create API endpoint (#15536, ad7523f)
- Use parameter_filter instead of attr_accessible (#15741, 328ee19a)

Repositories
- Provide API for file type content (#15630, 8fac5bed)
- Need a quick way to allow “insecure” syncs (#15802, 810cc603, 34824f25)

Documentation
- Remove YARD from Katello (#15670, 37ff67b3)

Bug Fixes

Installer
- Add rubocop to katello-installer (#16354, 0743b788, 34d01ec2)

Upgrades
- Create a preupgrade script to check systems before upgrades (#15611, fea48380)

Puppet
- Support cleaning empty puppet envs with puppet 4 (#16523, f7b70e71, 58469817)
- katello installer does not allow for upgrading puppet (#16053, 8db5561d, b192d5e7)
- –clear-puppet-environments does not handle puppet 4 env dir (#16011, 6cbb35d5)
- empty puppet environments are left behind in /etc/puppet/environments (#15845, 13189a68)

Hammer
- Support large file uploads in the CLI (#16457, f060a2b3)
- Following the README in setting up hammer-cli-katello, you get a gem dependency conflict (#16101, f46fbd64, 8f19345a)
- [Sat6.2] command “hammer activation-key add-host-collection” fails if using option “–host-collection” with organization_id set to default 1 (#16034, 34ae3d3d)
- Drop support for Ruby 2.0.0 (#15949, 44a80a49)
- Fix the broken link to Travis in the Readme (#15934, 5fbe0fab)
- Adjust coverage settings in hammer-cli-katello (#15927, 03f06430)
- Hammer doesn’t handle removal of required :organization_id param on content_view and lifecycle_environment
• Allow Foreman objects to resolve using  create_search_options_creators_without_katello_api (#15701, 18926cd6, d270200b)
• Organization options for content-view and lifecycle-environment should fail gracefully for hammer hostgroups create/update (#15693, 101e9666)
• hammer content-view create fails when component-ids are specified (#15678, d9551dc8)
• Cannot create new content view (#15604, 6fefa3f3)
• Remove 1.9.3 support from hammer-cli-katello tests (#15593, 7b95d443)
• Remove hammer content-host-update - New command is hammer host update (#15589, 2597aaef)
• [Sat6] allow multiple rpm's to be added via hammer content-view-filter rule create (#15537, 6dce9a75)
• Use fully qualified object .::Foreman in #15420 ( #15443, 39117d81)
• Update test data with new API ( #15436, a9fa1808)
• Only require hammer_cli and hammer_cli_foreman from git in development and production ( #15419, 650bb22e)
• hammer hostgroup update or create command fails when using --organization-ids option fails ( #15313, 2c7c6b6f)
• hammer host-collection add-host/remove-host always return success (#15291, 2e3e5edf)
• 'hammer activation-key subscriptions' shows already removed subscriptions (#15272, 9e72e0c8)
• unable to remove 'version' parameter from command ( #13636)
• need way to attach a subscription to a content host w/ hammer ( #9669, 14c96768)

Installer

• capsule-certs-generate fails for missing parser cache ( #16455, 95eea445)
• Installer should support Puppet 3 and Puppet 4 cache directory ( #16334, e7177df5)
• katello-check output should display an absolute path to certs ( #16280, e03bc400)
• Generate katello-installer's parser cache for kafo and include in the source bundle ( #15938, 7e43a9d2, 9fa93e0a)
• Do not use facter anywhere in katello-installer ( #15911, 57814d72)
• Look at AIO data path for cached data ( #15910, 3edf7534)
• puppet-certs doesn't support puppet 4 aio paths for SSL certificates ( #15882, 55b0911f)
• katello-installer may fail on machines with low RAM ( #15696, 33f416d6)
• rake setup_local creates ./modules/modules ( #15511, ce810a94)
• Install fails if host puppet certs have already been generated ( #15241, b54ac874)
• Select Puppet::server_implementation from installer ( #14602)
• katello-certs-check should print absolute paths to certificates ( #15775, 5b7b21e4)
• The installer should check that the cert rpms installed on the system are corresponding to those present in ~/ssl-build (or in the capsule certs tar.gz) ( #15538, df36e803, e1f168d7)
• Making Upgrade from 3.1 RC2 to 3.1 Release ( #16433, 4ea05178)

Repositories

• Handle import upload errors from pulp ( #16451, f58088de)
• Unable to upload large RPM files from Satellite UI ( #16344, 0127b0ad)
• look for treeinfo files when enabling a repo ( #16278, 821d936d)
• The refresh_repository file is misspelled as refresh_repository ( #16157, be6cc4be)
• Unable to sync Docker Containers to Satellite if repository already exists ( #15971, 4f30704e)
• Repository > Details: “Last Synced” for an unsynced repo looks silly. ( #15933, 9cf370e)
• Cannot add/remove repositories to a content view ( #15869, a7d8f7c6)
• Enabling a repository needs to fail on pulp error ( #15824, 236cc438)
• Syncing a PULP_MANIFEST puppet repo over file:/ fails with No such file or directory: u///dir/modules.json’( #15812, d7f8c110)
• Incremental update task name should have more info ( #15808, 133a4dde)
• Opening Red Hat Repositories link without an uploaded manifest provides the user with a dead link ( #15803, c7eb8c52)

Documentation

• doc change for updated memory specs ( #16427, e3b1057f)
• Fix README references to YARD and praise ( #15669, 4e21fa41)
• Fix broken link in the README ( #15609, 1a6e0477)
• katello disconnected instructions fail to work due to vhost configuration ( #15702, 3913669a)

GPG Keys

• Inconsistent with capitalization of GPG keys across navigation, page title, and button ( #16409, e77758e2)

Errata Management

• Environment and content view not displayed for content host ( #16399, d157380f)
- dashboard latest errata shows untranslated strings (#15929, 3f888f37)
- Cannot apply large sets of errata on errata page because the host search returns a 414 (#15376, d099e609)
- Incremental Update fails with --update-all-systems (#16232, d715a3f1)

**Client/Agent**
- Removing katello-ca-consumer rpm should revert rhsm.conf (#16388, 8d75e8c8)
- Large virt-who json may cause performance issue (#16228, a0ec0f2b)
- calling enabled_repos always forces an errata applicability regeneration (#16209, 184c966c)
- provide option to delete host with subscription-manager unregister (#15455, 71bf4797)
- Re-Registering host with uppercase hostname errors ‘Name has already been taken’ (#15891, 54e881bf)
- Facts updated twice by checkin (#16368, fb6aa992)
- unable to process virt-who data, fails with error: "Validation failed: Name is invalid, Name is invalid" (#16248, fdec6dc)

**Web UI**
- Content host detail page says “RAM (GB): 1024 MB” which is bit confusing (“GB” vs. “MB”) (#16370, 21c9750b)
- Update All button is grayed out unless a package is selected. (#16341, 2062d106)
- Javascript tests are failing on Jenkins (#16282, 11d70ff4)
- Make manifest upload link on RH repositories page point to the actual manage manifest page. (#16078, 069e742a)
- Search functionality stop to work after selecting Activation Key Association tab (#16033, 8ec1a101)
- Free up space in content view version UI (#15986, 4c02361b)
- Red Hat Repositories page not loading (#15832, a6008343)
- Cron weekly katello-remove-orphans warnings sending mail (#15823, 0b7806c6)
- Handle ‘use latest’ correctly when removing puppet modules from CVs (#15817, 8de4f8a9)
- Update katello details page to use bastion nutupane action panel loading screen (#15545, 1de7a9dd)
- Content host details page should be explicit about unregistered clients (#15456, e550e639)
- When search results is zero, message returned is misleading (#14271, 20bac1b0)
- guest subscriptions have incorrect link to hypervisor (#14218, 6eea32d8)
- no change in status color when assigning subscription to content host (#12569, d31947e0)

**API**
- Error undefined method inject for nil:NilClass when no subscriptions are provided to bulk add/remove API (#16369, d684dd81)
- /api/v2/hosts/:id does not expose content_source_id (#15697, e6a7ba59)
- Do not require organization_id when searching in content_views#index and katello/environments#index (#15672, b2640c53)
- API ping don't return information for foreman_auth service (#15582, 95d7b906)
- API Missing route /organizations/:orgid/repositories to list all repos in an organization (#15487, 1de1c034)
- full_results parameter is improperly defined in the API documentation (#15420, 49469e2e)

**Hosts**
- Breaking change in inherited_attributes method (#16359, f4dae3ca)
- strong params filter incorrect for subscription_facet_attributes - cannot update hypervisor_guest_uuids or installed_products (#16173, c282e562)
- Unregistering a Content Host can pause ListenOnCandlepinEvents with Candlepin::Consumer: 410 Gone error (#16170, 883c8066)
- visiting new host page has js error of "KT is not defined" (#15512, 2ab1d40b)
- Helper rake tasks not fully updated for Host Unification and Scoped search (#15721, 5f624ad3)

**Content Views**
- Unpublished content views displayed in the content view list on the composite content view page [Web/UI] (#16346, eb439b09, a5ccf0f1)
- Do not wrap description field in the Content View version listing (#16331, 1e332614)
- The “Remove View” button for deleting a content view should say “Delete View” to match the confirmation submit button (#16271, b5e80512)
- User shouldn't be allowed to add same package in content-view filter repeatedly (#16186, a43dc492)
- Probably should condense the list of puppet modules (and maybe other associations) for content view info (#15987, dd4aadf)
- Cannot delete a RedHat Product or Products with Repositories published in a Content View error does not help user (#15811, 63d1d08)
- hammer content-view version list ignores -organization(-id) options (#15796, 8e39a9a8, c2956945)
- Not able to select/publish " Use Latest Version" of puppet module in content view (#15579, 57eae9cb)
Atomic
- Containers hosted on Atomic host not able to access Katello yum repos (#16343)

Foreman Integration
- need script to unify hosts with shortname and fqdn (#16270, 3fb17a34)
- Remove System and Hypervisor models/controllers/tests/actions (#12556, f5dcf970, df4bc4d7, 440b51d5, 37fa1d79)

Tests
- Tests are failing with ‘LoadError: cannot load such file – polyglot’ (#16213, 1ce49302)
- Test failures under Rails 4.2.7.1 (#16088, db95d867)
- Reduce warnings when running katello tests (#15588, 4e5d97dc)
- katello_fixtures directory not cleaned up in /tmp (#15042, f3713906)

Activation Key
- attaching subscription to an activation key causes UI error (#16189, db12c23b)

Capsule
- Update Katello to synchronize puppet content to capsule based on capsules puppet path. (#16456, c7a3b4f1)
- Capsule auto-synchronization fails with an error ‘PLP0034’ (Katello::Errors::PulpError) after publishing content view on satellite 6.2.0 (#16177, fd79377c)
- Pulp storage error (#16064, 2bb06e19)

Subscriptions
- Add API Bulk Actions for add/remove/auto-attach subscriptions (#16038, e51d11fe)
- hammer activation-key add-subscription/host subscription attach must accept pool ids (#16036, a66ae300)
- Package upload action logs whole input as Parameters (#15940, 59e9f514)

Docker
- Enable katello docker registries to use other ports (#16037, 7be5d7f2)
- docker tag view page shows empty alert (#15759, a78a3ee8)

Tooling
- Carry patched version of urllib3 for lazy sync (#15982, b60f4e83)

Upgrades
- upgrade_check fails because of running tasks (#15945, a0aeeaa25)
- Apache has 7x number of open files on capsule with satellite 6.2 compare to satellite 6.1 (#15841, b4ed05ec)
- upgrade_check does not correctly determine active tasks (#15694, d12e6e67)
- update_subscription_facet_backend_data step fails on upgrade (#16117, dfa26d40)
- hypervisors are deleted upon upgrade to 3.0 (#15726, 93a2d186)
- Error rendering info message in migration due to missed escaping (#15683, 70e6cf78)
- Upgrade from Katello 3.0 to Katello 3.1 fails on apipie:cache task (#16441, a812f1f1)

Dashboard
- Content dashboard has wrong links to [Invalid InsufficientCurrent] Subscriptions (#15941, 73cc4243)

Candlepin
- Katello not receiving messages from candlepin (#15727, 72ad0375)
- virt-who checkin should use default org view and should not overwrite existing registration (#15725, 6a9661b5)
- Deleting a product with multiple repos results in candlepin error (#15482, 7e64292a)
- undefined method [] for nil:NilClass related to activation_key pool association (#15749, 946f3c77)
- VDC guest subscriptions showing as null in activation key (#16398, fe268976)

Roles and Permissions
Pulp

- Out of Memory error while syncing repo (#15101)
- incremental export should be in same format as full export (#14915, b261110a)
- Users should be warned during upgrade of long running Pulp migrations (#15660, ba43845f)
- Errata Install to Content Host takes too long and doesn't scale well (#15366, ab45b88e)

Orchestration

- ListenOnCandlepinEvents pauses during manifest import (#15648, 66e98cb7)
- katello 3.0 RC failing content promotion but can be resumed manually (#15428)

Other

- Cannot create new hostgroup via API/CLI (#16484, 5608b835)
- katello-installer - exclude build dirs from from rubocop checking (#16469, 1e99296f)
- Large files can't be uploaded through content upload APIs (#16429, 68c5d7d1)
- katello-service tool is missing smart_proxy_dynflow_core (#16373, d323d1c3)
- Cannot create new organization via the web ui (#16304, f867be09)
- Add description of remove-content to hammer repository help (#16247, 28ba5d4f)
- Incorrect Next Sync date calculation in weekly Sync Plan (#16035, 08e85148)
- Adjust coverage settings in Katello (#15998, 6fce27a8)
- Autocomplete is not working. (#15917, 6c5b6f1e)
- Content view version in progress tasks should take me to the task itself (#15892, 935af3b3)
- capsule pulp disk usage is not available on rhel6 (#15673, 71b1a3b4)
- New hammer host-collection hosts command does not expose any options (#15429, 8a8057e2)
- Add a Readme for test/data directory on how to generate JSON api (#15305, 1e876e57)
- migrate_content_hosts fails with unique constraint violation (#16137, 7c6a0017)
- No proper subscriptions created for custom products (#15981, 54c453cd)
- Migrate shouldn't ping backends when there are no systems present (#15826, f70b73a8)
- sync and publish emails are never sent (#16303, 319c4650)

Deprecation Warnings

- host status .relevant? deprecation warning (#15398, 6cc8e2f6)

Contributors


Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.

View our Privacy Policy
This web site is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Source available: github/theforeman/theforeman.org
Thanks to our sponsors for hosting this website and our project services.
Hammer

What is the CLI?

The Hammer CLI provides users with a command-line interface for interacting with Katello. It's our goal to make all
functionality that's accessible through Katello's Web UI also available through Hammer so that users may use Hammer for their entire Katello workflow.

## Installation

The first step to install the CLI is to setup the appropriate repositories: foreman, katello and epel.

Select your Operating System: Red Hat Enterprise Linux 6

```bash
yum -y --disablerepo=* --enablerepo=rhel-6-server-rpms install yum-utils wget
yum-config-manager --disable *
yum-config-manager --enable rhel-6-server-rpms epel
yum-config-manager --enable rhel-6-server-optional-rpms
```

After setting up the appropriate repositories, install Katello:

```bash
yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el6/x86_64/katello-repos-latest.rpm
yum -y localinstall https://yum.theforeman.org/releases/1.13/el6/x86_64/foreman-release.rpm
```

How do I use Hammer?

To get started with hammer, view the help:

```bash
hammer -u <user> -p <password> --help
```

How do I contribute to Hammer?

See the [Katello Hammer CLI project](https://github/theforeman/theforeman.org) if you want to get setup for contributing to the hammer code.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Activation Keys

Activation Keys provide a mechanism to define properties that may be applied to Content Hosts during registration. This includes properties such as:

- Lifecycle Environment
Definitions

- **Content Host**: A statically defined group of Content Hosts.
- **Subscription**: The right to receive the associated content from Katello.

General Features

The following is a high-level summary of the Activation Key features:

- Create an Activation Key
- Add subscriptions to an Activation Key
- Change repository enablement for an Activation Key
- Add Host Collections to an Activation Key
- Register a Content Host using an Activation Key

Create an Activation Key

To create a new key,

- navigate to: Content > Activation Keys
- click **New Activation Key**

![New Activation Key](image.png)

- **Name**: This required option is used to identify the activation key to command line tools, such as `subscription-manager`.
- **Content Host Limit**: This option will control how many Content Hosts may be registered using the key. An “unlimited” value will not place any limits on usage. Specifying a quantity will limit the number of registered content hosts.
  Registering with an activation key consumes one of the available limit quantity, while unregistering makes it available again. (i.e. this quantity is not a usage counter but a limit of actively registered content hosts)
- **Description**: A free form text field that can be used to store a description of the key for later reference or for pseudo-
tagging that can be used to search.

- **Environment and Content View**: Although optional, at least one activation key used during registration must specify a content view. Activation keys are used in the order specified to `subscription-manager` meaning the last activation key with a content view takes precedence.

The following example would use CV_B's content view:

```
subscription-manager register --org Default_Organization --activationkey NO_CV --activationkey CV_A --activationkey CV_B
```

Or equivalently:

```
subscription-manager register --org Default_Organization --activationkey NO_CV,CV_A,CV_B
```

For registration to succeed, at least one activation key must be successfully applied. For an activation key to succeed, at least one of the listed subscriptions must be successfully attached to the registering content host.

### Add Subscriptions to an Activation Key

To add subscriptions to a key:

- navigate to: Content > Activation Keys
- select the desired key from the list
- click Subscriptions
- click Add
- select the Subscriptions you would like to add
- click Add Selected

The **Auto-Attach** setting controls how the group of subscriptions are processed during registration.

When 'Auto-Attach' is enabled but no subscriptions are added to the activation key, subscriptions will be automatically added to cover the installed products. This is equivalent to passing the `--auto-attach` flag to the `subscription-manager` command:

```
subscription-manager register --org=Default_Organization --auto-attach
```

When 'Auto-Attach' is enabled and subscriptions are listed for the activation key, two things will happen. First all subscriptions for custom products will be attached to the registering content host. Second, the group of Red Hat subscriptions will be attached as needed to cover the content host's installed Red Hat products. This is most commonly used when there is a group of similar subscriptions (e.g. several Red Hat Enterprise Linux from different contracts, or guest subscriptions from different hypervisors) and which one used is not important. Katello's subscription tooling, Candlepin, will automatically choose the minimal proper subscriptions from the group.

Finally, when 'Auto-Attach' is disabled, all subscriptions on the activation key will attached to the registering content host, regardless of whether needed to cover an installed product or not. For example, adding an OpenStack Platform subscription would then allow that product to be installed after registration.
Change Repository Enablement for an Activation Key

To change repository enablement settings using a key:

- navigate to: Content > Activation Keys
- select the desired key from the list
- click Product Content
- click the edit icon for the repository content set that you would like to modify
- select the desired value (e.g. ‘Override to Yes’, ‘Override to No’, ‘Defaults to Yes’, ‘Defaults to No’)
- click Save

View current settings:
Change current settings:

Add Host Collections to an Activation Key
To add Host Collections to a key:
- navigate to: Content > Activation Keys
- select the desired key from the list
- click Host Collections
- click Add
- select the Host Collections you would like to add
- click Add Selected

Register a Content Host using an Activation Key

The simplest form of registering a content host with an activation key is this:

```
subscription-manager register --org=Default_Organization --activationkey=$KEY_NAME
```

Click here for more information

Note that modifying an activation key does not change anything on content hosts previously registered with the key.

Foreman 2.3.3 has been released! Follow the quick start to install it.

Foreman 2.2.2 has been released! Follow the quick start to install it.

View our Privacy Policy

This web site is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Source available: github/theforeman/theforeman.org

Thanks to our sponsors for hosting this website and our project services.
Backup

In the following sections, these assumptions are being made with respect to making the backup:

- `/tmp/backup` will be used as the target for backups
- All commands are executed as `root`
Option One: Offline repositories backup
By default, the whole Katello instance will be turned off completely for the entire backup.

```
# katello-backup /tmp/backup
```

Option Two: Online repositories backup
Backing up the repositories can take an extensive amount of time. You can perform a backup while online. In order for this procedure to succeed, you must not change or update the repositories database until the backup procedure is complete. Thus, you must avoid publishing, adding, or deleting content views, promoting content view versions, adding, changing, or deleting sync-plans, and adding, deleting, or syncing repositories during this time. To perform an online-backup of the repositories, run:

```
# katello-backup --online-backup /tmp/backup
```

Option Three: Skip repositories backup
There may be situations in which you want to see a system without its repository information. You can skip backing up the Pulp database with the following option:

```
# katello-backup --skip-pulp /tmp/backup
```

Please note you would not be able to restore a Katello instance from a directory where the Pulp database was skipped.

Option Four: Incremental backup
Incremental backups can be used to only store the changes since the last backup:

First take a full backup:

```
# katello-backup /tmp/backup/full
```

Take 1st incremental backup

```
# katello-backup /tmp/backup/incremntal1 --incremental /tmp/backup/full
```

Take 2nd incremental backup

```
# katello-backup /tmp/backup/incremntal2 --incremental /tmp/backup/incremntal1
```

An example with full backup on Sunday and incremental backup for all other weekdays would look like:

```
#!/bin/bash -e
DESTINATION=/var/backup
if [[ $(date +%w) == 0 ]]; then
    katello-backup $DESTINATION
else
    LAST=$(ls -td $DESTINATION/* | head -n 1)
    katello-backup $DESTINATION --incremental "$LAST"
fi
exit 0
```

Final check-up
After a successful backup, the backup directory should have the following files:

```
# ls /tmp/backup
config_files.tar.gz
mongo_data.tar.gz
pgsql_data.tar.gz
pulp_data.tar.gz
```

Additionally, if you ran the backup without skipping the Pulp database, you will see the additional file:

```
pulp_data.tar
```

Katello instance should be up and running. Next chapter is dedicated to restoring a backup.
Full restore

All the following commands are executed under root system account.

Please note only backups that include the Pulp database can be restored. To verify that your backup directory is usable, make sure it has the following files:

```
# ls /tmp/backup
config_files.tar.gz
mongo_data.tar.gz
pgsql_data.tar.gz
pulp_data.tar
```

Once verified, simply run:

```
# katello-restore /tmp/backup
```

This command will require verification in order to proceed, as the method will destruct all databases before restoring them. Once the procedure is finished, all processes will be online, and all databases and system configuration will be reverted to the state and the time of the backup.

Check log files for errors, such as /var/log/foreman/production.log and /var/log/messages.

Incremental restore

Incremental backups need to be restored sequentially starting with the oldest:

```
# katello-restore /tmp/backup/full
# katello-restore /tmp/backup/incremental1
# katello-restore /tmp/backup/incremental2
```
Capsules

What are Capsules?

The Capsule server is a Katello component that provides federated services to discover, provision, control, and configure hosts.
Each Katello server includes a Default Capsule, and you may deploy additional Capsules to remote data centers. A Capsule server provides the following features:

- **Content features**, including:
  - Repository synchronization
  - Content delivery
  - Host action delivery (package installation updates, etc)
  - Subscription management proxy (RHSM)
- **Foreman Smart Proxy features**, including:
  - DHCP, including ISC DHCP servers
  - DNS, including Bind and MS DNS servers
  - Realm, including FreeIPA
  - Any UNIX-based TFTP server
  - Puppet Master servers
  - Puppet CA to manage certificate signing and cleaning
  - Baseboard Management Controller (BMC) for power management
  - Provisioning template proxy

The Katello Capsule server is a means to scale out the Katello installation. Organizations can create various capsules in different geographical locations. These are centrally managed through the Katello server. When a Katello user promotes content to a particular environment, the Katello server will push the content to each of the Capsule servers subscribed to that environment. Hosts pull content and configuration from the Katello Capsule servers in their location and not from the central server.

In a fully configured capsule, communication is completely isolated between hosts and the Katello server.

How do Capsules differ from Smart Proxies?

A Katello Capsule is a Foreman Smart Proxy with the addition of content-related services.

Deployment

In the simplest use case, a user may only want to use the Default Capsule. Larger deployments would have a single Katello server with multiple Capsules attached, with these remote Capsules deployed to various datacenters. Capsules can also be used to scale the number of hosts attached to a single Katello server.

Installation

See Capsule Installation

Removal

To stop all services and remove all Katello and Foreman related packages, run the following command as root on the capsule:

capsule-remove

Capable Isolation

The goal of Capsule Isolation is to provide a single endpoint for all of a client’s communication, so that in remote network segments, you need only open Firewall ports to the Capsule itself. The following section details the communication clients need to have with a Capsule. The installation options mentioned are the default starting with Katello 2.2.
Content and Configuration Services

There are five primary areas that require client communication:

1 - Content Delivery

That is, yum. Katello Capsules by default have the Pulp feature, which mirrors content for the selected Lifecycle Environments.

Install Option:

- `--pulp=true`

Required Connectivity:

- Clients need to be able to communicate with the Capsule on port 443/tcp.

2 - Katello Agent
The Katello agent is a goferd plugin which allows you to schedule remote actions on hosts such as package installation, updates, etc. A capsule must be running the Qpid Dispatch Router service for this feature to work.

Install Option:
- `--qpid-router=true`

Required Connectivity:
- Clients need to be able to communicate with the Capsule on port 5647/tcp

3 - Puppet & Puppet CA
By default, the Puppet CA feature on the Capsule is an independent CA which will manage the certificates for all the clients registered against the Capsule. Simply select the Puppetmaster and Puppet CA to be the Capsule when creating a host.

Install Option:
- `--puppet=true --puppetca=true`

Required Connectivity:
- Clients need to communicate with the Capsule on port 8140/tcp.

4 - Subscription Management
Content Hosts utilize Subscription Manager for registration to Katello and enabling/disabling specific repositories.

Install Option:
- `--reverse-proxy=true`

Required Connectivity:
- Clients need to talk to the Capsule on port 8443/tcp.

5 - Provisioning Services
When provisioning a host using DHCP/PXE, you will need, at a minimum, the TFTP feature enabled on the capsule, and a DHCP server available. While not required, the Capsule can provide the DHCP service. In order for the installer to obtain its kickstart template from the Capsule, you should enable the templates feature.

If a TFTP proxy has the Templates feature as well, Foreman will automatically make the communication isolated. Your clients need to talk to the Capsule on port 67/udp and 68/udp for DHCP, 69/udp for TFTP, and 8000/tcp for Templates.

Consult the installer’s `--help` for the full range of provisioning options.

---

Foreman 2.3.3 has been released! Follow the quick start to install it.

Foreman 2.2.2 has been released! Follow the quick start to install it.

---

View our [Privacy Policy](#).

This web site is licensed under a [Creative Commons Attribution-ShareAlike 3.0 Unported License](#). Source available: [github/theforeman/theforeman.org](#)

Thanks to [our sponsors](#) for hosting this website and our project services.
Content

Katello can currently host two different types of content, RPMs and puppet modules. RPMs and Puppet Modules can be synced from an external resource or can be uploaded directly.

The advantages to using Katello to mirror your local content are:
- Reduce bandwidth usage and increase download speed by having client machines pull updates from Katello
- Provision hosts using local Repositories covered HERE TODO
- Customize content locally, covered HERE TODO

Definitions
- Repository - Collection of content (either RPM or puppet)
- Product - Collection of Repositories, Content Hosts subscribe to a product
- Library - A special pre-created Lifecycle Environment where Repositories are created and content is synced or uploaded to. A Content Host can subscribe to library and receive content as soon as the content is synced or uploaded.

Creating a Product
From the web UI, navigate to:
Content > Products > New Product (top right)

Creating a Repository
From the web UI, navigate to:
Content > Products > Select desired product > Create Repository (right hand side)

Note the following options:
- Publish via HTTP: allows access to the Repository without any restriction. Unless you desire to restrict access to your content in this Repository, we recommended to leave this checked.
- URL: If you are syncing from an external Repository (yum or puppet), this would be filled in. This can be changed, added, or removed later. For example if you are wanting to create a mirror of EPEL, you would set this to "https://dl.fedoraproject.org/pub/epel/6/x86_64/".
Syncing a Repository

From the web UI, navigate to:

Content > Products > Select desired product > Select the Repository > Sync Now
Syncing multiple repositories
To easily sync multiple repositories at once and track their progress, navigate to:

Content > Sync Status

From here you can expand the desired products, and select multiple repositories to sync.

Uploading RPM Content

Uploading RPM content directly is not currently supported. You will need to build a custom yum Repository. TODO Provide instructions on creating a custom yum repo

Uploading Puppet Content

To upload puppet modules, first create a Repository with type puppet (similarly to creating a yum Repository above):
When creating this Repository the URL field can be left blank.
Puppet modules can be uploaded via the Web UI, navigate to:
Content > Repositories > Products > Select desired Product > Select desired Puppet Repository > Select file on the right
Subscribing a System to a Product for yum content

To read about registering systems and subscribing them to the Product click TODO.

Scheduling Repository Synchronization

Sync plans give the ability to schedule Repository synchronization on a hourly, daily or weekly basis. Sync Plans are applied to Products and thus all Repositories within a Product will be synchronized according to the products plan.

Creating a Sync Plan

If you would like to schedule certain repositories to sync on a hourly, daily or weekly basis, Sync Plans give you this capability.

To create a Sync Plan, navigate to:
Content > Sync Plans > click “New Sync Plan” on the upper right

The Start Date and Start Time fields are used as the day of the week/month and time of the day to run the re-occuring syncs.

For example a sync plan that starts on Sunday 2014-04-06 at 2:30 will occur every Sunday at 2:30 every week if it has a weekly interval. If on a daily interval it would sync every day at 2:30.

Assigning a Sync Plan to a Product

Navigate to:
Content > Sync Plans > Select your Sync Plan > Products > Add

Then select the Products you want to add and click “Add Selected” in the upper right.
GPG Keys
To learn about securing your packages and Repositories with GPG Keys click here. TODO

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Content Hosts

What is a Host?

A Host is a Foreman concept that represents a server/host/system/computer (whatever you want to call it). In addition to
holding facts about the system, it:

- Stores which operating system the system should be running
- Stores which puppet classes should be assigned
- Stores which parameters apply to which puppet classes
- Allows you to re-provision the machine

What are Content Hosts?

Content Hosts are the part of a host that manages Content and Subscription related tasks. As time goes on more and more of this functionality will be moved to the Host object. A Host's Content Host:

- Stores which Products are assigned (i.e. which Repositories will the system pull content from)
- Initiates package install/upgrade/removal
- Determines which errata apply to a system
- Initiates errata installation

How is a Content Host registered?

Subscription Manager is the client for Katello that handles registration.

Installing Subscription Manager

Depending on your Operating System, for:

- RHEL, subscription-manager is installed by default
- Fedora, subscription-manager is available from the Everything repo for its release: `yum install subscription-manager`
- CentOS 7, subscription-manager is available in the ‘os’ repo for its release: `yum install subscription-manager`
- CentOS 5/6, enable the upstream subscription-manager repo and then install subscription-manager (be sure to change ‘6’ to ‘5’ if you’re on EL5, as the version from 6 will not work):

```
yum install subscription-manager -y
```

Registering with Subscription Manager

First install the bootstrap rpm from your Katello server:

```
rpm -Uvh http://$KATELLO_HOSTNAME/pub/katello-ca-consumer-latest.noarch.rpm
```

Then register:

```
subscription-manager register --org=Default_Organization --environment=Library
```

Subscription manager will prompt for your username and password. You can also specify `--username $USER --password $PASS` on the command line.

Registering to a Content View

To register to Content View “MyView” in a “Devel” Lifecycle Environment:

```
subscription-manager register --org=Default_Organization --environment=Devel/MyView
```

Registering without using a username and password

Activation Keys allow you to register and consume content without using a username and password. To create an Activation Key see the Activation Key Guide

Once you have created an activation key, register with:

```
subscription-manager register --org=Default_Organization --activationkey=$KEY_NAME
```

Actions with registered Content Hosts
To see the list of your Content Hosts, navigate to Hosts > Content Hosts

Changing the Lifecycle Environment and Content View of a Content Host:

Navigate to the Content Host Details page, Host > Content Hosts > Click the name of the desired Content Host

Look in the upper right corner for the "Content Host Content":
Then select the new Lifecycle Environment you desire, select the new Content View you desire, and click save.

Assigning a Content Host to a Product

In order for a Content Host to receive package updates and access Repositories hosted on Katello, it needs to be subscribed to a product.

Navigate to Hosts > Content Hosts > Select Content Host > Subscriptions > Click the “Add” tab

Check the checkbox under the Products you want to add and select “Add Selected” in the upper right.

To see existing attached Products, click the “List/Remove” tab. To remove a Product, select the checkbox under the desired Product in this list and click “Remove Selected”.

Package Management

To perform package actions on a single Content Host, navigate to: Hosts > Content Hosts > Select Content Host > Packages
From here you can:

- See a list of installed packages
- Perform a yum install/update/remove of a Package or Package Group
- Update all packages (equivalent of running 'yum update')

**View and Install Applicable Errata**

If your synced Repositories contain Errata, you can use Katello's Errata management to track and install Errata.

Navigate to: Hosts > Content Hosts > Select Content Host > Errata

To apply errata, search for the errata you want and select the checkbox beside each errata. Then click “Apply Selected” at the top right.
The “Show From” filters what applicable errata to show:

- Current Environment - Shows only Applicable Errata available in the Host's Content View & Lifecycle Environment.
- Previous Environment - Shows Applicable Errata that are available from the Host's Content View but in the previous Lifecycle Environment. Promoting the Content View Version from that previous Lifecycle Environment to the current Lifecycle Environment for this Host would cause all Applicable Errata shown to then be available.
- Library Synced Content - Shows Applicable Errata which have been synced to the Library. This shows you what is applicable even when the Errata have not been published into a Content View. All applicable Errata are shown regardless of availability to the Content Host.

Change Host Collection Assignments

To change Host Collection assignments for a Content Host, navigate to: Hosts > Content Hosts > Select Content Host > Host Collections

Bulk Actions

Katello provides the ability to perform actions on many Content Hosts at once such as:

- Package installation/upgrade/removal
- Listing and applying applicable errata
- Assigning Host Collections
- Changing Lifecycle Environment and Content View assignments

In order to use the bulk actions, perform whatever search you desire and select which Content Hosts you want to modify. If you want to select all Content Hosts from a search result, click the 'checkbox' above the table:
This will select all Content Hosts on that page (only the ones that are visible). To select all that correspond to that search query, notice a bar has now appeared:

Next select the 'Bulk Actions' button in the top right.
From here you can select the tab corresponding to any action you wish to perform.
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.

View our Privacy Policy

This web site is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Source available: github/theforeman/theforeman.org

Thanks to our sponsors for hosting this website and our project services.
Content Views

What can a Content View be used for?

- To stage content through environments (Dev, Test, Production).
- To filter the contents of a repository (include a package or exclude certain errata, for example).
• To have multiple snapshots of the same repository and/or puppet modules.

Definitions

• Content View - snapshot of one or more repositories and/or puppet modules.
• Composite Content View - a Content View that contains a collection of other Content Views.
• Filter - provides finer grained control over content in a Content View. Can be used to include or exclude specific packages, package groups, or errata.
• Publishing - Content Views are 'published' in order to lock their contents in place. The content of the Content View is cloned and all filters applied. Publishing creates a new version of the Content View.
• Promoting - Content Views can be cloned to different Lifecycle Environments (Dev, Test, Production).

General Workflow

First create a product and repository in the library environment and populate the repository with content (by syncing it or uploading content). A Content Host can now register directly to library and be attached to the content therein. Updates will be available as soon as new content is synced or uploaded.

To utilize Content Views for filtering and snapshoting:

1. Create a Content View
2. Add the desired repository and/or puppet modules to the Content View
3. Optionally create one or more Filters to fine tune the content of the Content View.
4. Publish the Content View
5. Attach the Content Host to the Content View
6. Optionally promote the Content View to another environment

At this point the Content Host will no longer be getting content directly from Library, but from the Content View. Updates to library will not affect this Content Host.

Note that all of the actions below can also done with hammer, the CLI tool, and examples are given at the end of each section.

Creating a Content View

To create a Content View using the web UI, navigate to:

Content > Content Views

Click the Create New View button on the top right of the screen.

From the CLI:
Creating a Composite Content View

To create a Composite Content View using the web UI follow the above steps for Creating a Content View but check the “Composite View?” checkbox.

From the CLI:

```
hammer content-view create \
--organization="Default Organization" \
--name="New Composite Content View" \
--description="This is my new composite content view." \
--composite
```

Adding Repositories

Adding a repository to a Content View means whenever a Content View is published, all of the content contained within the repository at that time is included in the Content View. If the repository is synced after publishing the Content View, the Content View will contain the state of the repository prior to syncing. A new version of the Content View must be published in order for the new version to get the contents of the newly synced repository.

To add a repository using the web UI, navigate to:

Content > Content Views > Select the desired Content View > Content (within sub navigation) > Repositories

```
hammer content-view add-repository \
--organization="Default Organization" \
--name="New Content View" \
--repository="CentOS 6.5"
```

Adding a Puppet Module

Adding a puppet module to a Content View means that whenever the Content View is published the puppet module is locked to the version selected. If the “Use Latest” version is selected then the puppet module will be “frozen” at the latest version available when the Content View is published. A new version of the Content View must be published in order for the new version to get any updated puppet module.
To add a puppet module using the web UI, navigate to:

Content > Content Views > Select the desired Content View > Puppet Modules (within sub navigation)
From the CLI, first find the UUID of your puppet module from the list:

```
hammer puppet-module list
--organization="Default Organization"
--repository "Puppet Modules"
```

Then add the puppet module:

```
hammer content-view puppet-module add
--organization="Default Organization"
--content-view="New Content View"
--uuid=91cc9bb7-dbb3-4798-b50a-45173b763cbb
```

Adding Content Views to a Composite Content View

Adding a version of a Content View to a Composite Content View means whenever the Composite Content View is published, all of the content contained within the specific version of that Content View is contained in the Composite Content View. If the Content Views contained within the Composite Content View are updated (i.e. a new version is published) or if their content is
updated after publishing the Composite Content View, the Composite Content View will only contain the versions of the Content View(s) prior to syncing. A new version of the Composite Content View must be published in order for it to get the updated Content Views.

To add a Content View to a Composite Content View using the web UI, navigate to:
Content > Content Views > Select the desired Content View > Content (within sub navigation) > Repositories

Find the Content View ID of the specific version of the Content View to add:

```
hammer content-view version list \  
--organization="Default Organization" \  
--content-view="New Content View"
```

From the CLI, add a Content View to a composite Content View:

```
hammer content-view update \  
--organization="Default Organization" \  
--content-view="New Composite Content View" \  
--component-ids=2
```

Creating a filter

If only using Content Views as snapshots, Filters are unnecessary. If the desire is to filter what content make it into the view, such as blacklisting a package by name or version, or blacklisting errata by date or type, Filters can help accomplish these tasks.

To create a new Content View Filter using the web UI, navigate to:
Content > Content Views > Select the desired Content View > Content (within sub navigation) > Filters > New Filter
New Content View

Add New Filter

- Name:
- Content Type:
- Package:
- Type:
- Evaluate:
- Description:

Create
From the CLI, adding a Content View Filter:

```
hammer content-view filter create \
   --organization="Default Organization" \ 
   --content-view="New Content View" \ 
   --name="New Filter" \ 
   --inclusion=false \ 
   --type=rpm
```

From the CLI, adding a Content View Filter rule:

```
hammer content-view filter rule create \
   --organization="Default Organization" \ 
   --content-view="New Content View" \ 
   --content-view-filter="New Filter" \ 
   --name="something-else" \ 
   --max-version="10.0.0" \ 
   --min-version="10.0.0"
```

Selecting which Repositories to Filter

By default a Filter applies to all repositories (present and future) in the Content View. It’s possible to select which repositories within the Content View apply to the filter. This is useful, for example, if the desire is to exclude errata from only certain repositories in a view.

To select which repositories to Filter in the web UI, navigate to:

Content > Content Views > Select the desired Content View > Content (within sub navigation) > Filters > Select the desired Filter > Affected repositories (within sub navigation)
From the CLI, adding a Content View Filter:

```
hammer content-view filter update
   --organization="Default Organization"
   --name="New Filter"
   --repository-ids=2,3,7
```

Publishing a Content View

Publishing a Content View produces a new version of the content view that is subsequently promoted to the Library lifecycle environment. This newly published version of the content view is now available to any content host registered to Library.

To publish a Content View, in the web UI, navigate to:

Content > Content Views > Select the desired Content View > Publish New Version
From the CLI:

```
hammer content-view publish \n  --organization="Default Organization" \n  --name="New Content View"
```

Registering a Content Host

To register a Content Host that is not currently registered to the Content View, simply use `subscription-manager` on the client Content Host and run:

```
subscription-manager register --org=ACME_Corporation --environment=Library/my_rhel_view
```

This would register the Content Host to the Library environment and the `my_rhel_view` Content View.

If the Content Host is already registered, from the UI:

Hosts > Content Hosts > Select the desired Content Host
Initially a Content View is published to Library as version 1. If there are Content Hosts in other environments that would like to consume this Content View, a version of the content view will need to be promoted to those environments. For example, given the Content View “New Content View”, version 1 of which has been promoted to the Dev environment. Any Content Hosts in Dev attached to the Content View would remain at version 1 until a version 2 is both published and promoted to the Dev environment.

To promote a Content View in the Web UI, navigate to:

Content > Content Views > Select the desired Content View > Versions (within sub navigation) > Click promote for desired version
New Content View

Version | Status | Environments | Content | Author | Actions
---|---|---|---|---|---
Version 1 | Published, (W/03/14 3:37 PM) | Library | 487 Packages | | Promote

Choose one or more lifecycle environments from the existing promotion paths available in Habitat.
To promote a Content View in the CLI:

```
hammer content-view version promote \
  --organization="Default Organization" \
  --content-view="New Content View" \
  --to-lifecycle-environment="Test" \
  --version 1
```

Foreman 2.3.3 has been released! Follow the quick start to install it.

Foreman 2.2.2 has been released! Follow the quick start to install it.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients

2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet

3. Release Notes

4. CLI

5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content

6. Troubleshooting

Katello Inter-Server Sync

NOTE: This feature is intended to replace the 'katello-disconnected' script.
If you are working in an air-gapped network environment where some of your Katello servers do not have Internet connectivity, you may be interested in using the Katello Inter-Server Sync (ISS) feature. This allows you to export repos, including repos in content views, on your “upstream” Katello server, and then import said repos into your “downstream” server that does not have connectivity. Individual repos can be exported, or all of the repos in a content view.

List of currently supported repo content types:
- yum

Future releases will enable support for additional content types.

The diagram above shows an example scenario where a user wants to export all Yum content in a content view and then import to another Katello server. The ISO file is burned to media and then walked across the air-gap in the network.

**Detailed Operation**

**Exporting**

The ISS feature allows users to move Yum content from one Katello server to another, in a way that is compatible with air-gapped networks. Typically users will set up an upstream server that is connected to the Internet, and then create a content view that contains Yum content that they would like to present to the downstream server (step 1).
Content is exported via either `hammer repository export` or `hammer content-view version export` (step 2). It is exported to the location set in “pulp_export_destination” in the Settings page, under the Katello tab. This defaults to `/var/lib/pulp/katello_export`. Please be aware that the location needs to be readable and writable by the `foreman` user.

You can select to either export as a plain set of directories, or as a set of ISO files. The “iso_size_mb” parameter sets how large you would like each ISO file to be. It defaults to 4380 MB, which is the size of a single-side, single-layer DVD.

**Importing**

Importing (step 3) can be done in one of two ways. The first way is to make the export available via HTTP to the importing Katello instance. Simply put the export in `/var/www/html/pub/export`, either via copy or symlink. After that, edit your CDN location from the manifest import page to point to “http://export/path/to/export” and the Red Hat Repos page will then work as expected, using your exported data. Please be sure to use ‘http’ and not ‘https’ when altering the CDN url. Katello by default only supports the CA certificate for `cdn.redhat.com`. This is a [known limitation](http://projects.theforeman.org/issues/16392) that will be addressed in a future version.

The second way is to perform a repository sync via hammer, specifying the source location. Please see the `hammer repository sync` command for more information. This method is the only way to import custom content, and is the only way to import incremental content.
Docker Management

Katello can be used to manage and deploy Docker content. Katello can retrieve Docker content from a variety of sources such as Docker hub, private Docker registries, the Red Hat CDN, and so forth. Docker content can then be published and promoted via Content Views and then pulled or provisioned to a server running Docker.
What is Docker?

Docker is a tool used to manage Linux containers. To read more about Docker, check out the official Docker site. Docker repositories, which contain images and tags, can be retrieved, stored, managed, and deployed from Katello.

How to sync a Docker repository

The easiest way to get Docker content into Katello is to sync it in. You can either sync Docker content from the Red Hat CDN (if you have subscriptions for the content) or from a registry such as Docker Hub.

Red Hat Docker Images

Content can be synced into Katello using a Red Hat manifest in much the same way as yum content. See our guide on how to manage Red Hat content for more information.

Docker Hub/Docker Registry

To sync content from a Docker registry such as Docker Hub (which is the official Docker-run registry), simply start by creating a new Repository.

On the new Repository screen, select “Docker” as the content type. Once you do that, you’ll be given two options: upstream name and URL. The URL will be the registry URL; for Docker Hub, this would be https://registry.hub.docker.com.

For the upstream name, you want to use the fully qualified upstream name which also includes any namespace such as the username. This can be just “busybox” if the Repository is an official Docker Hub Repository or it can be something like “fedora/ssh” where “fedora” is the username/namespace.

Then click save and then sync the Repository as you normally would. Katello will fetch all the images and tags contained within that Repository.

How to Upload Docker Images

In versions of Katello prior to 3.0, Docker images could be uploaded directly via either the UI or CLI. However, Katello 3.0 only supports the Docker Registry v2 format, which is significantly different than the Docker Registry v1 format. The docker save command outputs a Docker image in v1 format, which cannot be uploaded directly to a v2 repository.

As a workaround, you can create a local Docker registry like so:
Note the `v2` above, which specifies a v2 registry. Push your changes to your newly created local registry then follow the instructions in the section above to sync this registry to Katello. This will ensure that your Docker content stays in Docker’s v2 registry format.

### How to Publish and Promote Docker Content

Docker content can be published and promoted via Content Views much like yum or puppet content.

After creating a Content View, visit the Docker Content tab. Here you can select any Docker repositories you want to add to your Content View. After you’ve added Docker Repositories to your view, you may proceed as normal. Visit the Content View user guide for more information.

### How to View and Pull Docker Content

To view Docker content contained with Katello, visit the Docker Tags page. This can be accessed under the Content menu at the top of any page.
On the Docker Tags page, you can see a list of Docker Tags grouped by Repository in Katello. This shows you Tags grouped across Content Views and Lifecycle Environments. Suppose I wanted to pull the latest Tag from my redis repository, I would click the latest row for my redis repository.

<table>
<thead>
<tr>
<th>Name</th>
<th>Product Name</th>
<th>Repository Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.8.14</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.15</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.16</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.17</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.18</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.19</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.6</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.7</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.8</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>2.8.9</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>buildroot-2013.08.1</td>
<td>Tester</td>
<td>busybox</td>
</tr>
<tr>
<td>buildroot-2014.02</td>
<td>Tester</td>
<td>busybox</td>
</tr>
<tr>
<td>latest</td>
<td>Tester</td>
<td>tester</td>
</tr>
<tr>
<td>latest</td>
<td>Tester</td>
<td>redis</td>
</tr>
<tr>
<td>ubuntu-12.04</td>
<td>Tester</td>
<td>busybox</td>
</tr>
<tr>
<td>ubuntu-14.04</td>
<td>Tester</td>
<td>busybox</td>
</tr>
</tbody>
</table>
I can see here that my redis Repository has been added to a published Content View called redisv. If I want to use the tag from that Content View, I would just copy the Published At URL and then on my docker server I would run:

```
$ docker pull localhost:5000/default_organization-library-redisv-Tester-redis:latest
```

How to Provision Docker Content

See how to provision content in the documentation in the [foreman-docker documentation](#). Provisioning content from Katello works in much the same way.

First, proceed to the new Container page by accessing it from the Containers menu at the top. Then, select the Local Content tab on the second step. This will allow you to select a Docker image from a published Katello repository which is in an environment/content view/capsule. Then just proceed in the wizard as per the Foreman Docker instructions. When you are finished, you should have a new container running from an image in Katello.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Email Notifications

Types of Email Notifications

In addition to the Email Notifications that Foreman provides:
- Puppet run summary (Daily/Weekly/Monthly)
- Puppet errors

Katello provides a few addition reports:

- Katello Host Advisory (Daily/Weekly/Monthly) - A report of all of the Errata applicable to all readable Content Hosts
- Katello Promote Errata - A report generated at Content View promotion time showing what Errata applicable to the Content Hosts within that Content View.
- Katello Sync Errata - A report generated after each Repository sync listing new Errata synced and how many Content Hosts are applicable.

**Configuring the Foreman/Katello to send emails:**

The configuration on how the Foreman/Katello service sends email is located in `/etc/foreman/email.yaml`:

production:
  delivery_method: :smtp
  smtp_settings:
    address: smtp.example.com
    port: 25
    domain: example.com
    authentication: :none

For more information see: [Email Configuration](#)

**Opting in to the emails**

By default a user will receive no email notifications. Each notification must be opted into.

To opt in for your own user, at the very top right of the web interface, hover over your Username, click “My Account” and then click the “Mail Preferences” tab.

To opt in for other users, navigate to “Administer” > “Users” > Click the desired User > click the “Mail Preferences” tab.

Select which emails and frequency you would like the user to have and click “Submit”.

<table>
<thead>
<tr>
<th>User</th>
<th>Mail Preferences</th>
<th>Locations</th>
<th>Organizations</th>
<th>Roles</th>
</tr>
</thead>
</table>

**Foreman**

**Foreman 2.3.3 has been released!** Follow the quick start to install it.

**Foreman 2.2.2 has been released!** Follow the quick start to install it.
Errata

Errata are updates between major releases. An Erratum is metadata about a group of packages that explains the importance of the package updates. Errata may be released individually on an as-needed basis or aggregated as a minor release. There are three main types of errata:
• Enhancement: the new packages contain one or more added features
• Bugfix: the new packages contain one or more bug fixes
• Security: the new packages fix one or more security vulnerabilities

With regard to Content Hosts, Errata is divided into two distinct classifications depending on whether or not the Errata is present in the Content Host’s Lifecycle Environment and Content View:

• Applicable: the errata applies to one or more Content Hosts
• Installable: the errata applies to one or more Content Hosts and is present in the Content Host’s Lifecycle Environment and Content View

Definitions
• Content Host
• Content View
• Lifecycle Environment

General Features
The following is a high-level summary of the Errata features:

• View List of Errata
• View Errata Details
• View Affected Content Hosts
• View Repositories Containing Errata
• Applying Errata

View List of Errata
To view the list of Errata in the Organization:

• navigate to: Content > Errata

<table>
<thead>
<tr>
<th>Errata</th>
<th>Type</th>
<th>Affected Content Hosts</th>
<th>Updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>R-GA-2014-1684</td>
<td>Important: bird security update</td>
<td>Security Advisory - Important</td>
<td>1/11/14</td>
</tr>
<tr>
<td>R-GA-2014-1683</td>
<td>Important: mgz e11 server security update</td>
<td>Security Advisory - Important</td>
<td>1/11/14</td>
</tr>
<tr>
<td>R-GA-2014-1676</td>
<td>dovecot bug fix update</td>
<td>Bug Fix Advisory</td>
<td>1/9/14</td>
</tr>
<tr>
<td>R-GA-2014-1674</td>
<td>Important: rpm security update</td>
<td>Security Advisory - Important</td>
<td>1/9/14</td>
</tr>
<tr>
<td>R-GA-2014-1674</td>
<td>selinux policy bug fix update</td>
<td>Bug Fix Advisory</td>
<td>1/9/14</td>
</tr>
<tr>
<td>R-GA-2014-1675</td>
<td>httpd bug fix update</td>
<td>Bug Fix Advisory</td>
<td>1/6/14</td>
</tr>
<tr>
<td>R-GA-2014-1671</td>
<td>systemctl-fileset bug fix update</td>
<td>Bug Fix Advisory</td>
<td>12/4/14</td>
</tr>
<tr>
<td>R-GA-2014-1679</td>
<td>Important: rdo, open-svc, and nw-nfsd security, bug fix, and enhancement update</td>
<td>Security Advisory - Important</td>
<td>12/1/14</td>
</tr>
<tr>
<td>R-ESA-2014-1513</td>
<td>qconf enhancement update</td>
<td>Product Enhancement Advisory</td>
<td>11/30/14</td>
</tr>
<tr>
<td>R-ESA-2014-1510</td>
<td>courier-real bug fix update</td>
<td>Bug Fix Advisory</td>
<td>11/18/14</td>
</tr>
<tr>
<td>R-ESA-2014-1503</td>
<td>weekly and group bug fix update</td>
<td>Bug Fix Advisory</td>
<td>11/18/14</td>
</tr>
<tr>
<td>R-ESA-2014-1513</td>
<td>device mapper multipath bug fix update</td>
<td>Bug Fix Advisory</td>
<td>11/18/14</td>
</tr>
</tbody>
</table>

View Errata Details
To view the details of an Errata:

• navigate to: Content > Errata
• Click on an Errata ID
View Affected Content Hosts

To view the Affected Content Hosts of an Errata:

- navigate to: Content > Errata
- Click on an Errata ID
- Click on the Content Hosts Tab

Note the following option:

- Checking the box limits the display of Content Hosts to those which already have the Errata available in their Lifecycle Environment and Content View.
View Repositories Containing Errata

To view the Repositories Containing an Errata:

- navigate to: Content > Errata
- Click on an Errata ID
- Click on the Repositories Tab

Note that you can filter by Lifecycle Environment and Content View.

Applying Errata

How Errata is applied to a Content Host(s) depends on whether the Errata is installable.

- If the Errata is already installable then the Errata is applied to the Content Host(s).
- If the Errata is not installable then an Incremental Update is generated. An Incremental Update creates a point release of the Content View with the Errata included. The Errata can also be applied to the Content Host(s) as part of this process.

There are two ways to apply Errata:

- A single Errata can be applied to one or more Content Hosts
- Several Errata can be applied to one or more Content Hosts via a bulk operation

Applying a Single Errata

To apply a single Errata:

- Navigate to: Content > Errata
- Click on an Errata ID
- Click on the Content Host tab
- Select the desired Content Hosts
- Click “Apply to Hosts”
- Confirm the action
Applying Several Errata

To apply several Errata:

- Navigate to: Content > Errata
- Select the desired Errata
- Click “Apply Errata”
- Select the intended Content Hosts
- Click “Next”
- Confirm the action
### Foreman Errata Section

The page displays a table of errata with columns for `Errata ID`, `Title`, `Type`, `Content Host Counts`, and `Updated`. Each row of the table includes details such as...

- **RHBA-2014:1948**: Security Advisory - Important
- **RHBA-2014:1875**: device-mapper-multipath bug fix update
- **RHBA-2014:1866**: qtdata enhancement update
- **RHBA-2014:1733**: qtdata enhancement update
- **RHBA-2014:1637**: at bug fix update
- **RHBA-2014:1515**: audit bug fix and enhancement update
- **RHBA-2014:1426**: openipath bug fix and enhancement update
- **RHBA-2014:1378**: ras bug fix and enhancement update
- **RHBA-2014:1376**: xcb-util xcb-x11-drivers, and mesa bug fix and enhancement update
- **RHBA-2014:1472**: elfutils bug fix and enhancement update
- **RHBA-2014:1332**: illx3 enhancement update
- **RHBA-2014:1330**: new packages: json-c
- **RHBA-2014:1384**: subscription-manager bug fix and

### Apply Errata Section

The page also includes a section for applying errata, allowing users to select content hosts where errata are available in the host's Lifecycle Environment. The form includes fields for filter by environment, search, and selecting hosts.
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Glossary

The following terms are used throughout this document, and are important for the users understanding of Katello.

**Activation Key**
A registration token which can be used in a kickstart file to control actions at registration. These are similar to Activation Keys.
in Spacewalk, but they provide a subset of features because after registration, Puppet takes control of package and configuration management.

**Application Lifecycle Environment**
Steps in a promotion path through the Software (Development) Life Cycle (SDLC). Content (packages, puppet modules) can be moved through lifecycle environments via content view publishing/promotion. Traditionally these environments are things like Development -> Test -> Production. Channel cloning was used to implement this concept for this in Spacewalk.

**Attach**
Associating a Subscription to a Host which provides access to RPM content.

**Capsule**
An additional “server” that can be used in a Katello deployment to facilitate content federation and distribution in addition to other localized services (Puppet master, DHCP, DNS, TFTP, and more).

**Change Set**
Set of packages and puppet modules which are promoted between Application Lifecycle Environments. Katello records the progress of changesets as they promoted. Katello also provides audit capabilities to review how environments have changed over time.

**Compute Profile**
Default attributes for new virtual machines on a compute resource.

**Compute Resource**
A virtual fabric, or cloud infrastructure, where hosts can be deployed by Katello. Examples include RHEV-M, OpenStack, EC2, and VMWare.

**Content**
Software packages (RPMS), Package Groups, Errata, and Puppet modules. These are synced into the Library and then promoted into Lifecycle Environments via Content Views in order to be used/consumed by Hosts.

**Content Delivery Network (CDN)**
The mechanism to deliver Red Hat content in a geographically co-located fashion. For example, content which is synced by a Katello in Europe will pull content from a source in Europe.

**Content View**
A definition of content that combines products, packages, errata and Puppet modules, with capabilities for intelligent filtering and snapshotting. Content Views are a refinement of the combination of channels and cloning from Spacewalk.

**External Node Classifier**
A Puppet construct that provides additional data for a Puppet master to be used for configuring Hosts. Foreman acts as an External Node Classifier to Puppet Masters in a Satellite deployment.

**Facter**
A program that provides information (facts) about the system on which it is run (eg: total memory, operating system version, architecture, etc.) Facter facts can be used in Puppet modules in order to enable specific configurations based on Host data.

**Hammer**
The command line tool for Katello. Hammer can be used as a standard cli (and used in scripts) and can also be used as a shell in the same way that spacecmd, virsh and others work.

**Host**
A system, either physical or virtual, which is managed by Katello.

**Host Group**
A template for how a Host should be built. This includes the content view (which defines the available RPMs and Puppet modules), and the Puppet classes to apply (which determines the ultimate software and configuration).

**Location**
A collection of default settings which represent a physical place. These can be nested so that a user can set up defaults, for example, for Europe, which are refined by Tel Aviv, which are refined by DataCenter East, and then finally by Rack 22.

**Library**
The Library is the single origin of all content which can be used. If you are an Information Technology Infrastructure Library (ITIL) shop, it is your definitive media library.

**Manifest**
The means of transferring subscriptions from a Subscription Provider (such as the Red Hat Customer portal) to Katello. This is similar in function to certificates used with Spacewalk.

**Organization**
A tenant in Katello. Organizations, or orgs, are isolated collections of hosts, content and other functionality within a Katello deployment.

**Permission**
The ability to perform an action.

**Product**
A collection of content repositories.

**Promote**
The act of moving content from one Application Lifecycle Environment to another.

**Provisioning Template**
User defined templates for Kickstarts, snippets and other provisioning actions. These provide similar functionality to Kickstart Profiles and Snippets in Katello.

**Puppet Agent**
An agent that runs on a Host that applies configuration changes to that Host.

**Puppet Class**
A Puppet Class is re-usable named block of puppet manifest, similar to a class in an object-oriented programming language. Puppet classes must be included/instantiated in order to use their functionality. Puppet Classes can be parameterized - they can take parameters when they are included/instantiated and those parameters may be used by the underlying manifest to affect the ultimate configuration.

**Puppet Manifest**
A Manifest is a simple set of Puppet instructions. Manifests typically have the .pp extension. A manifest is much like a procedure in programming terms.

**Puppet Master**
A Capsule component that provides Puppet manifests to Hosts for execution by the Puppet Agent.

**Puppet Module**
A Puppet Module is a set of Puppet manifests/classes, template files, tests and other components packaged together in a specific directory format. Puppet Modules are typically associated with specific software (eg: NTP, Apache, etc) and contain various classes used to assist in the installation and configuration of that software. Puppet Labs maintains a repository of official and user-contributed modules called the Puppet Forge.

**Pulp Node**
A Capsule component that mirrors content. This is similar to the Spacewalk Proxy in Spacewalk. The main difference is that content can be pre-staged on the Pulp Node before it is used by a Host.

**Repository**
A collection of content (yum repository, puppet repository).

**Role**
A collection of permissions that are applied to a set of resources (such as Hosts).

**Smart Proxy**
A Capsule component that can integrate with external services, such as DNS or DHCP.

**Smart Variable**
A configuration value that controls how a Puppet Class behaves. This can be set on a Host, a Host Group, an Organization, or a Location.

**Standard Operating Environment (SOE)**
A controlled version of the operating system on which applications are deployed.

**Subscription**
The right to receive content and service from Red Hat. This is purchased by customers.

**Syncing**
Mirroring content from external resources into an organization's Library.

**Sync Plans**
Scheduled execution of syncing content.

**Usergroup**
A collection of roles which can be assigned to a collection of users. This is similar to the Role in Spacewalk.

**User**
A human who works in Katello. Authentication and authorization can be done via built in logic, or using external LDAP or kerberos resources.
Managing Content Hosts using GPG Keys

GPG Keys provide a way to verify the integrity of packages found within a Repository and/or Product. Once one or more GPG Keys have been created, they can be associated with a Product or Repository during creation or by editing an existing Product or Repository.
For more information on GPG Keys see [The GNU Privacy Guard](https://www.gnupg.org/).

## General Features

The following is a high-level summary of GPG Key features:

- **Create a GPG Key**
- **View Associated Products**
- **View Associated Repositories**
- **Associate GPG Key with Product**

### Create a GPG Key

To create a new GPG Key:

- navigate to: `Content > GPG Keys`
- click **New GPG Key**

Note that you may either upload your GPG Key or simply paste in the contents.

![New GPG Key](image)

### View Associated Products

To view all Products that have been assigned a GPG Key:

- navigate to: `Content > GPG Keys`
- select the desired GPG Key from the list
- click **Products**
View Associated Repositories

To view all Repositories that have been assigned a GPG Key:

- navigate to: Content > GPG Keys
- select the desired GPG Key from the list
- click Repositories
Associate GPG Key with Product

To add a GPG to a Product:

Note that adding a GPG Key to a Product adds the GPG Key to all current and future repositories unless a repository already has a GPG Key assigned. This can also be overridden by assigning a GPG Key to an individual repository afterward as well.

- navigate to: Content > Products
- select the desired Product from the list
- click Details
- click the edit button on the GPG Key field
- select the desired GPG Key
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Managing Content Hosts using Host Collections

Host Collections provide a mechanism to statically group multiple Content Hosts. This enables administrators to group Content Hosts based on the needs of their organization. For example, Content Hosts could be grouped by function, department or business unit.
Once a Host Collection is created, it can be used to perform various actions on the Content Hosts contained within it. This includes actions such as the following:

- Package installation, removal and update
- Errata installation
- Changing of assigned Lifecycle Environment or Content View

Definitions

- **Content Host**

General Features

The following is a high-level summary of the Host Collection features:

- Create a Host Collection
- Add Content Hosts to a Host Collection
- Copy a Host Collection
- Perform actions on a Host Collection

Create a Host Collection

To create a new collection,

- navigate to: Hosts > Host Collections
- click **New Host Collection**

Note the following option:

- **Content Host Limit**: This option will control how many Content Hosts are allowed to be added to the collection.

Add Content Hosts to a Host Collection

To add Content Hosts to a collection:

- navigate to: Hosts > Host Collections
• select the desired collection from the list
• click **Content Hosts**
• click **Add**
• select the Content Hosts you would like to add
• click **Add Selected**

Copy a Host Collection

Copying a Host Collection allows a user to quickly create a new collection that is a copy of an existing one.

To copy a Host Collection:

• navigate to: Hosts > Host Collections
• select the desired collection from the list
• click **Copy Collection**
• enter a name for the new collection
• click **Create**
Perform Actions on a Host Collection

To perform an action on Content Hosts within a collection:

- navigate to: Hosts > Host Collections
- select the desired collection from the list
- click Collection Actions
- click on the action that you would like to perform
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Lifecycle Environments

What can a Lifecycle Environments be used for?

- Hold content view versions.
- To manage the lifecycle of Content Hosts.
Establish workflow containers and promote content views.

**Definitions**

- Lifecycle Environment - containers for content view versions which are consumed by content hosts.
- Library - a special kind of Lifecycle Environment that does not have a parent. The library serves as the main container for synced content such as products, puppet modules, and published content views. Every organization has a library. Subsequent environments are derived from the library. The first node of an environment is the Library, all future environments are derived from the library and follow the library in promotion order.
- Lifecycle Environment Path - Sequence of lifecycle environments that form the content promotion order.

**General Workflow**

First create a lifecycle environment connected to the library life cycle environment and promote content views to the new lifecycle environment. A Content Host can now register directly to the promoted content view in the promoted environment or library therein. Updates will be available as soon as new content is synced and promoted.

**Viewing the list of lifecycle environments**

From the web UI, navigate to:

Content -> Lifecycle Environments

![Lifecycle Environment Paths](image)

**Creating a lifecycle environment**

Click on the + next to the Library or the prior environment to add a new path
Creating a lifecycle environment path

Click on the New Environment Path

Click on the New Environment Path
View/Updating environment name

Click on the name of the environment.

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Provisioning

See the Foreman manual for general information on configuring provisioning.
Templates

Katello ships a number of templates in addition to the standard Foreman ones. When using these templates, if a host has a Host group with an Activation Key, it will register as a Content Host automatically.

- **Katello Kickstart Default** - Kickstart template for Fedora, CentOS, RHEL, and other Red Hat-compatible operating systems.
- **Katello Kickstart Default Finish** - image-based provisioning
- **Katello Kickstart Default User Data** - cloud-init template for EC2 and OpenStack
- **subscription_manager_registration** - Snippet for registering a host for content

To customize any of the above templates, simply clone them and add your changes.

When you synchronize a repository with a distribution such as Fedora or CentOS, Katello will automatically create the operating system and assign these default templates. You may change the defaults by going to Administer > Settings, and selecting the Katello tab.
Managing Puppet Content

Importing the Puppet Forge

The **Puppet Forge** is a collection of puppet modules written by the community which can be used to manage hosts in Katello.
These modules can be used in content views as described in the content views guide in order to configure the running hosts.

To import the puppet forge navigate to
Content > Products

Click on the +New Product button.

Once the product is created, select the product and click the Create Repository button. Fill out the repository as shown:

This can be done via the CLI:

```
hammer product create
   --organization "Default Organization"
   --name Puppet

hammer repository create
   --organization "Default Organization"
   --product Puppet
   --name forge
   --content-type puppet
   --url "https://forge.puppetlabs.com/

mkdir /modules
chmod 755 /modules
pulp-puppet-module-builder --output-dir=/modules --url=git@mygitserver.com:mymodules.git --branch=develop
```

The repository can now be synced.

Importing Puppet Modules from Git

In order to allow users to import puppet modules from Git repositories, Katello comes with a tool called ‘pulp-puppet-module-builder’ from the pulp-puppet-tools RPM. This utility will be available on the Katello server but it can also be installed on another machine if desired. By running the ‘pulp-puppet-module-builder’ against a Git repository, it will checkout the repository, build all of the modules, and publish them in a structure Katello can synchronize.

The most common method is to run the utility on the Katello server itself and publish to a local file system directory and sync against that directory.

```
mkdir /modules
chmod 755 /modules
pulp-puppet-module-builder --output-dir=/modules --url=git@mygitserver.com:mymodules.git --branch=develop
```

This will checkout the ‘develop’ branch of the Git repository located at ‘git@mygitserver.com:mymodules.git’ and publish them to the /modules directory. If you have SELinux enabled, in order to sync from the file system, you'll need to apply a label to the files in order for the system to access them. Two options are httpd_sys_r_content_t or pulp_tmp_t. Note: if you choose httpd_sys_r_content_t then the webserver can also read the files so that may or may not be good. One way to apply these
labels would be to use the chcon command.

Next, from within Katello, simply set the url on your Puppet Repository to ‘file://modules’. You can now sync the Repository just like any other Repository.

If you are running this on a remote machine, you will need to publish the containing to folder to a location accessible by HTTP or HTTPS.

```
mkdir /var/www/html/modules/  
chmod 755 /var/www/html/modules/  
pulp-puppet-module-builder --output-dir=/var/www/html/modules --url=git@mygitserver.com:mymodules.git --branch=develop
```

Then in Katello, simply enter ‘http://HOSTNAME/modules/’ for the Repository url and sync it like you normally would.

---

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Red Hat Content

Katello can be used to manage content associated with Red Hat products based upon available subscriptions. This includes content such as RPMs, package groups, errata and distributions.
Definitions

- Subscription Manifest - An archive file containing certificates and data that represent the subscriptions that are available. A subscription manifest is created and downloaded from the Red Hat Customer Portal.
- Repository - Collection of content (either rpm or puppet).
- Product - Collection of repositories (content hosts attach to a product).
- Library - The initial lifecycle environment where repositories are created. Content that is synced or uploaded lands in the library.

General Workflow

The following is a high-level summary of the workflow:

- Create a subscription manifest using the Red Hat Customer Portal
- Import the subscription manifest
- Enable Red Hat repositories
- Synchronize repositories
- Schedule repository synchronization
- Attach a content host to a product for Red Hat content

Create a Subscription Manifest Using the Red Hat Customer Portal

If you are a Red Hat customer, you should have access to the Red Hat Customer Portal to create and download a subscription manifest. Once created, the manifest can be imported into a Katello Organization.

To access the Red Hat Customer Portal, click here
For details on how to create a subscription manifest, click here

Import the Subscription Manifest

Importing a subscription manifest will allow for Red Hat content associated with purchased subscriptions to be enabled and synchronized to Katello.

To import a manifest,

- navigate to: Content > Red Hat Subscriptions
- click Choose File
- navigate to the file containing the manifest (e.g. manifest.zip)
- click Open
- click Upload
Enable Red Hat Repositories

Once a subscription manifest is imported, access is available to potentially hundreds of Red Hat Repositories (e.g. Red Hat Enterprise Linux Server, Red Hat Enterprise Virtualization...etc). This process allows you to select only those that you are interested in for your enterprise.

To enable Red Hat repositories,

- navigate to: Content > Red Hat Repositories
- select the content type: RPMs, Source RPMs, Debug RPMs, Beta, ISOs or Other
- select one or more Red Hat products (e.g. Red Hat Enterprise Linux Server)
- select one or more Repository Sets (e.g. Red Hat Enterprise Linux 6 Server (RPMs))
- select one or more Repositories (e.g. Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server)

Note:

- When enabling a RHEL repository, Red Hat recommends selecting the Server repo (e.g. 6Server, 5Server) versus a specific release (e.g. 6.2). When a specific release is necessary, the preferred way is to create a Content View with filters that narrow the content to the desired version (e.g. 6.2)
- If you plan to provision content hosts, be sure to enable both the RPM and Kickstart repositories.
Expand each Red Hat Product below to examine the different repository sets available. When enabling a repository set, the different repositories within are discovered and may be enabled individually.

### Enable Red Hat Repositories

<table>
<thead>
<tr>
<th>RPMs</th>
<th>Source RPMs</th>
<th>Debug RPMs</th>
<th>Beta</th>
<th>ISOs</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODUCT</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux High Availability for RHEL Server</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux Load Balancer for RHEL Server</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux Resilient Storage for RHEL Server</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux Server</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux Workstation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Synchronize Repositories

Synchronizing a repository will retrieve all associated content and mirror the content in the Katello Library lifecycle environment.

To sync multiple repositories as well as track their progress,
- navigate to: Content > Sync Status
- expand the desired products
- select the repositories to sync
- click Synchronize Now
Schedule Repository Synchronization

Creating a Sync Plan

Sync plans provide the ability to schedule repository synchronization on a daily, weekly or a monthly basis. Sync plans can be applied individually or to a set of repositories.

To create a Sync Plan:

- navigate to: Content > Sync Plans
- click New Sync Plan on the upper right

Note the following options:

- **Start Date and Start Time**: specify the day of the week/month and time of the day to run the recurring syncs. For example, a sync plan that starts on Sunday 2014-04-06 at 2:30 will occur every Sunday at 2:30 every week if it has a weekly interval. If on a monthly interval it would sync every month on the 6th day at 2:30.
Assigning a Sync Plan to a Red Hat Product

To assign a sync plan to a product,

- navigate to Content > Sync Plans
- select your Sync Plan
- click Products
- click Add
- select the products that you want to add
- click Add Selected on the upper right
Attach a Content Host to a Product for Red Hat Content

To read about registering a content host and subscribing it to a product, click TODO.

Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.
Katello 3.2 Documentation

1. Installation
   1.1 Katello
   1.2 Capsule
   1.3 Clients
2. Upgrade
   2.1 Katello
   2.2 Capsule
   2.3 Clients
   2.4 Puppet
3. Release Notes
4. CLI
5. User Guide
   5.1 Activation Keys
   5.2 Backup
   5.3 Capsules
   5.4 Content
   5.5 Content Hosts
   5.6 Content Views
   5.7 Disconnected
   5.8 Docker Management
   5.9 Email Notifications
   5.10 Errata
   5.11 Glossary
   5.12 GPG Keys
   5.13 Host Collections
   5.14 Lifecycle Environments
   5.15 Provisioning
   5.16 Puppet Integration
   5.17 Red Hat Content
6. Troubleshooting

Katello Troubleshooting
For general support information, see here.

Table of Contents

- Sub-service Status
Sub-services status

Katello uses a set of back-end services to perform the actual job. The status of these services can negatively influence the whole system and it's one of the first things to check when some errors occur.

The status of back-end services can be found either from the Web UI on the /about page:

![Backend System Status](image)

Alternatively, the hammer ping command can be used to get this information.

katello-service tool can be used to restart Katello related services. See man katello-service for more details.

Tasks

Katello uses Foreman Tasks for orchestration between the underlying services (local database, Pulp, Candlepin...). The tasks are modeled as Dynflow processes. When something goes wrong (and there might be many reasons for this happening), Dynflow gives us the tools to recover from these errors to get to the consistent state.

Health checking

There are two properties used for identifying issues with a task:

- **state** - what phase of execution is the task in, possible values are:
  - **planning** - the planning phase of the task is performed: the operations performed in this phase shouldn't modify anything outside Katello's database. The execution of this phase happens in the web-process thread and usually should not take more than few seconds
  - **planned** - the planning phase finished and the task is waiting for the executor process (foreman-tasks service) to pick it up
  - **running** - the executor is performing the orchestration action, modifying the state of external services to converge to the final state
  - **paused** - something went wrong during running the task and it's waiting for the resolution (further details below)
  - **stopped** - the execution of the task finished (the success is determined by the result value)
  - **result** - how the task ended up (or is going to end up if we already know it)
  - **pending** - task is in the process of executing
  - **success** - no errors occurred during the execution
  - **error** - unresolved errors occurred during the execution
  - **warning** - there were errors during the execution, but they did not prevent the task from finishing or were skipped manually (further details below).

To see all the tasks in the system, one can go to /foreman_tasks/tasks page. To see all the tasks that failed, one can search on
Failed tasks include those in the 'stopped' or 'paused' state. The stopped tasks are already considered as resolved, there is no risk of inconsistency. The tasks in the 'stopped' state and the 'error' result are usually those failed during the planning phase (usually locking error or bad input data).

To see all the tasks requiring further assistance, filter on `state = paused`:

Dealing with paused task

Once the paused task is identified, one can investigate the problem causing the errors:
The resolution of the problem is dependent on the error details. The task may be resolvable by resuming the task: make sure the sub-services are running (see Sub-services status for more details) and then click 'Resume' within the web interface.

If this still doesn't help, one possible step is going to a Dynflow console (the button from task details takes you there):

Caution: Dynflow console is considered a low-level tool and should be used very carefully, ideally discussing other options before using its features.

If the failed task was taken care of by other means (performing the failed steps manually) or it was identified as not critical to the whole task, one can skip the failed step and resume the task to continue. These tasks end up with warning result at the end, to indicate there was some difficulty during the run.

Dealing with Long Running Tasks

In some cases, there might be an issue with sub-services that make it appear as if the task is running for too long without any obvious evidence that something is occurring within the task.

The first place to look in this case is filtering the tasks on state = running and looking at Running Steps in the task details:
In this case, the "start_time" => nil indicates that the task was not picked up by Pulp, which usually means some issues with running the Pulp workers. See (see Sub-services status for more details).

One can also go to the Dynflow console for even more details: the suspended state means that the step is waiting for the external task to finish - the suspended state itself doesn’t have to indicate any error:

If you’re sure the underlying services are running fine, depending on the type of task, there might be a possibility to cancel the running step and possibly following dealing with paused tasks instead.
**Locking**

Foreman tasks provides a locking mechanism which is important to prevent the possibility of operations colliding that are being performed concurrently on the same resource (such as synchronizing and deleting a repository at the same time).

When trying to run an operation on a resource that another task is already running, one can get **Required lock is already taken by other running tasks**.

A locked resource is one where another task that is related to the same resource is already running. Thus, the task being attempted will result in that task being tried in **running or paused state**. This means that the error is triggered also in cases, where there is a task with unresolved failure (see dealing with paused tasks for more details).

In rare cases, it might be hard to get into the stopped state. There is a possibility to unlock the resource in the **running** task. This will switch the task into **stopped** state, freeing the resources for other tasks. **Caution: unlocking allows running other tasks to run on potentially inconsistent data, which might lead into further errors**. It's still possible to go to the Dynflow console and resume the tasks, even after using the unlock feature. There are two unlock-related buttons: **Unlock** and **Force Unlock**. The only difference between these two is the second one is allowed even when the task is in **running** state, and therefore is potentially even more dangerous than the **Unlock** button. See dealing with tasks running too long before attempting to use the **Force Unlock** option.

**Debug Certificate**

Debug certificates (also called Ueber Certificates) can be used to unlock all the content for a given Organization. These are meant to be used by sysadmins who are debugging issues with the Katello install.

**Generating a Debug Certificate**

To generate a debug certificate for a given Organization from the UI, navigate to the organizations page and click on the organization for which you want a debug certificate. Click on the button to generate and download the certificate as highlighted below:
To generate a debug certificate using the API see the API docs located on your server running at /apidoc .

In either case, you will get the Private Key and Certificate returned to you in a format such as:

Using Firefox to browse content

If you wish to use the certificate to browse content via Firefox, do the following:

1. Copy the contents of the above file from -----BEGIN RSA PRIVATE KEY----- to -----END RSA PRIVATE KEY----- inclusive to a file called key.pem
2. Copy the contents of the above file from -----BEGIN CERTIFICATE----- to -----END CERTIFICATE----- inclusive to a file called cert.pem
3. Run the following command to create a pkcs12 file:
   openssl pkcs12 -keypbe PBE-SHA1-3DES -certpbe PBE-SHA1-3DES -export -in cert.pem -inkey key.pem -out [NAME].pfx -name [NAME]
4. Provide a password when prompted.
5. Using the preferences tab, import the resulting pfx file into your browser (Edit->Preferences->Advanced Tab -> View Certificates -> Import)
6. Point your browser at http://[FQDN]/pulp/repos/[ORG_NAME]

To use curl to access the repository, you can provide --cert and --key options. Provided the cert is in ~/cert.pem and key in ~/key.pem, the following command will let you access any repository data in the organization. To check the access to a repository, checking the availability of repodata/repomd.xml is usually a good idea (make sure key.pem and cert.pem are "absolute paths" otherwise it silently fails):


Frequently Asked Questions

Can I use pulp-admin with Katello?
We do not encourage the use of pulp-admin because it has the potential to get data out of sync. However, pulp-admin can be useful when troubleshooting Katello.

1. Install needed packages

```bash
yum install -y pulp-admin-client pulp-rpm-admin-extensions
```

2. Edit `/etc/pulp/admin/admin.conf`

3. Uncomment the 'host:' line and add your server's hostname:

```
host: katello-hostname.example.com
```

4. Run `grep default_password /etc/pulp/server.conf` to lookup the admin password

```
sudo grep default_password /etc/pulp/server.conf
# default_password: default password for admin when it is first created; this
# default_password: rGox3G9QhICRD8fTsNR7FxqdgbvJHJSJ
```

5. Use pulp-admin by specifying the admin username and password:

```
pulp-admin -u admin -p rGox3G9QhICRD8fTsNR7FxqdgbvJHJSJ repo list
```

**Using pulp-admin without password**

Using the 'pulp-admin login' command does not function and is not supported with Katello in an attempt to limit access to the certificate authority generated at installation time.

Katello 3.0 generates a client cert at installation time which allows usage of pulp-admin without specifying the username and password. To use this:

1. `mkdir ~/.pulp`
2. Copy the public client cert and private key to a file together:

```
# sudo cat /etc/pki/katello/certs/pulp-client.crt /etc/pki/katello/private/pulp-client.key > ~/.pulp/user-cert.pem
```
3. Run pulp-admin without username and password:

```
pulp-admin repo list
```

**How can I sync a repository like Katello does directly from the console?**

Sometimes you want to debug why a synchronization of a repository from Katello is failing and rather than dig through log files and error messages it can often be easier to try to sync the repo with the "grinder" tool which is what Katello uses to download repositories. The tool can be ran from a terminal on your Katello server:

```
$ grinder yum --label=sync-test --url=https://fedorapeople.org/groups/katello/releases/yum/1.0/RHEL/6Server/x86_64/ 
  grinder.RepoFetch: INFO   fetchYumRepo() repo_label = sync-test, repo_url = https://fedorapeople.org/groups/katello/releases/yum/1.0/RHEL/6Server/x86_64/, basepath = /, verify_options = [] 
  grinder.RepoFetch: INFO   sync-test, https://fedorapeople.org/groups/katello/releases/yum/1.0/RHEL/6Server/x86_64/, Calling RepoFetch with: cacert=<None>, clicert=<None>, clikey=<None>, proxy_url=<None>, proxy_port=<3128>, proxy_user=<None>, proxy_pass=<NOT_LOGGED>, sslverify=<1>, max_speed=<None>, verify_options=<{}>, filter=<None> 
  grinder.RepoFetch: INFO   5 threads are active. 8 items left to be fetched 
  grinder.RepoFetch: INFO   4 threads are active. 4 items left to be fetched 
  grinder.RepoFetch: INFO   WorkerThread deleting ActiveObject 
  grinder.RepoFetch: INFO   3 threads are active. 3 items left to be fetched 
  grinder.RepoFetch: INFO   WorkerThread deleting ActiveObject 
  grinder.RepoFetch: INFO   Thread ending 
  grinder.ParallelFetch: INFO   WorkerThread deleting ActiveObject 
  grinder.ParallelFetch: INFO   Thread ending 

You now have a directory called sync-test off of your current working directory:

```
$ ls sync-test/
converge-ui-devel-0.8.3-1.el6.noarch.rpm
elasticsearch-0.18.4-13.el6.noarch.rpm
katello-1.0.6-1.el6.noarch.rpm
katello-agent-1.0.6-1.el6.noarch.rpm
katello-all-1.0.6-1.el6.noarch.rpm
katello-certs-tool-1.1.7-1.el6.noarch.rpm
lucene3-contrib-3.4.0-2.el6.noarch.rpm
repodata
rubygem-actionmailer-3.0.10-3.el6.noarch.rpm
...
```
Foreman 2.3.3 has been released! Follow the quick start to install it.
Foreman 2.2.2 has been released! Follow the quick start to install it.